Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: Evergreen HDMI audio success, need testers

  1. #11
    Join Date
    Dec 2011
    Posts
    2

    Default

    This is not safe.

    Running as a normal user, I also got segmentation fault, strace told me it was because of lack of permissions to a sysfs-file, so I ran it as root.

    Instant system lockup and after a reboot, my ethernet controller was broken.

    Rebooted the system, no change.

    Powered off the system, removed power cord, let it be for a while, powered on.

    Took about 15-20 seconds until it started after powering on, ethernet controller back.

    Tried again with another fglrx, same freeze.

    I have yet to be able to get the computer to boot (even just spin up the fans before bios).

    The power led just keeps blinking and sometimes manages to start spinning up the fans until it dies again and get stuck in a loop.

  2. #12
    Join Date
    Aug 2009
    Location
    Russe, Bulgaria
    Posts
    517

    Default

    Quote Originally Posted by Vincenzov View Post
    error segment :-(
    I guess this should read "Segmentation Fault"

  3. #13
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default

    hehehehe ok :-)

  4. #14
    Join Date
    May 2007
    Posts
    319

    Default

    Good work,

    so all the other drivers (intel, nouveau) seem to pass the ELD stuff into the hardware at some point, not sure if you can work out from radeontool or you need more tracing to see if this happens on ATI hw.

  5. #15
    Join Date
    Nov 2007
    Posts
    77

    Default

    If anyone needs the radeontool rpm, the latest version (1.6.2) is here: http://download.opensuse.org/reposit...nSUSE_Factory/

  6. #16
    Join Date
    Aug 2007
    Posts
    437

    Default

    I had an HD 5850 for a year, doing almost exclusive Windows gaming and when switching back to works on Linux, I sold it. One year after being sold, it is still not supported by Linux, it proved again that ATI is for Windows only and investing on hardware for the future support is the stupidest idea.

  7. #17
    Join Date
    Oct 2008
    Location
    Poland
    Posts
    183

    Default

    In case of lockup

    I've tried to prepare patch reading safe registers only. However it may happen some cards lock up when reading that registers from 0x0000 to 0xe000 range.

    After lock up you will probably need to power off the machine. In some rare cases taking power cable *and* battery is needed.

  8. #18
    Join Date
    May 2007
    Posts
    231

    Default

    Quote Originally Posted by Zajec View Post
    In case of lockup

    I've tried to prepare patch reading safe registers only. However it may happen some cards lock up when reading that registers from 0x0000 to 0xe000 range.

    After lock up you will probably need to power off the machine. In some rare cases taking power cable *and* battery is needed.
    It's completely family dependant (and also timing dependant) best is to not read this range, also the way radeontool hamer the register backbone doesn't help.

  9. #19
    Join Date
    Oct 2008
    Location
    Poland
    Posts
    183

    Default

    Quote Originally Posted by glisse View Post
    It's completely family dependant (and also timing dependant) best is to not read this range, also the way radeontool hamer the register backbone doesn't help.
    Unfortunately I can't limit the range of registers. I'm blindly looking for registers used for controlling HDMI (enabling HDMI mode, setting audio and video frames).
    Even worse: from the early results I've received, it seems DCE4 (early Evergreen) does not have HDMI registers in 0x0000...0xe000.

  10. #20
    Join Date
    Oct 2008
    Posts
    151

    Wink

    Nice, I'll get you the results of my HD5850 - might not be today but it'll be this week.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •