Results 1 to 2 of 2

Thread: Black instead of transparent in nikki (qt 4.7.4 + xf86-video-ati-git 20111215)

Hybrid View

  1. #1
    Join Date
    Nov 2011
    Posts
    3

    Default Black instead of transparent in nikki (qt 4.7.4 + xf86-video-ati-git 20111215)

    Hi, I'm on an arch linux 64bit system and running the game Nikki and the Robots (uses qt 4.7.4 for drawing) looks like this:



    The black boxes around the letters are supposed to be transparent.

    This also happens with xf86-video-ati 6.14.3 from the official arch extra/ repo. This does not happen when using catalyst.

    Can anybody reproduce this? Does anybody have an idea what the reason might be, how to find out the reason or how to fix this?

    FYI:
    Code:
    $ cat /etc/X11/xorg.conf.d/20-radeon.conf 
    Section "Device"
           Identifier  "Radeon"
    	Option "ColorTiling" "on"
    	Option "AccelMethod" "EXA"
    	Option "EnablePageFlip" "on"
    	Option "EXAVSync" "yes"
    EndSection
    Feh also displays images with black background, even though they have transparent bg.
    Gimp, gwenview, rox-filer and GQview display pngs with transparent bg correctly (chessboard bg).

  2. #2
    Join Date
    Nov 2011
    Posts
    3

    Default Removing ugly black borders in Nikki and the Robots

    The current solution against the ugly black blocky backgrounds in Nikki and the Robots is the following:
    • Install Qt 4.8
    • Delete following included files:
      • libQtCore.so.4
      • libQtGui.so.4
      • libQtOpenGL.so.4

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •