Results 1 to 3 of 3

Thread: Laptop warm and noisy under Linux

  1. #1
    Join Date
    Dec 2011
    Posts
    7

    Default Laptop warm and noisy under Linux

    Hello,

    I have the feeling that my laptop (lenovo y470) consumes much more power under linux that it does under Windows.
    The laptop is much warmer and the fans louder under linux, and I don't even use the Nvidia GPU, just the intel IGP.

    On Windows the laptop is cold and almost inaudible.

    Using the ondemand CPU governor decreases the CPU temperature by 5, which is of course a good start but not enough to keep the laptop cool and quiet.
    I have also added pcie_aspm=force to the kernel line in grub.conf

    I must admit I'm out of ideas here and therefore ask for your help.

    Here are a few commands results and info that might be helpful:

    Running Archlinux 64 bits (kernel 3.1.4-1) with KDE 4.7.3
    CPU: Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz

    cpufreq-info: http://pastebin.com/ZhxDSKzp
    sensors: http://pastebin.com/2MnKufk4
    lspci: http://pastebin.com/ZMYqXEcx
    dmesg: http://pastebin.com/DnMydsYL
    lsmod: http://pastebin.com/fDDVbR9y

    load average: 0.12, 0.09, 0.06

    Thanks in advance guys!

  2. #2
    Join Date
    Jul 2008
    Location
    Berlin, Germany
    Posts
    857

    Default

    It appears that your computer has switchable graphics/optimus. If you can, disable the discrete graphics in the BIOS. If not maybe you can disable it using vga_switcheroo.

    Also you can reduce the power consumption of Intel graphics with kernel 3.1 and i915.i915_enable_rc6=1 kernel parameter.

  3. #3
    Join Date
    Dec 2011
    Posts
    7

    Default

    Hello,

    Thanks for your answer:

    After what you told me, I started to explore how to deactivate the Nvidia GPU.

    I found this link:http://tautvidas.com/blog/2011/05/di...graphics-card/
    I followed the instructions (I just had to install linux-headers to make it work) and it worked like a charm!

    Now sensors reports:
    # sensors
    acpitz-virtual-0
    Adapter: Virtual device
    temp1: +56.0C (crit = +127.0C)

    coretemp-isa-0000
    Adapter: ISA adapter
    Physical id 0: +56.0C (high = +86.0C, crit = +100.0C)
    Core 0: +51.0C (high = +86.0C, crit = +100.0C)
    Core 1: +53.0C (high = +86.0C, crit = +100.0C)

    Which is a ~15 decrease compared to what I have shown yesterday. It should also considerably extends the battery life. Hurray!

    I will try to activate RC6 and will keep you up with the results.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •