Results 1 to 8 of 8

Thread: Linux Compatibility: M-Audio Revolution 7.1

  1. #1
    Join Date
    Jan 2007
    Posts
    15,102

    Default Linux Compatibility: M-Audio Revolution 7.1

    This is an entry for Phoronix LCH. Feel free to comment on the Linux compatibility for the M-Audio Revolution 7.1 in this thread.

    M-Audio Revolution 7.1



    Description: 7.1 channel sound card based on the Envy24HT chip
    Hardware Notes:

    alsa driver
    ice1724

    lspci -vv
    0000:01:0a.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Au
    dio Controller (rev 01)
    Subsystem: VIA Technologies Inc. M-Audio Revolution 7.1
    Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-

  2. #2
    Join Date
    Sep 2008
    Posts
    40

    Default

    Works for me on Ubuntu 8.10, but it doesn't work properly with hibernation. After waking up from hibernate, the sound is completely garbled and worthless. If anyone has tips on restarting the card after waking up I'd really appreciate.

  3. #3
    Join Date
    Jan 2009
    Posts
    117

    Default

    Quote Originally Posted by W3ird_N3rd View Post
    Works for me on Ubuntu 8.10, but it doesn't work properly with hibernation. After waking up from hibernate, the sound is completely garbled and worthless. If anyone has tips on restarting the card after waking up I'd really appreciate.
    Try rmmod for the kernel module of the driver before heibernate and modprobe after. That might be work around to make driver not to mess the state.

  4. #4
    Join Date
    Apr 2009
    Posts
    3

    Default

    I have been using an M-Audio Revolution 7.1 for a couple years on my linux box,
    and I use it as a Myth frontend/HD home theater. The card works great...

  5. #5
    Join Date
    Sep 2008
    Posts
    40

    Default

    Audio input does not appear to be functional unfortunately.

    I haven't tried fixing the hibernate issue, I've got too much hardware having trouble with hibernate. I just turn my computer off nowadays..

  6. #6
    Join Date
    Oct 2007
    Posts
    1,283

    Default

    If you have a spare partition or USB stick, you may want to try OSS4.

  7. #7
    Join Date
    Sep 2008
    Posts
    201

    Default

    this card works great under alsa for me

  8. #8
    Join Date
    Sep 2008
    Posts
    40

    Default

    As this thread comes up quickly on Google, I'll post it here.

    Using this card on Ubuntu, it sometimes randomly, for no reason whatsoever, becomes insanely loud in an instant, clipping beyond the edge of madness, ridiculously loud, deafening. If you're using head/earphones and have a weak hart, this sure can kill you.

    Whenever this happens, there is only one thing you can do: reload alsa.

    killall pulseaudio
    sudo alsa reload

    Or just reboot the computer, obviously. This problem occurs completely at random, there is nothing to be found in dmesg so I wouldn't know how to troubleshoot it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •