Page 20 of 21 FirstFirst ... 1018192021 LastLast
Results 191 to 200 of 208

Thread: AMD Catalyst 7.11 Linux Driver

  1. #191
    Join Date
    Nov 2007
    Posts
    29

    Default

    Code:
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Files"
    EndSection
    
    Section "Module"
    	Load "dbe"
    	Load "dri"
    	Load "glx"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"fr"
    	Option		"XkbVariant"	"latin9"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"		"/dev/input/mice"
    	Option		"Protocol"		"ImPS/2"
    EndSection
    
    Section "Device"
    	Identifier	"ATI RADEON X800pro"
    	Driver		"fglrx"
    	BusID		"PCI:1:0:0"
    	Option          "XAANoOffscreenPixmaps"   "true"
    EndSection
    
    Section "Monitor"
    	Identifier	"Samsung 913N"
    	Option		"DPMS"
    	HorizSync	30-81
    	VertRefresh	56-75
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"ATI RADEON X800pro"
    	Monitor		"Samsung 913N"
    	DefaultDepth	24
    	SubSection "Display"
    		Modes		"1280x1024" "1024x768"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice	"Generic Keyboard"
    	InputDevice	"Configured Mouse"
    EndSection
    
    Section "Extensions"
    	Option		"Composite"	"Enable"
    EndSection
    
    Section "DRI"
    	Group "video"
    	Mode  0666
    EndSection
    I can delete the module section, that would change nothing.
    With that configuration everything works fine excepted WoW, but I still have hope
    Last edited by Nevohteeb; 12-06-2007 at 05:49 PM.

  2. #192
    Join Date
    Sep 2007
    Location
    Athens-Hellas
    Posts
    255

    Default

    Hmm...

    Try some things...
    Under Device section add the following:

    Code:
    Option      "TexturedVideo" "True"
            Option      "Textured2D" "True"
            Option      "TexturedXrender" "True"
            Option      "UseFastTLS" "2"
            Option      "BackingStore" "True"
    And under Extensions add:

    Code:
    Option "RENDER" "Enable"
           Option "DAMAGE" "Enable"
    PS: If your X server hangs after you restart it then turn option "Textured2d" "False"

  3. #193
    Join Date
    Nov 2007
    Posts
    29

    Default

    Quote Originally Posted by djdoo View Post
    Hmm...

    Try some things...
    Under Device section add the following:

    Code:
    Option      "TexturedVideo" "True"
            Option      "Textured2D" "True"
            Option      "TexturedXrender" "True"
            Option      "UseFastTLS" "2"
            Option      "BackingStore" "True"
    And under Extensions add:

    Code:
    Option "RENDER" "Enable"
           Option "DAMAGE" "Enable"
    PS: If your X server hangs after you restart it then turn option "Textured2d" "False"
    Just one question (I'm still learning )

    What are those options for?

  4. #194
    Join Date
    Sep 2007
    Location
    Athens-Hellas
    Posts
    255

    Default

    The texture stuff are boosting performance to the parts of the driver each one reffers.. Video,2D,XRender by using modern accelleration features.
    Only TexturedVideo is officially documented the other 2 are testing let's say.

    The 2 Extensions options are extensions of the X server which can be used in various rendering situations.

    Backing Store now is an Xorg's mechanism to store images-visual stuff and not have to re-render them when they appear again.

  5. #195
    Join Date
    Nov 2007
    Posts
    29

    Default

    I tried all the options you mentioned and did not see any difference on my desktop environement nor under WoW.

    Nevertheless I did not check xorg.0.log to see if there are any warnings tho.

    I noticed I'm not the only one having the WoW bug with 8.42 and 7.11 drivers, but I guess this will be fixed with next release (hope so ^^)

    Anyway, I'll installed and configure compiz tonight to see if all the options you told me about are needed or not

  6. #196
    Join Date
    Nov 2007
    Posts
    5

    Default

    Quote Originally Posted by Nevohteeb View Post
    I noticed I'm not the only one having the WoW bug with 8.42 and 7.11 drivers, but I guess this will be fixed with next release (hope so ^^)
    I haven't seen the problem like you described on my Xpress 200 card since I installed WOW. I found an old config.WTF that fixed most of my problems. When I get home I'll PM you the file to see if that fixes your problems.

    Still I do encounter some problems in wow with the new driver. Random graphical errors still happen, but they don't seem to make the game unplayable and are barely noticeable.

    The biggest issues I encounter from my perspective are the games slows to a crawl after playing for about an hour. I believe this to be the product of the memory leak reported by many, but this problem only showed up after installing the new version of WINE, so what's to blame for this problem is anyones guess.

    The next is the minimap turning all white while indoors or in a dungeon. This has been reported at crossover office, and many other forums. Crossover reports this to be a issue with missing pthreads in the driver, though I don't know enough about that to verify the findings.

    Finally the game will only play in OpenGL mode at 800X600 resolution and going any higher then that causes the game to be to slow to play.

    At any rate, WOW for the first time is playable on my card and after a couple of bug fixing I suspect that these issues will be resolved.

    I'll send that config file this evening for you.

  7. #197
    Join Date
    Dec 2007
    Posts
    13

    Default

    This new release is far better than the previous one, in single-head I have like 400 More FPS with fgl_glxgears.
    BUT as long as the few glitch I have with dual-head are not resolved, I'll stick with the 8.40 release of the driver.

    The most annoying one is the very slow motion of the scroll bar in the secondary screen. I can almost follow line per line the change as it happen...

    The other bug wich show there is a "bug", when I launch fgl_glxgears on the secondary screen the windows open in the secondary screen, but the content of the window is showing in the primary screen.

  8. #198
    Join Date
    Nov 2006
    Posts
    72

    Default

    Hi,
    quick question:
    is AIGLX and composite supposed to work with xorg-1.4?
    with catalyst-7.11..
    thanks

  9. #199
    Join Date
    Oct 2007
    Location
    Brussels, Belgium
    Posts
    28

    Default

    Quote Originally Posted by slacker View Post
    Hi,
    quick question:
    is AIGLX and composite supposed to work with xorg-1.4?
    with catalyst-7.11..
    thanks
    doesn't work for me. Was working with previous version

  10. #200
    Join Date
    Oct 2007
    Posts
    54

    Default

    Is it a problem with xorg-1.4? With my xorg-1.3 it is working (slow, of course).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •