Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Latest 11.2 freezes my computer when display goes to sleep (Radeon HD 5830)

  1. #1
    Join Date
    Feb 2011
    Posts
    10

    Angry Latest 11.2 freezes my computer when display goes to sleep (Radeon HD 5830)

    Hello everyone,

    I've installed the latest 11.2 from ATI package (I've built .debs for Ubuntu Maverick), and when the screen goes to sleep (after the time set in gnome-power.preferences) the computer totally freezes.

    Is this happening to anyone else? It's a same because it's the first version that removes the vertical flickering while watching videos.

    Thanks in advance!

    PS: My card is a Radeon HD 5830 Mobility.

  2. #2
    Join Date
    Feb 2011
    Posts
    10

    Default

    I've forgot to say that the "Tear Free Desktop" option is enabled.

  3. #3
    Join Date
    Jan 2010
    Location
    Portugal
    Posts
    945

    Default

    You mean 11.1 right? My desktop computer also freezes when going into hibernation sometimes, but not always. I still couldn't find what could be causing it, but disabling desktop effects might help. HD4200 here.

  4. #4
    Join Date
    Jul 2007
    Posts
    56

    Default

    Hi!
    A while back I had occasional freezes when waking up from suspend. That freeze actually was not complete freeze. I have learned to try to ssh to freezed box since "good and trouble-free " nvidia days So Ihave a habbit to leave ssh server opend on my laptop, which basically is rarely needed.
    It was possible to ssh and it turned out that acpid actually is the cause for freeze, Xorg froze because acpid was stuck. Nothing worked, no keyboard no nothing computer appears to be dead, but sticking network cable in worked When I killed acpid process with -9 computer woke up instantly... Everything worked again.
    Since I discovered that, I have no acpid on my system and it's not neccessary for me as well...
    My suggestion is to install ssh and when it freezes try to ssh into it and see what happens there, kill acpid and see whether it helps

    regards
    Kirurgs

  5. #5
    Join Date
    Jul 2007
    Posts
    56

    Default

    Damned one minute
    I tried to add: HD3650, 2.6.37 (custom), cat 11.1, x86_64

  6. #6
    Join Date
    Jan 2010
    Location
    Portugal
    Posts
    945

    Default

    @Kirurgs When I ssh into my system I actually see xorg with 100% cpu usage. Never noticed acpid though. I could swear I disabled acpid some time ago, but I'm not really sure. I'll try that tomorrow and see if it helps. Thanks for the tip.

  7. #7
    Join Date
    Jul 2007
    Posts
    56

    Default

    Please make sure you kill only acpid process, killall -9 acpid...
    But, I don't get xorg consuming 100% CPU with acpid stuck, that was at nvidia time and then it meant - kaput I could only shutdown system properly...
    So killing acpid might not help and you'll have to revert to last working fglrx...

    P.S. I must say that as opposite to my quadro nvidia card I had previously, I have never encountered PM problems with Radeons, whether it's clock freqs, suspend, hibernate - everything worked with every catalyst version I tried.

  8. #8
    Join Date
    Feb 2011
    Posts
    10

    Default

    First thing, I meant 11.1. Sorry for the mistake.

    Now, when I said "sleep" I meant the sleep in gnome-power-preferences (see attached screenshot). That's the "screen goes to black after some minutes" functionality.

    And I don't have acpid installed on my computer.

    Any ideas? Anyone with the same problem? It's a shame, because it's the first driver that seems to draw everything correctly on screen.


  9. #9
    Join Date
    Jan 2010
    Location
    Portugal
    Posts
    945

    Default

    I'm using KDE with an intel GPU and what happens is that when the laptop's screen turns itself off (xset dpms force off maybe?) it doesn't come back up by itself. What I have to do is close the lid and open it again, and then (after the pc suspends and resumes) the scren is back again. I always thought that was due to my messing around with the acpi scripts. Any chance you got the same problem?

    On my desktop with Radeon HD4200 I get the freezes only from time to time after resuming from hibernation. It's not all the time. I already tried killing acpid but it didn't help, just like Kirurgs predicted. The thing is I only started using hibernation recently, so I have no idea if there is even a fglrx version that works, or if it's fglrx's fault to begin with. I'll have to try the OSS drivers first.

  10. #10
    Join Date
    Feb 2011
    Posts
    1

    Default

    Same here. I think the problem is connect to the screen being locked. Go to alt-f2 , gconf-editor, and gnome-desktop, should be an option to disable screen lock. Also make sure suspend/hiberate are checked there. After I disabled the screen lock the problem went away.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •