Page 105 of 111 FirstFirst ... 55595103104105106107 ... LastLast
Results 1,041 to 1,050 of 1109

Thread: "Ask ATI" dev thread

  1. #1041
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,386

    Default

    Quote Originally Posted by ungoliant View Post
    I just upgraded to Catalyst 10.6, and was very happy to see how Direct2D has improved. I have now decent 2d performance, wich is very nice. But, the only 3 games I play, Quake Live, Savage 2, and Heroes of Newerth, have all stopped working. Savage 2 and HoN don't even start, and Quake Live does, but shows really broked graphics with white skins and surfaces.

    This is really frustrating, since I have to choose between a fluent desktop or a working game station, and I simply use both...

    Are you aware of this problem? any ETA on fixing OpenGL (which i'm guessin is the problem here)?

    Thanks.
    I don't *think* anyone has reported 3D problems that serious with 10.6, but I could be wrong. Are you sure you did a complete uninstall of the previous driver before installing the new one ? If you don't then you can end up with a mix of old and new files and that almost always causes some kind of Bad Thing.

  2. #1042
    Join Date
    May 2010
    Posts
    29

    Default

    Quote Originally Posted by bridgman View Post
    I don't think we ever supported >2 displays per card, unless some of the displays were showing the same image. AFAIK the Evergreen series are the first ATI products to support >2 independent displays per GPU.

    Or are you talking about a dual-GPU card such as one of the FireMV products ?
    One would expect that supporting more than two screens in the 5870 eye6 card would be a priority for the driver team. I sure thought it would have been since I spent so much money on it.

    Is there any indication on when this will be supported?

  3. #1043
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,386

    Default

    Quote Originally Posted by emergence View Post
    AMD/ATI linux devs, there is a bug related to the drivers regarding tearing. The bug still exists with catalyst 10.6. Any ideas as to when it will be resolved?

    The bug was opened 1.5+ years ago:
    https://bugs.launchpad.net/ubuntu/+s...er/+bug/303697

    I myself have an HD5850 and with compiz and metacity I'm getting tearing when dragging windows. My previous post alluded to this same issue and was told that 2D rendering was being rewritten. Catalyst 10.6 has not resolved my issue.
    Emergence, the bug ticket you linked to has nothing in common with the problem you are describing other than the word "tearing". Tearhing in Xv is a different issue from the "tearing while moving window" issue you are discussing.

    There is a recent ticket on the driver bug tracker (#1834) but it doesn't really have any useful information at all (eg no indication of video vs. desktop interaction, no steps to reproduce, no system settings), so it's effectively useless. I haven't seen any bug tickets referring to the problem you are describing, which I understand to be tearing on window edges and contents when dragging them around the screen ?

    For what it's worth, I'm not aware of any drivers which sync 2D operations by default since the performance penalty can be significant. The radeon driver has an EXAVsync optionwhich can be enabled in xorg.conf, but that was the first such option I had seen.

  4. #1044
    Join Date
    Oct 2007
    Posts
    321

    Default

    1) Would it be possible to add an option silence NAN values on OpenGL when pertaining to NAN values, because the opengl specification on floating point values does not specifically specify using IEEE754 floating point values to represent numbers.

    case in point would be the function, glPointSize... the specification specifically states that it will return GL_INVALID_VALUE when the value is less than or equal 0. However, the ati driver will return this on any positive nan signal value. (This will help with wine in particular)


    2) Would it be possible to have all opengl specific matrixies default to the identity matrix when initializing opengl. (spotted with xbmc, but still wouldn't hurt to address this, and it could fix problems with older games, and specifically effects shaders)

    3) The behaviour of GLX_SGI_video_sync is sub optimal, and confuses a lot of programs into thinking that they are missing frames when they are not. would it be possible to change the behavior to better signify that nothing no vblanks are missed? (xbmc again, unfixed)

    As a note, the behavior of returning 1 when nothing is rendered, and 3 when something is rendered causes a lot of problems when detecting missed frames.

    4) Another video sync question, but will the ati driver ever pick up support for the extension GLX_OML_sync_control?

    5) Is it possible to add an configuration to silence the Success error output when compiling and linking glsl completely, because xbmc, wine and other programs that utilize glsl wind up having to use special spam filters that waste cpu cycles to filter this output.

  5. #1045
    Join Date
    Sep 2008
    Posts
    989

    Default

    Quote Originally Posted by bridgman View Post
    I don't *think* anyone has reported 3D problems that serious with 10.6, but I could be wrong. Are you sure you did a complete uninstall of the previous driver before installing the new one ? If you don't then you can end up with a mix of old and new files and that almost always causes some kind of Bad Thing.
    I can reproduce this problem, and so can anyone with an HD5000 series GPU running Catalyst 10.5 or later. We're reporting 3D problems that serious with 10.6 right now.

    Can you please look into this? If this doesn't get triaged, then it could end up stuck in "blame ping-pong" for a year or two, while S2Games blames ATI and ATI blames S2Games, back and forth forever. All us poor users can do is beg you guys to look at this. It's extremely easy to reproduce -- trivially easy, even -- with any HD5000 series GPU running Catalyst 10.5 or 10.6. Just start Savage 2 or HoN and they simply crash in the userland part of fglrx. They don't in 10.4 or earlier.

  6. #1046
    Join Date
    Oct 2007
    Posts
    912

    Default

    Quote Originally Posted by allquixotic View Post
    I can reproduce this problem, and so can anyone with an HD5000 series GPU running Catalyst 10.5 or later. We're reporting 3D problems that serious with 10.6 right now.

    Can you please look into this? If this doesn't get triaged, then it could end up stuck in "blame ping-pong" for a year or two, while S2Games blames ATI and ATI blames S2Games, back and forth forever. All us poor users can do is beg you guys to look at this. It's extremely easy to reproduce -- trivially easy, even -- with any HD5000 series GPU running Catalyst 10.5 or 10.6. Just start Savage 2 or HoN and they simply crash in the userland part of fglrx. They don't in 10.4 or earlier.
    Just to make absolutely certain (because you didn't state this): did you completely remove the old versions of catalyst before installing the newer ones?
    Might want to check in /etc to make certain that all old files are really removed as well.

  7. #1047
    Join Date
    Sep 2008
    Posts
    989

    Default

    Quote Originally Posted by mirv View Post
    Just to make absolutely certain (because you didn't state this): did you completely remove the old versions of catalyst before installing the newer ones?
    Might want to check in /etc to make certain that all old files are really removed as well.
    I think it's safe to say that testing this on a clean install of Fedora 13 (which doesn't even offer any binary drivers out of the box) is close enough to ensuring that I removed all previous versions.

    I also verified that this bug is not related to the ATI 2d Acceleration Architecture: I disabled and enabled the direct2daccel flag various times (restarting X each time) to see if it made a difference. It didn't.

    One last test: it's orthogonal to whether you have a compositing manager enabled.

    However, interestingly, both the Unigine Heaven demo and Second Life run reasonably well (some weirdness with Unigine, but at least it runs). So the drivers aren't "totally broken", it's just a very specific piece of it. In other words, a fairly isolated bug.

  8. #1048
    Join Date
    Jun 2010
    Posts
    61

    Default

    Quote Originally Posted by bridgman View Post
    Emergence, the bug ticket you linked to has nothing in common with the problem you are describing other than the word "tearing". Tearhing in Xv is a different issue from the "tearing while moving window" issue you are discussing.

    There is a recent ticket on the driver bug tracker (#1834) but it doesn't really have any useful information at all (eg no indication of video vs. desktop interaction, no steps to reproduce, no system settings), so it's effectively useless. I haven't seen any bug tickets referring to the problem you are describing, which I understand to be tearing on window edges and contents when dragging them around the screen ?

    For what it's worth, I'm not aware of any drivers which sync 2D operations by default since the performance penalty can be significant. The radeon driver has an EXAVsync optionwhich can be enabled in xorg.conf, but that was the first such option I had seen.
    Thanks for following up on this. I'm going to create a new topic in this forum to get some input as to who suffers from the issues I'm suffering from. I understand that there are no bug tickets open regarding tearing when dragging windows or a single horizontal tear on my second screen. Once I get some input from people, I'll create a bug report for each of these two issues.

  9. #1049
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by noobish View Post
    One would expect that supporting more than two screens in the 5870 eye6 card would be a priority for the driver team. I sure thought it would have been since I spent so much money on it.

    Is there any indication on when this will be supported?
    catalyst 10-7 support more than two screens 10-7 supports 24 screens.

  10. #1050
    Join Date
    Sep 2008
    Posts
    68

    Default

    Quote Originally Posted by Qaridarium View Post
    catalyst 10-7 support more than two screens 10-7 supports 24 screens.
    I really hope your right on this one. Maybe rotation for RHEL 5 Randr 1.1 is supported as well?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •