Page 50 of 111 FirstFirst ... 40484950515260100 ... LastLast
Results 491 to 500 of 1109

Thread: "Ask ATI" dev thread

  1. #491
    Join Date
    Oct 2007
    Location
    Under the bridge
    Posts
    2,099

    Default

    Oops, wrong thread.

    Anyway, two questions for bridgman:

    1. Will fglrx RDR use the DRI2 and GEM/TTM infrastructure or will it take nvidia's route and rip everything out?

    2. Can we expect OpenCL on Linux?
    Last edited by BlackStar; 01-30-2009 at 06:13 AM.

  2. #492
    Join Date
    Jul 2008
    Posts
    1,712

    Default

    Realnic does not like thinking. He does like trolling.

  3. #493
    Join Date
    Aug 2008
    Location
    Netherlands
    Posts
    225

    Default

    Quote Originally Posted by energyman View Post
    Realnic does not like thinking. He does like trolling.
    ow, just deleted my message because I found myself being unconstructive... but since you already replied on my post:

    Quote Originally Posted by RealNC View Post
    After battling with 9.1, I have another question: Why don't you sell ATI to someone who has a clue about writing drivers? No, no, I'm not joking. That would really help.
    They opensourced it... THINK about this... read back your posts... stupid right?
    Last edited by tmpdir; 01-30-2009 at 07:37 AM.

  4. #494
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,282

    Default

    Quote Originally Posted by BlackStar View Post
    1. Will fglrx RDR use the DRI2 and GEM/TTM infrastructure or will it take nvidia's route and rip everything out?
    We were planning to use DRI2, but as I understand it current thinking is to bypass it and do our own implementation. We already have a good memory manager and do not plan to replace that with GEM/TTM.

    Quote Originally Posted by BlackStar View Post
    2. Can we expect OpenCL on Linux?
    I don't know for sure but I expect so. Linux is an important part of our Stream solutions and we expect OpenCL to become a core part of Stream.

  5. #495
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    4,729

    Default

    There is no support for a1 surfaces in the open drivers & EXA, and seemingly won't be for months. Does frglx support it?

  6. #496
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    364

    Default

    Quote Originally Posted by bridgman View Post
    We were planning to use DRI2, but as I understand it current thinking is to bypass it and do our own implementation. We already have a good memory manager and do not plan to replace that with GEM/TTM.
    If we are already at it, are you planning to enable KMS in fglrx in the same way or will that remain an OSS-only feature?

  7. #497
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by bridgman View Post
    Can you post your log please ?

    I probably don't need to say this, but "boot to black screen" is not a bug, just perhaps the most common symptom that *something* (probably specific to a distro release and hardware configuration) has gone wrong.
    i have the black screen to on a hd4350 with the 8.12 and 9.1 and 9.2beta only 8.11 works (but need 1-3 times to boot right)...

    newest debian sid radeon works like vesa

    "BlackScreen" by booting the system. only init 3 mode boots right.

    my system is :

    ass@ass:~$ infobash -v3
    Host/Kernel/OS "ass" running Linux 2.6.28-6-generic i686 [ sidux 2008-04 Πόντος - kde-lite - (200812222321) ]
    CPU Info (1) AMD Engineering Sample 1024 KB cache flags( sse3 nx lm svm ) clocked at [ 2600.000 MHz ]
    (2) AMD Engineering Sample 1024 KB cache flags( sse3 nx lm svm ) clocked at [ 2600.000 MHz ]
    (3) Dual-Core AMD Opteron 8218 1024 KB cache flags( sse3 nx lm svm ) clocked at [ 1000.000 MHz ]
    (4) Dual-Core AMD Opteron 8218 1024 KB cache flags( sse3 nx lm svm ) clocked at [ 1000.000 MHz ]
    Videocard ATI Device 954f X.Org 1.4.2 [ 1920x1200@60.0hz ]
    Network cards 2x Broadcom NetXtreme BCM5754 Gigabit Ethernet PCI Express
    Processes 149 | Uptime 1:23 | Memory 537.3/3296.1MB | HDD ATA SAMSUNG SP2014N,ATA SAMSUNG HD103UJ Size 1200GB (87%used) | Client Shell | Infobash v3.05

    my vga is an hd4350 256mb on PCIe my kernel are kano's kernel a Kubuntu 9.04 backbort..

  8. #498
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,282

    Default

    Yeah, that makes sense. AFAIK we are currently supporting 8.10 but not the prerelease 9.04 versions yet. For pre-release distros you are probably better off pulling the latest open source drivers.

  9. #499
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by bridgman View Post
    Yeah, that makes sense. AFAIK we are currently supporting 8.10 but not the prerelease 9.04 versions yet. For pre-release distros you are probably better off pulling the latest open source drivers.
    i dont use 9.04... i use debian5/sid/sidux---

    on debian kernel 2.6.26 = blackscreen

    on kanos 2.6.28 = blackscreen

    ...

  10. #500
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,282

    Default

    OK, maybe I'm confused. Your post said a Kubuntu 9.04 backport, what am I missing ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •