Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: radeonHD available for download

  1. #1
    Join Date
    Dec 2006
    Posts
    82

    Default radeonHD available for download

    http://cgit.freedesktop.org/xorg/dri...ideo-radeonhd/

    is now accessible to the public.

    you can download it with:
    git clone git://anongit.freedesktop.org/xorg/driver/xf86-video-radeonhd

    Code:
    $ ./autogen.sh --prefix=/usr
    $ make
    # make install
    That code built on my system without error. Haven't had a chance to try it; I am in the middle of some CS homework; and will try it after.

    You'll also need install the build dependencies. (xorg-sdk definitely)

  2. #2
    Join Date
    Dec 2006
    Posts
    82

    Default

    It doesn't look like all chipsets are supported yet. If you chipset isn't a certain one the driver throws an X error and stops the server startup.

    The Mobility X1300 isn't supported. Looking at ati_id.c there are 4 different PCI Ids for such a card; not sure which mine is. If someone knows how to get that it'd be appreciated.

    Also it mentions a mailing list; anyone know where that mailing list is and where to subscribe?

  3. #3
    Join Date
    Aug 2007
    Posts
    53

    Default

    it doesn't work on my mobility x1600

    I can paste Xorg.log if it helps

  4. #4
    Join Date
    Sep 2006
    Location
    PL
    Posts
    913

    Default

    i'll wait two weeks and try it out.

  5. #5
    Join Date
    Sep 2007
    Posts
    26

    Default

    Quote Originally Posted by koolmanoncampus View Post
    Also it mentions a mailing list; anyone know where that mailing list is and where to subscribe?
    radeonhd@opensuse.org
    and/or:
    http://bugs.freedesktop.org (radeonhd component)

  6. #6
    Join Date
    May 2007
    Location
    Nurnberg.
    Posts
    334

    Default

    Quote Originally Posted by koolmanoncampus View Post
    It doesn't look like all chipsets are supported yet. If you chipset isn't a certain one the driver throws an X error and stops the server startup.

    The Mobility X1300 isn't supported. Looking at ati_id.c there are 4 different PCI Ids for such a card; not sure which mine is. If someone knows how to get that it'd be appreciated.

    Also it mentions a mailing list; anyone know where that mailing list is and where to subscribe?
    It is not the chipset which isn't supported, it is the card which isn't supported. We need to carry around card specific information such as the connector layout. Sadly atombios provides insufficient information.

  7. #7
    Join Date
    May 2007
    Location
    Nurnberg.
    Posts
    334

    Default

    Quote Originally Posted by mile View Post
    it doesn't work on my mobility x1600

    I can paste Xorg.log if it helps
    radeonhd@opensuse.org please

    There might be some delay, as many people need to see their cards supported.

  8. #8
    Join Date
    May 2007
    Location
    Nurnberg.
    Posts
    334

    Default

    Quote Originally Posted by yoshi314 View Post
    i'll wait two weeks and try it out.
    Try now, your card will only get support after someone reports it.

  9. #9
    Join Date
    Dec 2006
    Posts
    82

    Default

    Quote Originally Posted by libv View Post
    It is not the chipset which isn't supported, it is the card which isn't supported. We need to carry around card specific information such as the connector layout. Sadly atombios provides insufficient information.
    K.. I misread the xlog error; sorry for the confusion.

    I sent in my xorg log nontheless.

  10. #10
    Join Date
    Jul 2007
    Posts
    27

    Default

    Quote Originally Posted by libv View Post
    It is not the chipset which isn't supported, it is the card which isn't supported. We need to carry around card specific information such as the connector layout. Sadly atombios provides insufficient information.
    So will the RadeonHD driver actually support the R500 (520 etc) series of cards as well? It seems like only R600 support is being worked on. If it will what can a non-programmer like me to do help? I have a Mobility X1400.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •