I'm reading the threads out here... people having problems with video tearing, Firefox flickering, etc. I'm somewhat stunned at that, because I can't even get HD2600XT to start X without freezing the machine!!

First I had an Sapphire HD2600XT 256 Mb AGP. I'm running Debian Unstable. The machine is a vanilla MSI KT4 Ultra mobo, Athlon XP2100+ CPU, AGP 8X, 2.5 Gb RAM, parallel ATA disk. I tried with the drivers already in Debian, and also 8.43 from the ATI site. The best I got was X, then Gnome startup, then when I go to the top menubar (I have it auto-hidden), as the bar descends, the machine hard-locks... so can't remote login, no keyboard input, can't switch to virtual console. I have to either hard-reset or Alt-Sysrq-b.

So I got a VisionTek HD2600XT 512 MB. Now it hard-locks while starting X, at the grey weave pattern, that is, the cursor changes from an X to an arrow, and then it is locked.

I've tried changing the AGP memory settings in the BIOS... locks at 256 Mb and 128 Mb, and X won't even start at 64 Mb. Tried commenting out all settings so they default in the Device section in xorg.conf. I feel like I'm missing something big, because compared to the kinds of problems everyone is having, mine seem to be fundamental, given that the HD2600 is not a very old card!

So I'd appreciate very much some hints so the thing can startup and I can run a browser or something, let alone MythTV. A working xorg.conf would be welcome too.

I've been playing with X for years now, I started when video cards with 2 Mb RAM were high end. Anyone remember Chips & Technologies onboard video? This by far is the most unusable driver I've used out of the box.