Results 1 to 5 of 5

Thread: Ibm T60, Dell 2007FP, Ati 8.30.3, but only clone mode :-(

  1. #1
    Join Date
    Jan 2007
    Posts
    2

    Default Ibm T60, Dell 2007FP, Ati 8.30.3, but only clone mode :-(

    Hi

    Michael you posted earlier some xorg config for a ibm t60, and that leads me to that you maybe have access to such one!

    My problem is that have a Ibm T60 with a x1400 mobility and ati drivers 8.30.3 (running gentoo, but that is not important).

    I have my laptop connected to a Dell 2007FP flat panel screen. Its connected with the vga cable.

    My problem is that I can't get big desktop mode to work! Every time I login it is in clone mode... Im running Gnome 2.16 ... but that should not be a problem (I think :-)

    I have tried several setup from the other posts here, but the same result every time. Have you or somebody else seen/found a solution for this?

    /Anders

  2. #2

    Default

    Yes, Phoronix has a Lenovo T60 with Mobility X1400.

    What happens when you try to enable Big Desktop mode? What does your xorg.conf look like? Are you using any pairmodes or anything like that? Have you tried the latest 8.32.5 display drivers?

  3. #3
    Join Date
    Jan 2007
    Posts
    2

    Default

    I found my problem, it was gnome that forced the clone setup. I tried to use fluxbox with my old setup and there it was, a big desktop. I then ereased my gnome config and now I have a working big desktop on gnome again!

    My setup looks loke this:
    Section "ServerLayout"
    Identifier "Main Layout"
    Screen 0 "Screen 0" 0 0
    InputDevice "Mouse0" "CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Files"
    FontPath "/usr/share/fonts/100dpi/"
    FontPath "/usr/share/fonts/75dpi/"
    FontPath "/usr/share/fonts/artwiz"
    FontPath "/usr/share/fonts/corefonts"
    FontPath "/usr/share/fonts/freefont"
    FontPath "/usr/share/fonts/intlfonts"
    FontPath "/usr/share/fonts/mathematica-fonts"
    FontPath "/usr/share/fonts/misc/"
    FontPath "/usr/share/fonts/mplus/"
    FontPath "/usr/share/fonts/sharefonts"
    FontPath "/usr/share/fonts/terminus"
    FontPath "/usr/share/fonts/ttf-bitstream-vera"
    FontPath "/usr/share/fonts/ttf-gentium"
    FontPath "/usr/share/fonts/Type1/"
    FontPath "/usr/share/fonts/unfonts"
    FontPath "/usr/share/fonts/unifont"
    FontPath "/usr/share/fonts/vlgothic/"
    FontPath "/usr/share/fonts/TTF/"
    FontPath "/usr/share/fonts/CID/"
    EndSection

    Section "Module"
    Load "extmod"
    Load "dri"
    Load "dbe"
    Load "record"
    Load "xtrap"
    Load "glx"
    Load "type1"
    Load "freetype"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "xkbLayout" "dk"
    Option "xkbRules" "xorg"
    EndSection

    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Monitor"
    Identifier "Monitor 0"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "ATI Graphics Adapter 0"
    Driver "fglrx"
    Option "DesktopSetup" "horizontal"
    Option "ForceMonitor" "lvds,crt1"
    Option "VideoOverlay" "on"
    Option "OverlayOnCRTC2" "on"
    Option "UseFastTLS" "2"
    Option "EnablePrivateBackZ" "on"
    Option "UseInternalAGPGART" "no"
    Option "Centermode" "off"
    Option "OpenGLOverlay" "off"
    Option "PseudoColorVisuals" "off"
    Option "HSync2" "30-81"
    Option "VRefresh2" "56-76"
    Option "Mode2" "1400x1050"
    BusID "PCI:1:0:0"
    EndSection

    Section "Screen"
    Identifier "Screen 0"
    Device "ATI Graphics Adapter 0"
    Monitor "Monitor 0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "DRI"
    Mode 0666
    EndSection


    Section "ServerFlags"
    Option "AIGLX" "off"
    EndSection


    Section "Extensions"
    Option "Composite" "Disable"
    Option "XVideo" "Enable"
    EndSection


    Is there a way to make my second screen run 1600x1200 instead of the default 1400x1050 ??

  4. #4

    Default

    Quote Originally Posted by abachn View Post
    Is there a way to make my second screen run 1600x1200 instead of the default 1400x1050 ??
    Try looking at the pairmodes in aticonfig.

  5. #5
    Join Date
    Jan 2007
    Posts
    1

    Default

    Quote Originally Posted by Michael View Post
    Try looking at the pairmodes in aticonfig.
    Did you manage to get this working? I am stuck on a similar prblem with my T60.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •