Results 1 to 6 of 6

Thread: cant enable dri with 7.11! help

  1. #1
    Join Date
    Oct 2007
    Posts
    13

    Default cant enable dri with 7.11! help

    i installed 7.11 on opensuse 10.2 64 bit, and followed the exact same instructions as i did with my 10.3 install (64bit) and dri wont enable on 10.2.

    here is my xorg.0.log:

    Code:
    (II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
    (WW) fglrx(0): could not detect X server version (query_status=-3)
    (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized. 
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed!                  *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO)             *
    (WW) fglrx(0): * no 3D acceleration available                *
    (WW) fglrx(0): ********************************************* *
    and after that aiglx complains about not having dri enabled...
    i built the module by hand in /lib/modules/fglrx which worked on 10.3

    any ideas would be great! thanks

    xorg.conf:
    Code:
    # /.../
    # SaX generated X11 config file
    # Created on: 2007-05-10T23:53:25-0500.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "ServerLayout"
    	Identifier     "Layout[all]"
    	Screen      0  "aticonfig-Screen[0]" 0 0
    	InputDevice    "Keyboard[0]" "CoreKeyboard"
    	InputDevice    "Mouse[1]" "CorePointer"
    	InputDevice    "Mouse[3]" "SendCoreEvents"
    	Option	    "Clone" "off"
    	Option	    "Xinerama" "off"
    EndSection
    
    Section "Files"
    	InputDevices   "/dev/gpmdata"
    	InputDevices   "/dev/input/mice"
    	FontPath     "/usr/share/fonts/misc:unscaled"
    	FontPath     "/usr/share/fonts/local"
    	FontPath     "/usr/share/fonts/75dpi:unscaled"
    	FontPath     "/usr/share/fonts/100dpi:unscaled"
    	FontPath     "/usr/share/fonts/Type1"
    	FontPath     "/usr/share/fonts/URW"
    	FontPath     "/usr/share/fonts/Speedo"
    	FontPath     "/usr/share/fonts/PEX"
    	FontPath     "/usr/share/fonts/cyrillic"
    	FontPath     "/usr/share/fonts/latin2/misc:unscaled"
    	FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
    	FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
    	FontPath     "/usr/share/fonts/latin2/Type1"
    	FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
    	FontPath     "/usr/share/fonts/baekmuk:unscaled"
    	FontPath     "/usr/share/fonts/japanese:unscaled"
    	FontPath     "/usr/share/fonts/kwintv"
    	FontPath     "/usr/share/fonts/truetype"
    	FontPath     "/usr/share/fonts/uni:unscaled"
    	FontPath     "/usr/share/fonts/CID"
    	FontPath     "/usr/share/fonts/ucs/misc:unscaled"
    	FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
    	FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
    	FontPath     "/usr/share/fonts/hellas/misc:unscaled"
    	FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
    	FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
    	FontPath     "/usr/share/fonts/hellas/Type1"
    	FontPath     "/usr/share/fonts/misc/sgi:unscaled"
    	FontPath     "/usr/share/fonts/xtest"
    	FontPath     "/opt/kde3/share/fonts"
    	FontPath     "unix/:7100"
    EndSection
    
    Section "Module"
    	Load  "dbe"
    	Load  "type1"
    	Load  "freetype"
    	Load  "extmod"
    	Load  "glx"
    	Load  "v4l"
    	Load  "dri"
    EndSection
    
    Section "ServerFlags"
    	Option	    "AllowMouseOpenFail" "on"
    	Option	    "AIGLX" "true"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard[0]"
    	Driver      "kbd"
    	Option	    "Protocol" "Standard"
    	Option	    "XkbLayout" "de"
    	Option	    "XkbModel" "pc104"
    	Option	    "XkbRules" "xfree86"
    	Option      "XkbVariant" "nodeadkeys"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse[1]"
    	Driver      "synaptics"
    	Option	    "Buttons" "5"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "Emulate3Buttons" "on"
    	Option	    "HorizScrollDelta" "0"
    	Option	    "InputFashion" "Mouse"
    	Option	    "Name" "Synaptics;Touchpad"
    	Option	    "Protocol" "explorerps/2"
    	Option	    "SHMConfig" "on"
    	Option	    "Vendor" "Sysp"
    	Option	    "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse[3]"
    	Driver      "mouse"
    	Option	    "Buttons" "5"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "Name" "ImPS/2 Generic Wheel Mouse"
    	Option	    "Protocol" "explorerps/2"
    	Option	    "Vendor" "Sysp"
    	Option	    "ZAxisMapping" "4 5"
    EndSection
    
    Section "Modes"
    	Identifier     "Modes[0]"
    	ModeLine     "1024x768" 64.1 1024 1080 1184 1344 768 769 772 795
    	ModeLine     "1024x768" 55.0 1024 1072 1104 1184 768 771 775 790 +hsync -vsync
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]"
    	Driver      "fglrx"
    	Option      "FSAAEnable" "off"
    	Option      "Capabilities" "0x00000000"
    	Option      "VideoOverlay" "on"
    	Option      "OpenGLOverlay" "off"
    	Option      "FSAAScale" "0"
    	Option      "XAANoOffscreenPixmaps" "true"
    EndSection
    
    Section "Extensions"
    	Option "DAMAGE" "true"
    	Option "Composite" "true"
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]"
    	Device     "aticonfig-Device[0]"
    	Monitor    "aticonfig-Monitor[0]"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Group        "video"
    	Mode         0660
    EndSection

  2. #2
    Join Date
    Aug 2007
    Posts
    6,615

    Default

    It seems your kernel changed via update but the kernel module was not updated. Compile the kernel module again.

  3. #3
    Join Date
    Oct 2007
    Posts
    13

    Default

    i have recompiled it, but no love. is it possible, because i have multiple kernels installed, that it is compiling and installing against the wrong kernel?

    ill make it again, and update with the results

  4. #4
    Join Date
    Oct 2007
    Posts
    13

    Default

    yea no love in any of my kernels. i recompiled for all of them and it still gives the same error.
    I did notice however, during boot it will try to start "atieventsd" and complains that the file isnt found... is this something left over from my 8.40 install?

    edit: an interesting thing has shown up... when dri is trying to be started, the log says that it is loading the 8.40 module, even though i most definitley uninstalled it before installing 7.11. thoughts????
    Last edited by gummybearx; 12-05-2007 at 12:57 AM.

  5. #5
    Join Date
    Oct 2007
    Posts
    1,269

    Default

    (WW) fglrx(0): could not detect X server version (query_status=-3)
    My spidey sense tells me you need a newer version of X.

  6. #6
    Join Date
    Oct 2007
    Posts
    13

    Default

    yea im actually up to date with the xorg7.3 repo in opensuse buildservice.... i resolved this tho..by installing 10.3 and going from scratch. unfortunate, but true....

    :-(

    somehow it was still loading parts of the 8.40 drivers i installed via rpm, with the .run installed 7.11

    oh well

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •