So, I got a HD2600XT to replace an X800GTO that was happy till its fan flaked out. But with the new card, I can't get X to start with DRI enabled: X always gets a floating point error (signal 8) in glesx.so (esutSetDestSurf called from glesxMakeTrans) while trying to map the root window. I notice that with the old card (with all the same configs), /var/log/Xorg.0.log reported:

(II) fglrx(0): GLESX enableFlags = 14

and without DRI, with either card, one gets:

(II) fglrx(0): GLESX enableFlags = 10

but the new card gives the exotic:

(II) fglrx(0): GLESX enableFlags = 58

Anyone know what the flag bits are, or what sets them, or seen anything like 58 in their log?

Or any other hints about what might be causing the FP error?

(Glad to post the xorg.conf and/or Xorg.0.log, but maybe it's something obvious--to somebody else. I've tried every version of the driver that can support this card, both direct from the ATI site and emerged from Gentoo, plus a couple kernels and Xorg versions. In all cases, old card works fine till the fan stops and it dies of heat exhaustion, but new card gives same error. I even tried a superstitious card swap, but of course H/W is never the problem.)