Results 1 to 3 of 3

Thread: stream_get_contents() expects parameter 1 to be resource, boolean given in pts_networ

  1. #1
    Join Date
    Jan 2010
    Posts
    5

    Default stream_get_contents() expects parameter 1 to be resource, boolean given in pts_networ

    When I start the phoronix-test-suite I get the following error message.

    Code:
    matthias@xaYn ~/download/phoronix-test-suite $ ./phoronix-test-suite
    
    [NOTICE] stream_get_contents() expects parameter 1 to be resource, boolean given in pts_network.php:48
    
    [NOTICE] stream_get_contents() expects parameter 1 to be resource, boolean given in pts_network.php:48
    
    NOTICE: Failed To Fetch OpenBenchmarking.org Repository Data: pts
    
    Phoronix Test Suite v3.6.1 (Arendal)
    
    The Phoronix Test Suite is the most comprehensive testing and benchmarking platform available that provides an extensible framework for which new tests can be easily added. The software is designed to effectively carry out both qualitative and quantitative benchmarks in a clean, reproducible, and easy-to-use manner.
    
    ...
    and so on
    ...
    I am also not able to see the available tests.
    Code:
    matthias@xaYn ~/download/phoronix-test-suite $ ./phoronix-test-suite list-available-tests
    
    [NOTICE] stream_get_contents() expects parameter 1 to be resource, boolean given in pts_network.php:48
    
    [NOTICE] stream_get_contents() expects parameter 1 to be resource, boolean given in pts_network.php:48
    
    NOTICE: Failed To Fetch OpenBenchmarking.org Repository Data: pts
    
    Phoronix Test Suite v3.6.1
    Available Tests
    
    
    No tests found. Please check that you have Internet connectivity to download test profile data from OpenBenchmarking.org. The Phoronix Test Suite has documentation on configuring the network setup, proxy settings, and PHP network options. Please contact Phoronix Media if you continuing to experience problems.
    The output of "php -i"

    Do you have some ideas how I can solve this problem or how I could analyse my problem.

  2. #2

    Default

    Are you behind a proxy or anything like that? If so that might be the case. Otherwise it looks like you're on Gentoo? They have poor PHP defaults. Look in the PTS documentation or search the forums about allow_url_fopen (I think that's the option name) that I believe is disabled by default in Gentoo PHP but should be enabled.

  3. #3
    Join Date
    Jan 2010
    Posts
    5

    Default

    Thank you.

    I found this thread.

    After changing url_fopen to On in /etc/php/cli-php5.3/php.ini it worked.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •