I have an Asus P4VP-MX motherboard with a Intel Pentium 4 processor capable of 3.00 GHz. Unfortunately, the BIOS is only letting it clock at 1.50 GHz (1502 MHz according to BIOS system information). I concluded that this was due to the fact the BIOS version was 08.00.09 (build date 08/26/05) and probably out of date.

I went to the official Asus support page for the motherboard (http://support.asus.com/download.asp...IybiXlhuhUUW38) and found there were indeed new BIOS versions available. In fact, "Support new CPUs" is listed as part of the updates (although the link explaining what CPUs are supported by which version leads to a page not found error in Chinese).

I downloaded the latest version listed and tried using 'EZ Flash' but found that the file I had downloaded, "P4VP-MX-ASUS-1014.002", was not recognized by 'EZ Flash'. So I downloaded the second newest version and found that this file, "P4VP1013.AMI", was not accepted either.

At this point I attempted a different method of using the official Asus BIOS-Utilities (Afudos BIOS update tool V2.11). With both versions I had tried with 'EZ Flash', the program claimed to successfully update but no change was observed.

As far as I can tell the BIOS downloads available on the Asus site are not ROM files. I consulted the motherboard manual but it assumes that you can download a ".rom" file.

Do I have to convert the files available on the Asus site to ROMs somehow?

Is there somewhere I can download a ROM file from?