Page 6 of 6 FirstFirst ... 456
Results 51 to 53 of 53

Thread: AMD Releases Catalyst 12.1 Driver For Linux

  1. #51
    Join Date
    Jan 2012
    Posts
    2

    Default

    Quote Originally Posted by Milos_SD View Post
    Well, Xserver doesn't crash on startup with fglrx installed as it used to do before, and I can use AMD card with them. I can switch graphic cards from catalyst control panel, but for some reason, there is no direct rendering when I switch to Intel. But I realy don't care, while AMD card works with fglrx without a problem. Kernel is 3.2 on that laptop. And btw, in BIOS there is only option to turn switchable graphics on/off.
    It is not switching like in win7, you need to logout/login after switching from catalyst control panel.
    Well so much for wishful thinking. Mine don't work. Intel SB + AMD 6470M. Kernel is .38-13 on Natty. This sux!

  2. #52
    Join Date
    Apr 2011
    Location
    Dhaka,Bangladesh
    Posts
    102

    Default 12.1 good and bad

    Ok today installed amd 12.1 for my onboard amd hd 4250(880g chipset). It has both some good and bad thing for me.

    Goodies:
    1. Video on vlc has been smooth. I had a nasty bug that full screen video(any resolution,any format) on vlc or mplayer or any player suffers lagging started since I update to Kubuntu 11.10. But if the floating panel is on(put the cursor on it so that it not disappear) then its smooth. Now this bug seems to gone

    2. xvba back va is working goodly. It was corrupted before.

    3. On Google chrome accelerated 2d canvas still give no visual error(it give that before). With it demos.hacks.mozilla.org/openweb/HWACCEL/ is giving 60+ fps. Without it gives 23 fps. Although Amd is still blacklisted by chrome 16. I have to use about:flags to unblock both the card and accelerated 2d canvas.

    Bad:
    1. Looks like 12.1 has some performance regression at least for Lightmark.
    http://openbenchmarking.org/result/1...GR-1112156GR12

    2. Not new thing but today I saw it after installation that kwin is not using GLSL shaders nor direct rendering(both are ticked at kwin cofiguration). Kwin was giving some minor performance issues since 11.10 on resizeing window and some here and there randomly. Don't know if its causing by this or is it always direct rendering was disable for my onboard graphics.

  3. #53
    Join Date
    Feb 2012
    Posts
    1

    Default Running but kinda :D

    Quote Originally Posted by Milos_SD View Post
    Finaly with this release, Intel Sandy Bridge + AMD 6490 hybrid graphics on HP ProBook 4530s works (a least AMD card works - with intel there is no direct rendering, don't know why).
    I have the exact same laptop: HP Probook 4530 Core i5 (Sandy Bridge) with Radeon 6490 graphics card.
    The 12.1 finally gave me some positive results, but kinda' .

    After installing and running the "sudo amdcccle-initial" and restarting X server seems to freeze, but interestingly it loads successfully and if I type my password and hit enter it actually loads kde (running Kubuntu 11.04). If I hit ctrl+alt+f1 and then get back to ctr+alt+f7 I can force the x server to refresh the screen and see KDE fully loaded with effects running, but the screen remains frozen.

    I can move the cursor though.

    xorg.conf is has the usual "sudo amdcccle-initial" config option with the BusID. Tried commenting it, but it failed to start without it.

    I'd be glad if someone could help me finally run the ati driver successfully . Thanks in advance!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •