Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: HD2400pro agp + fglrx = don't work

  1. #11
    Join Date
    Jan 2008
    Posts
    3

    Default

    which output you use? Frich, I'm using DVI and it doesnt work but freezes.

  2. #12
    Join Date
    Dec 2007
    Posts
    5

    Default

    Hello,
    I use both:
    DVI and VGA.

    I got the fglrx driver partially working:
    my screens are detected, with a correct resolution,

    The Fullscreen Video are very bad, the 2d overlay accelerator seems not working.

    I got a system freeze when i try to run a 3D application (glxgears).

    I think that your system freeze is due to AIGLX extension: it try to start 3D on your card and cause a system freeze.

    you should add

    Section "ServerFlags"
    Option "AIGLX" "off"
    EndSection

    Section "Extensions"
    Option "Composite" "Disable"
    EndSection

    on your /etc/X11/xorg.conf

    Note:

    I have 3D and video overlay working on windows (only with 7.10 amd driver) New driver doesn't support the PCI-E to AGP bridge (used in my graphic card)

    I hope that radeonhd with working 2d acceleration + 3d will be available soon.

    Best regards

    Frich

  3. #13
    Join Date
    Jun 2006
    Posts
    3,046

    Default

    Quote Originally Posted by Frich View Post
    Hello,
    I choose an AGP card because my previous ATI 9800 is dead.

    My motherboard + ram + CPU works well, I don't want to change all my hardware just for a graphic card.
    You may have few options to NOT be doing that. AGP cards are about a year or so from being pulled completely from the market. As a bus, it's "okay" but the PCI-E interface is better overall and everything in creation has went to it. You're going to find that while your hardware is working, unless you want to go with older tech, the AGP motherboard is a liability.

    AMD's edge bridge, the Rialto, has had issues with Linux operation for a while now on their proprietary driver. NVidia's got decent AGP parts but they compare more with the R500 parts in performance and ability- not the same as the R600 you've bought and having problems with.

    Right now, there's several options to you:

    Ride it out, hoping that AMD gets their act together or the FOSS crowd beats them to it. You may be waiting a long while for that one.

    Buy a 7800GS from BFG Tech or one of the other companies using an NVidia part (which does seem to work right on Linux and is an AGP part...)

    or...

    Buy a whole new motherboard, CPU, RAM, etc. and side step the issue of a deprecated bus spec and be able to pick and choose a range of GPU options, all of which largely work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •