The build-apache test doesn't work anymore, all of a sudden. It used to work fine and I haven't touched that machine. Actually, it was a machine that was re-created from an image I haven't touched in weeks. When the pts/apache test updated to 1.4.0, both pts/apache and pts/build-apache stopped working:

Code:
# ./phoronix-test-suite run-test pts/build-apache

ERROR: Argument Missing.

CORRECT SYNTAX
phoronix-test-suite run-test [Test | Suite | OpenBenchmarking.org ID | Test Result]  ...
The pts/apache-1.4.0 installed and is running fine, but pts/build-apache doesn't even install anymore:

Code:
# ./phoronix-test-suite install-test pts/build-apache

WARNING: It appears that the Phoronix Test Suite is already running.
         For proper results, only run one instance at a time.


ERROR: Argument Missing.

CORRECT SYNTAX
phoronix-test-suite install-test [Test | Suite | OpenBenchmarking.org ID | Test Result]  ...
After some more fiddling around, I found that it only installed (and this was the only test to install like this) if I provided the version of the test, like so:

Code:
# ./phoronix-test-suite install-test pts/build-apache-1.4.0
And it only ran if I provided the version of the test, like so:

Code:
# ./phoronix-test-suite run-test pts/build-apache-1.4.0
And the biggest problem was that it only ran as part of a batch if the batch provided the version of the test, like so:

Code:
<Execute>
    <Test>pts/build-apache-1.4.0</Test>
  </Execute>
What am I doing wrong? Should I always provide the test version in my batches?

I would like to mention that the other tests are running fine without needing the version number.