Page 6 of 8 FirstFirst ... 45678 LastLast
Results 51 to 60 of 76

Thread: Radeon R600 Tiling Patches Are Ready

  1. #51
    Join Date
    Sep 2008
    Posts
    989

    Default

    Quote Originally Posted by Wilfred View Post
    Hey, if stuff is in git master, couldn't I just install xorg-edgers on ubuntu and recompile the ubuntu kernel with patch?
    If I want to test this that is.
    No, because xorg-edgers probably won't provide a built kernel with the kernel patches.

    The kernel patches are absolutely critical. You can't "skip" them. And you have to use a 3.3-rc or later kernel.

  2. #52
    Join Date
    Sep 2008
    Posts
    989

    Default

    Quote Originally Posted by ChrisXY View Post
    I have applied the two 0001-drm* patches (can you please provide the second patch in less comfortable way than in a mail to a mailinglist complete with headers with the patch attached encoded in base64?)
    Is it normal that git apply doesn't have any output whatsoever?
    Yes, that's normal. No output is good; complaining is bad.

  3. #53

    Default

    Quote Originally Posted by PuckPoltergeist View Post
    Partly ok. I get a short flickering with garbled screen with one message in dmesg:
    Code:
    radeon 0000:01:00.0: evergreen_surface_value_conv_check:329 invalid array mode 5
    radeon 0000:01:00.0: evergreen_packet3_check:1918 invalid cmd stream 454
    [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
    After this it works.
    I have to correct this. The Invalid command stream error came from the xv crash. The garbled screen on X startup doesn't leave any errors in the logs.

  4. #54
    Join Date
    Jan 2010
    Posts
    21

    Default

    Quote Originally Posted by allquixotic View Post
    And you have to use a 3.3-rc or later kernel.
    hmm running kernel 3.2.5 here. One doesn't have to use the 3.3-rc, 3.2.x + drm patches from 3.3 + 2d patches works too.

  5. #55
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    Nice, the boost in Doom3 seems to be around 37%. (Unfortunately since Mesa has serious problems with this particular game it only means that we go from 19 to 26 fps, but still..)

    However, after I run any game in Wine the desktop (GNOME fallback so no GL compositing) fails to redraw and the following is logged:

    Code:
    [  150.686126] radeon 0000:01:00.0: evergreen_surface_check_linear_aligned:213 cb pitch 1728 invalid must be aligned with 128
    [  150.686130] radeon 0000:01:00.0: evergreen_cs_track_validate_cb:426 cb[0] invalid (0x000000d7 0x00006f5f 0x00000890 0x01088168)
    [  150.686133] radeon 0000:01:00.0: evergreen_packet3_check:1918 invalid cmd stream 465
    [  150.686135] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
    (This seems to be an odd place to track these problems, should we file bugs on bugs.freedesktop.org instead?)

  6. #56
    Join Date
    May 2007
    Posts
    231

    Default

    Quote Originally Posted by whizse View Post
    Nice, the boost in Doom3 seems to be around 37%. (Unfortunately since Mesa has serious problems with this particular game it only means that we go from 19 to 26 fps, but still..)

    However, after I run any game in Wine the desktop (GNOME fallback so no GL compositing) fails to redraw and the following is logged:

    Code:
    [  150.686126] radeon 0000:01:00.0: evergreen_surface_check_linear_aligned:213 cb pitch 1728 invalid must be aligned with 128
    [  150.686130] radeon 0000:01:00.0: evergreen_cs_track_validate_cb:426 cb[0] invalid (0x000000d7 0x00006f5f 0x00000890 0x01088168)
    [  150.686133] radeon 0000:01:00.0: evergreen_packet3_check:1918 invalid cmd stream 465
    [  150.686135] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
    (This seems to be an odd place to track these problems, should we file bugs on bugs.freedesktop.org instead?)
    Yeah better to open bug but first make sure you are using lastest ddx from git few fixes went in.

  7. #57
    Join Date
    Nov 2009
    Location
    Italy
    Posts
    970

    Default

    Hi-Z patches for R600 has been updated if someone is interested: https://bugs.freedesktop.org/show_bug.cgi?id=36602
    ## VGA ##
    AMD: X1950XTX, HD3870, HD5870
    Intel: GMA45, HD3000 (Core i5 2500K)

  8. #58
    Join Date
    Jun 2009
    Posts
    2,932

    Default

    Yes! It's finally all coming together w00t w00t!

  9. #59
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    Quote Originally Posted by glisse View Post
    Yeah better to open bug but first make sure you are using lastest ddx from git few fixes went in.
    Already using latest git. Bug is filed at
    https://bugs.freedesktop.org/show_bug.cgi?id=45827

    I also noticed that if ColorTiling2D is not turned on I get a corruption in X after running a game using Mesa with the tiling patches applied. Is this another bug?

  10. #60
    Join Date
    Nov 2009
    Location
    Bratislava, Slovakia
    Posts
    48

    Default

    After rebuild from git everything works.
    Must have done somethig wrong when patching.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •