Page 8 of 8 FirstFirst ... 678
Results 71 to 76 of 76

Thread: Radeon R600 Tiling Patches Are Ready

  1. #71
    Join Date
    Nov 2011
    Posts
    267

    Default

    Quote Originally Posted by darkbasic View Post
    As easy as fakeroot make-kpkg --initrd kernel_image kernel_headers
    Or "make defconfig && make deb-pkg"
    (to get a generic kernel)
    I would suggest some changes from defconfig, though

  2. #72
    Join Date
    Jun 2010
    Location
    ฿ 16LDJ6Hrd1oN3nCoFL7BypHSEYL84ca1JR
    Posts
    1,044

    Default

    Quote Originally Posted by glisse View Post
    I pushed a fix to ddx upstream it should be ok now.
    Are you people looking into that problem: http://phoronix.com/forums/showthrea...932#post249932

    Or should I open a proper bug report at the freedesktop bugtracker?

    Further information is: The resolution of the laptop screen doesn't influence the buggy behaviour as long as the right screen has 1600x1200.
    When I reduce the right screen's resolution to 1680x1050 or lower the screen corruption of the laptop screen is gone, however the right screen's upper boundary is quite above what xrandr thinks it is.

    On the following screenshot the arandr window is at the very top of what is visible on the right screen, the whole area above it is NOT on the screen anymore.


    It's not only with the HDMI output, the VGA output has the same problem.
    HD 6550M by the way.

  3. #73
    Join Date
    Feb 2011
    Location
    Ukraine
    Posts
    132

    Default

    drm-next,mesa,ddx git - 12.02.12
    Code:
    hd6770 1920x1080      tilling on      tilling off
    Lightmark                  134         100
    Nexuiz                     72          graphic artifacts
    Etqw demo                  33.5        graphic artifacts

  4. #74
    Join Date
    Jun 2010
    Location
    ฿ 16LDJ6Hrd1oN3nCoFL7BypHSEYL84ca1JR
    Posts
    1,044

    Default

    Quote Originally Posted by ChrisXY View Post
    Are you people looking into that problem: http://phoronix.com/forums/showthrea...932#post249932
    I would have liked to edit my post but for some reason the edit time is still not infinite...

    Today I updated my stuff and it was solved. I believe (!) what solved it was 9b3ad51ae5fd9654df8ef75de845a519015150bb "radeon: fix pitch alignment for scanout buffer".

    Thank you very much, guys.

  5. #75
    Join Date
    Jun 2010
    Location
    ฿ 16LDJ6Hrd1oN3nCoFL7BypHSEYL84ca1JR
    Posts
    1,044

    Default

    Quote Originally Posted by PuckPoltergeist View Post
    I've removed mesa completely, started kdm, stopped kdm, reinstalled mesa, started kdm. Everytime the same behavior. As soon as I've enabled ColorTiling (not even ColorTiling2D) I got a garbled screen and dmesg showed the command stream errors. Something goes wrong on my HD5470. And I doubt it's because improper mesa.

    PS: I've found some other error messages in dmesg:
    Code:
    radeon 0000:01:00.0: evergreen_surface_check_1d:244 stencil height 581 invalid must be aligned with 8
    radeon 0000:01:00.0: evergreen_cs_track_validate_stencil:502 stencil invalid (0x000000af 0x000031ed 0x00000401 0x00002022)
    radeon 0000:01:00.0: evergreen_packet3_check:1918 invalid cmd stream 929
    [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
    Sorry for reviving that old thread but it is actually the only one google finds for
    Code:
    "stencil height" "invalid must be aligned with"
    so it seem to be caused here. This is obviously a rare problem, but I get it all the time...


    I use KDE too and I see no visual corruption.

    I don't really know when it happens but after working with KDE a bit I see this in my logs:
    Code:
    <snip>
    
    [ 6599.816781] radeon 0000:02:00.0: evergreen_surface_check_1d:240 stencil height 1 invalid must be aligned with 8
    [ 6599.816790] radeon 0000:02:00.0: evergreen_cs_track_validate_stencil:554 stencil invalid (0x0000000f 0x00000001 0x00000401 0x00002022)
    [ 6599.816796] radeon 0000:02:00.0: evergreen_packet3_check:2055 invalid cmd stream 2361
    [ 6599.816800] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
    [ 6658.589574] radeon 0000:02:00.0: evergreen_surface_check_1d:240 stencil height 1 invalid must be aligned with 8
    [ 6658.589583] radeon 0000:02:00.0: evergreen_cs_track_validate_stencil:554 stencil invalid (0x0000000f 0x00000001 0x00000401 0x00002022)
    [ 6658.589589] radeon 0000:02:00.0: evergreen_packet3_check:2055 invalid cmd stream 483
    [ 6658.589593] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
    [ 6887.698995] radeon 0000:02:00.0: evergreen_surface_check_1d:240 stencil height 1 invalid must be aligned with 8
    [ 6887.699003] radeon 0000:02:00.0: evergreen_cs_track_validate_stencil:554 stencil invalid (0x0000000f 0x00000001 0x00000401 0x00002022)
    [ 6887.699009] radeon 0000:02:00.0: evergreen_packet3_check:2055 invalid cmd stream 2361
    [ 6887.699013] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
    [ 6925.419753] radeon 0000:02:00.0: evergreen_surface_check_1d:240 stencil height 1 invalid must be aligned with 8
    [ 6925.419762] radeon 0000:02:00.0: evergreen_cs_track_validate_stencil:554 stencil invalid (0x0000000f 0x00000001 0x00000401 0x00002022)
    [ 6925.419768] radeon 0000:02:00.0: evergreen_packet3_check:2055 invalid cmd stream 483
    [ 6925.419772] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
    [ 6953.218075] radeon 0000:02:00.0: evergreen_surface_check_1d:240 stencil height 1 invalid must be aligned with 8
    [ 6953.218085] radeon 0000:02:00.0: evergreen_cs_track_validate_stencil:554 stencil invalid (0x0000000f 0x00000001 0x00000401 0x00002022)
    [ 6953.218091] radeon 0000:02:00.0: evergreen_packet3_check:2055 invalid cmd stream 2361
    [ 6953.218095] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
    
    <snip>
    I don't even know what that bug is. Is KDE doing something wrong having a "stencil height 1" somewhere where it shouldn't? Is the radeon driver supposed to log this so aggressively?


    linux mainline 3.4, libdrm and mesa and xf86-video-ati git, HD 6550M.

  6. #76
    Join Date
    Jan 2012
    Posts
    10

    Thumbs up tile speed up

    From here

    http://article.gmane.org/gmane.comp....ri.devel/69876

    Some benchmarks on juniper (5750), fullscreen 1920x1080,
    first result - kernel 3.4.0+ (fb21affa), second - with these patches:

    Lightsmark: 91 fps => 123 fps +35%
    Doom3: 74 fps => 101 fps +36%

    Vadim

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •