Page 13 of 20 FirstFirst ... 31112131415 ... LastLast
Results 121 to 130 of 195

Thread: Goodbye ATI

  1. #121
    Join Date
    Apr 2010
    Posts
    1,946

    Default

    Quote Originally Posted by RealNC View Post
    No, not by that much. The 560 is usually about 60-70% faster than a 4870 and the 560 Ti is about 70-80% faster. It's very, very rare to see a 2x performance difference.

    Here are benches of the 560 Ti vs the 4870. Note that they don't have benches of the plain 560 (non-Ti):

    http://www.anandtech.com/bench/Product/304?vs=330
    This site is better. Ive picked non-Ti. 60-100% average.

    4870 cannot downclock properly as well (all pre R700).

    I wonder if we ever will get GPU to work as pluggable CPU cores - plug more and get equivalent boost. On best - without drivers. Would require smp-friendly software or hardware tricks.

  2. #122
    Join Date
    Apr 2010
    Posts
    1,946

    Default

    Quote Originally Posted by GrrlTlak View Post
    Hi,

    i can understand your frustration with the state of AMD /ATI driver support in Linux. I myself finally made the switch to Windows 7 after having been "forced to live" with this driver disaster. The open radeon driver does not function due to energy issues and since my notebook really IS a tool and not the center of my being i decided to ditch Linux since there is no fully functional desktop environment when you are a customer of ATI or AMD. The situation and this company really are sucking. The only Linux i have left now resides in my Motorola Defy+ ...

    Hope you'll be glad with your all-new graphic chip ;-)
    This tip is very free:


    1. Take a Hammer
    2. Destroy useless AMD hardware

    or
    1. Take a paper box
    2. Send useless AMD hardware to #radeon

    3. Buy chip that is supported (intel or nvidia).


    NO ONE IS FORCING YOU TO DO STUPID THINGS.

    Also, did you notice that MS has used EXACTLY same tactics against Java? And against Firefox? And with OpenGL/Direct3d(there IS NO POINT IN directx - AT ALL).

    AMD has regular sex with microsoft (as in "owned"), end of the story.
    Last edited by crazycheese; 03-08-2012 at 09:57 AM.

  3. #123
    Join Date
    Feb 2011
    Posts
    3

    Default

    Quote Originally Posted by RealNC View Post
    No, not by that much. The 560 is usually about 60-70% faster than a 4870 and the 560 Ti is about 70-80% faster. It's very, very rare to see a 2x performance difference.

    Here are benches of the 560 Ti vs the 4870. Note that they don't have benches of the plain 560 (non-Ti):

    http://www.anandtech.com/bench/Product/304?vs=330
    That's comforting, I was using some wrong metrics then (mix of Wikipedia & other site)...

  4. #124

    Default

    Quote Originally Posted by RealNC View Post
    It's usable here and works perfectly.
    But tearing is still there. With both of nVidia proprietary driver and nouveau. And there is no any way to fix it with nVidia hardware. You maybe doesn't see it, that make you happy man, but that not make problem doesn't exist.
    Quote Originally Posted by RealNC View Post
    Do I care if there is or isn't?
    Developers are not telepathic, sorry. How they may fix this bug if they even doesn't know about it?
    Quote Originally Posted by RealNC View Post
    Yes.
    So you doesn't see it, as expected.
    Quote Originally Posted by RealNC View Post
    I don't play multiplayer games. Except chess.
    And what you will gonna do with PhysX when you clear Metro 2033, Alice: Madness Returns and Batman: Arkham City?

  5. #125
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,801

    Default

    Quote Originally Posted by RussianNeuroMancer View Post
    But tearing is still there. With both of nVidia proprietary driver and nouveau. And there is no any way to fix it with nVidia hardware.
    Nope. To get VSync, you enable it in KDE's system settings, *NOT* in the driver. There's a checkbox there: System Settings->Desktop Effects->"Advanced" tab->"Use VSync" checkbox. If you enable that, say goodbye to tearing.


    Developers are not telepathic, sorry. How they may fix this bug if they even doesn't know about it?
    How should I know who's bug it is? I thought it was a KWin problem, because the Catalyst driver had the same issue.

    So you doesn't see it, as expected.
    I'm very sensitive to tearing. Very sensitive. I can spot it immediately. If I tell you that there's no tearing and that VSync works, you can count on that.

    And what you will gonna do with PhysX when you clear Metro 2033, Alice: Madness Returns and Batman: Arkham City?
    What, will it kill my cat? What do you mean "what you will gonna do". Do I need to do something?

  6. #126
    Join Date
    Mar 2012
    Posts
    4

    Default I Hear Ya Buddy!

    I've been using ATI hardware since forever, been pretty pleased with it on the windows gaming side.. but i love to test linux distro's and the gfx is a nightmare every time.. My last attempts has been with my 5850, not sure if that's a notoriously bad example, but i've never had much luck with it.. actually the default (vesa?) driver has been fine, but any attempts at acceleration leaves the UI in shambles..

    Can't wait to see what those new gf104's can do ..

  7. #127

    Default

    Quote Originally Posted by RealNC View Post
    Nope. To get VSync, you enable it in KDE's system settings, *NOT* in the driver. There's a checkbox there: System Settings->Desktop Effects->"Advanced" tab->"Use VSync" checkbox. If you enable that, say goodbye to tearing.
    You really think I not try this?
    And this is not problem of some "unlucky" GPU model - I try five nVidia GPU's (different generations sure).

    Quote Originally Posted by RealNC View Post
    How should I know who's bug it is? I thought it was a KWin problem, because the Catalyst driver had the same issue.
    And... how KWin developer may know about that if you didn't tell? (And help you sort issue if it doesn't KWin issue.)

    Quote Originally Posted by RealNC View Post
    If I tell you that there's no tearing and that VSync works, you can count on that.
    KWin doesn't support nVidia sync implementation. nVidia driver can't do proper vsync for compositor without support on compositor side. I try to at least five nVidia GPU's (maybe more) with driver from 96 to 295. I sure try all advices for Compiz and KWin. If you doesn't see tearing that may mean you miss something or your case is very, very rare.

    Quote Originally Posted by RealNC View Post
    What, will it kill my cat? What do you mean "what you will gonna do". Do I need to do something?
    No, I just ask why you so happy about PhysX before, and I still not understand why you so happy about that.

  8. #128
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,801

    Default

    Quote Originally Posted by RussianNeuroMancer View Post
    You really think I not try this?
    And this is not problem of some "unlucky" GPU model - I try five nVidia GPU's (different generations sure).
    Well, dunno. As I said, it worked right from the start for me. I didn't have to do anything special. Note that I'm talking about the nvidia binary driver. I've no idea about Nouveau.

    And... how KWin developer may know about that if you didn't tell? (And help you sort issue if it doesn't KWin issue.)
    I reported it:

    http://blog.martin-graesslin.com/blo...#comment-43276

    He didn't know what I'm talking about. He was probably using NVidia :-)

    KWin doesn't support nVidia sync implementation. nVidia driver can't do proper vsync for compositor without support on compositor side. I try to at least five nVidia GPU's (maybe more) with driver from 96 to 295. I sure try all advices for Compiz and KWin. If you doesn't see tearing that may mean you miss something or your case is very, very rare.
    You probably enabled "Sync to VBlank" in nvidia-settings. Don't do that. Only enable it in KDE System Settings. I'm using KDE 4.8, btw. When I disable VSync in KDE, I get tearing. When I enable it again, everything is smooth again. It works.

    No, I just ask why you so happy about PhysX before, and I still not understand why you so happy about that.
    Because I can now re-play some of my favorite games with PhysX. I replayed Mirror's Edge and Mafia 2, and the effects were pretty nice. I didn't say it's the most important thing ever. It's just... nice.

    I'm gonna also try the CUDA water in Just Cause 2. It looks quite nice:

    http://www.youtube.com/watch?v=HE_lnS7TfDI

  9. #129
    Join Date
    May 2011
    Posts
    107

    Default

    RealNC: you are still lucky. Proprietary ATI drivers under linux on my dev-computer causes the kernel to crash without any error message, since 4+ years ago. So i have to use older kernel, or nVidia :P

  10. #130

    Default

    Quote Originally Posted by RealNC View Post
    I reported it:
    http://blog.martin-graesslin.com/blo...#comment-43276
    He didn't know what I'm talking about. He was probably using NVidia :-)
    AFAIK he using R300g, fglrx (some R600 GPU) and nouveau (some NV50 GPU).

    Quote Originally Posted by RealNC View Post
    You probably enabled "Sync to VBlank" in nvidia-settings. Don't do that. Only enable it in KDE System Settings. I'm using KDE 4.8, btw. When I disable VSync in KDE, I get tearing. When I enable it again, everything is smooth again. It works.
    I have two years to try everything before I switch to AMD. Believe me, I really try everything (that too). It's can not work right with nVidia driver in applications that doesn't support GL_EXT_x11_sync_object (KWin & Compiz) by disign of nVidia proprietary driver. Just admit it - you probably not so sensitive to tearing as you think (this itself is not something bad, but good for you).

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •