I've had a bug open for a while now asking for a Gallium3D driver for VirtualBox. One of the developers (Michael) is asking questions that are beyond my knowledge.

Actually I would now like to put a question back to you. Can you tell me whether my understanding is correct that a DRI2 driver based on Gallium3D will only be compatible with the version of Mesa (possibly even the build of Mesa) that it was built against? I realise that DRI2 was originally supposed to be an independent ABI, but as far as I can see they never managed to break the Mesa dependency.
I would appreciate any help I could get here.

VirtualBox Ticket #6526