The latest Linux driver from ATI is Catalyst 7.11, but there is no official support for the Mobility line AFAIK.

I'm using SimplyMEPIS 7 rc2, and I need a full 3D Linux driver for my HP 8510p notebook, which has an ATI Mobility HD 2600 GPU.

The suggestions that I've received so far, are to just install the standard Linux Catalyst 7.11 driver myself, or download it and install it with ENVY. Are these the right ways to go about this, or is there some other way this should be done?

btw, I'm a Linux noobie.