Results 1 to 7 of 7

Thread: Powerplay problems, how to disable it?

  1. #1
    Join Date
    Oct 2007
    Posts
    31

    Default Powerplay problems, how to disable it?

    Hi all,
    I've been having a problem with powerplay on my notebook for a while now.
    It's an Msi M635 with a X700 mobile and the problem is that whenever powerplay is enabled and as long as it's actually doing something (like throttling the videocard when i'm on battery) i get a lot of display corruption.

    The computer doesn't actually crash because i can see things happening when when launching konqueror, kmenu or a simple console, but it's like it is only "half" drawn on screen.

    This happens with both opensuse and winxp btw. The problem appeared with the introduction of the catalyst control center on winxp... i believe the last drivers that worked fine were the last release that brought the old control panel. I've submitted this problem to ATI and Msi but never got any response.

    So the way i got around this in windows was do disable powerplay or just set it to performance. All is fine this way, well except for not getting any battery time benefit.

    Now i'm new to linux and with the previous 3 linux driver releases i didn't have to do anything, because powerplay wasn't enabled by default. But with the latest Cat7.12 it is on by default when using the battery. So i just can't use the laptop on battery.
    Going to back to powerstate=3 (default state, with this card) with the aticonfig command doesn't correct the problem. This didn't work either with previous linux drivers (powerstate=3->powerstate=1or2 = corruption; powerstate=1or2->powerstate=3 = corruption is still there) or even with windowsXP (powerplay balanced/battery->Performance = corruption is still there).

    So i have to disable it from the start.
    Any way to do this?
    Or to try and troubleshoot the problem?

    regards,
    Carlos

  2. #2
    Join Date
    Apr 2007
    Location
    Würzburg, Germany
    Posts
    36

    Default

    You could try removing all files in /etc/acpid/events that are related to the ati drivers (containing "aticonfig" in their name). You can also manually switch power states via aticonfig.

  3. #3
    Join Date
    Oct 2007
    Posts
    44

    Default

    wouldn't it be enough to kill atieventsd?

  4. #4
    Join Date
    Oct 2007
    Posts
    31

    Default

    how can i kill it at boot? because if i get into kde there's corruption and i can't do anything

    regards,
    Carlos

  5. #5
    Join Date
    Apr 2007
    Location
    Würzburg, Germany
    Posts
    36

    Default

    I'm not sure this will help; I don't know what the job of atieventsd is, but the powerplay stuff is triggered by ACPI events via acpid and most likely works independetly of atieventsd (don't have time to check right now).

    Anyway, you can disable atieventsd by removing it from the default runlevel (use your distribution administrative tools for that).

  6. #6
    Join Date
    Oct 2007
    Posts
    31

    Default

    Thanks all,
    I disabled atieventsd, unplugged and still got corruption anyway. Plugged it back again... still corruption. Then, from what i managed see, typed init 3 on a terminal as su, logged in and run startx kde -> everything ok.
    Can't really use aticonfig command because going back to the default powerstate doesn't fix it.
    Now i'll look for ati related files in /etc/acpid/events.

    thanks,
    Carlos

  7. #7
    Join Date
    Oct 2007
    Posts
    31

    Default

    I found nothing related to ATI/AMD in /etc/acpid/events.
    And i get the same problems with cat7.12.
    more help anyone?

    regards,
    Carlos

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •