Just tried to compile Mesa from git on Fedora 16, and was told that I needed 'xcb-dri2 version 1.8'.

So I download libxcb-1.8-2.fc17.src.rpm from Fedora's development repository and try to recompile it for F16, only to be told:

error: Failed build dependencies:
graphviz is needed by libxcb-1.8-2.fc16.i686
xcb-proto >= 1.6 is needed by libxcb-1.8-2.fc16.i686

xcb-proto I can understand, but what On Earth is "graphviz"? And WTF do I need it just to compile Mesa?

I have no idea what "graphviz" might demand before I can compile it, but its source RPM is 19M and so I'm guessing "humber_bridge.src.rpm", and possibly "hanging_gardens_of_babylon-2.0.src.rpm".