Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Have Mesa's requirements "jumped the shark"?

  1. #1
    Join Date
    Jul 2007
    Posts
    448

    Angry Have Mesa's requirements "jumped the shark"?

    Just tried to compile Mesa from git on Fedora 16, and was told that I needed 'xcb-dri2 version 1.8'.

    So I download libxcb-1.8-2.fc17.src.rpm from Fedora's development repository and try to recompile it for F16, only to be told:

    error: Failed build dependencies:
    graphviz is needed by libxcb-1.8-2.fc16.i686
    xcb-proto >= 1.6 is needed by libxcb-1.8-2.fc16.i686

    xcb-proto I can understand, but what On Earth is "graphviz"? And WTF do I need it just to compile Mesa?

    I have no idea what "graphviz" might demand before I can compile it, but its source RPM is 19M and so I'm guessing "humber_bridge.src.rpm", and possibly "hanging_gardens_of_babylon-2.0.src.rpm".

  2. #2
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    So it's not a Mesa requirement, but one from libxcb.

    FWIW, graphviz is used for building graphs, needed by the documentation packages. I'm guessing you can disable building the docs, I also fail to see why you need to build graphviz itself from source.

    Edit: --disable-build-docs
    Last edited by whizse; 03-05-2012 at 04:16 PM.

  3. #3
    Join Date
    Jul 2007
    Posts
    448

    Default Because I'm trying to build RPMs from SRPMs.

    This is an RPM-based system, so I'm trying to build F16-friendly RPMs using the SRPMs from F17. Experience teaches to rebuild these packages from source to avoid any incompatibility issues from running F17 binaries on an earlier system.

  4. #4
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    Yes, but doesn't it build with graphviz from F16? Are you planning on backporting the whole dependency chain?

  5. #5
    Join Date
    Jul 2007
    Posts
    448

    Default Unfortunately, it does not.

    Quote Originally Posted by whizse View Post
    Yes, but doesn't it build with graphviz from F16? Are you planning on backporting the whole dependency chain?
    I'm not planning of back-porting anything, but this package is certainly not building with F16's toolchain.

  6. #6
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    Taking a source package from a newer distro release and recompiling it for an older system is basically what backporting is.

  7. #7
    Join Date
    Jul 2007
    Posts
    448

    Default Then I'll rephrase...

    I'm not planning on hacking any F17 .spec files so that a package rebuilds correctly on F16.

  8. #8
    Join Date
    Nov 2011
    Posts
    306

    Default

    Google says there is a Fedora 16 package of graphviz. You'll need to install it manually, probably (unless yum is a LOT smarter than apt)--at least with apt, the build-dependencies that you get are those of the repository version.
    It should work--I used the version that shipped with Squeeze to backport libxcb 1.8 to build mesa-git.
    That was much older than what you have (Squeeze ~=F12 to F13)

    BTW-remember to install everything from xcb-proto, or build will fail with some bizarre python errors.
    At least on Debian, you need xcb-proto 1.7+.
    That built fairly easily.

    Used to be that you could disable xcb...

    Also, be sure to get libdrm 2.4.31!

    FWIW: Building mesa-git with video decode enabled on squeeze
    Debian, but it might help.

  9. #9
    Join Date
    Oct 2007
    Posts
    1,326

    Default

    Quote Originally Posted by Ibidem View Post
    Also, be sure to get libdrm 2.4.31
    This broke my method of building mesa from git. I used to build drm/ddx/mesa from git, but I stopped that a long time ago since it was just mesa I wanted to be from git. Now, I'm waiting patiently for libdrm2 2.4.31 in Debian unstable. I tried installing drm from git, but the mesa build still complains that libdrm = 2.4.30

  10. #10
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    Quote Originally Posted by DanL View Post
    This broke my method of building mesa from git. I used to build drm/ddx/mesa from git, but I stopped that a long time ago since it was just mesa I wanted to be from git. Now, I'm waiting patiently for libdrm2 2.4.31 in Debian unstable. I tried installing drm from git, but the mesa build still complains that libdrm = 2.4.30
    It's pretty easy to build your own packages using the debian packaging.

    You could even grab the packaging scripts directly from git:
    http://anonscm.debian.org/gitweb/?p=...lib/libdrm.git (There's initial support for .31 there)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •