Quote Originally Posted by DanL View Post
This broke my method of building mesa from git. I used to build drm/ddx/mesa from git, but I stopped that a long time ago since it was just mesa I wanted to be from git. Now, I'm waiting patiently for libdrm2 2.4.31 in Debian unstable. I tried installing drm from git, but the mesa build still complains that libdrm = 2.4.30
First--what $PREFIX? configure uses /usr/local, while you may need /usr (or should set PKG_CONFIG_PATH so it's visible to pg-config)
Second--I grabbed the libdrm 2.4.31 tarball, rather than using git.
If you follow the link I mentioned (http://forums.debian.net/viewtopic.php?f=16&t=68862), I mentioned what worked for me.
I said "Squeeze" there, but it should be enough info to get any Debian version running Mesa from git.
(Whizse's tip is probably better than what I did, though)
If you use the Debian forums, I'd be happy to open that thread up to anything related to Mesa from git (whether it's enabling pipe-video, tracking 8.0, using clover, or whatever else)

Also...Debian Wheezy or later has gcc-4.6, which you need if you want Clover. That might be interesting.