Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: AMD Catalyst 12.2 For Linux Brings Few Changes

  1. #21
    Join Date
    Jun 2011
    Posts
    8

    Default

    Quote Originally Posted by Kano View Post
    And what fancy 3d effect does your email client use? I would expect that your crash is more sound related.
    Nvidia bug causes evolution to crash/segmentation fault. Temporary and permanent fixes on Debian Testing :
    http://verahill.blogspot.com.au/2012...4-no-real.html

    nvidia 295.20 bug causing gnome-shell to crash on Debian Testing :
    http://verahill.blogspot.com/2012/02...vidia-bug.html

  2. #22
    Join Date
    Jan 2010
    Posts
    105

    Default

    Quote Originally Posted by Kano View Post
    So in installed and ran this on my 5770 with no problem, so whatever is going on with the driver and ur card does not hold true for the whole evergreen generation. Maybe its not fglrx thats the problem? there's always a first time for everything

  3. #23
    Join Date
    Aug 2007
    Posts
    6,630

    Default

    Maybe not for 57*, but most likely for 56* and 54*. Btw. test 4 is where most oss drivers fail. You can call it directly using
    Code:
    gl2benchmark -sceneselect 4
    Last edited by Kano; 03-09-2012 at 04:58 PM.

  4. #24
    Join Date
    Jan 2008
    Posts
    36

    Angry installed it and ...

    Wake from suspend and hibernation still broken with my Acer One 722 netbook

    I wish there was a better way to tell AMD that I'm not happy with them. Hell, just an acknowledgment saying, they are working on my bug would be amazing. I test software for a living and it amazes me that so many complaints are ignored. They haven't to realize that they are losing money because of this.

    I know it's there issue because the open source driver, while slow, work fine.

  5. #25
    Join Date
    Oct 2011
    Posts
    22

    Default

    FINALLY!!! The GNOME Shell top-bar is displayed on the actual primary monitor! *performs a little dance*

    Until 12.2, the top-bar was always displayed on the left-hand (or top) monitor, despite setting the right-hand (or bottom) monitor as primary.
    Do note that it ain't perfect yet: sometimes programs are still launched on the left-hand monitor; for some reason the login screen is now positioned on the left-hand monitor, while this was the only thing that was working properly before; and don't try to manually use xrandr to change the primary monitor, it will fail and will cause the top-bar to be displayed on the left-hand monitor at all times again.
    Last edited by Forage; 03-10-2012 at 06:46 AM.

  6. #26
    Join Date
    Oct 2011
    Posts
    22

    Default

    HEADS-UP!

    In my case the identifiers of the monitors have been changed with the 12.2 drivers. What used to be "DFP4" and "DFP5" are now "DFP10" and "DFP11".
    If your pre-12.2 configuration suddenly stopped working after the update, e.g. your multi-monitor setup, check your /etc/X11/xorg.conf and ~/.config/monitors.xml config files. You might need to either update or clean up the files by altering the identifiers to the new ones or removing now redundant sections (if you have been using amdconfig, the CCC or GNOME display settings after the update).

    To determine your new identifiers use:
    Code:
    xrandr -q
    This nullifies my comments in the previous post: You can use xrandr manually to change the primary monitor, just make sure you use the new identifiers.

    Also, to fix the login screen being positioned on the left-hand (or top) monitor despite have the right-hand (or bottom) monitor as primary: add the following to /etc/X11/xorg.conf for the appropriate Monitor section:
    Code:
    Option	    "Primary" "1"
    And perform a new initialization afterwards:
    Code:
    sudo amdconfig --input=/etc/X11/xorg.conf
    Last edited by Forage; 03-10-2012 at 07:55 AM.

  7. #27
    Join Date
    Jul 2009
    Posts
    12

    Default

    I do see some progress with my HD6670 on Fedora 16
    The GNOME3 experience is gradually improving. Moving windows is no longer choppy, it is nearly perfectly smooth. A good experience now.
    The "random" crashes of the GNOME shell (probably caused by fglrx memory corruption) have reduced, but are still there and unpredictable. At least
    they do not happen every 10 minutes or so now, but rather once an hour or so.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •