Results 1 to 4 of 4

Thread: ATI X1950 AGP Driver Problem

  1. #1
    Join Date
    Jan 2008
    Posts
    3

    Default ATI X1950 AGP Driver Problem

    Does anyone know how, or had any success on installing the latest ATI proprietary drivers with this agp card on Debian etch? For a 2 weeks now I've been trying to get this card to have 3D acceleration but to no avail. So far nothing on Debian etch 4.0r2, Ubuntu gutsy, Slackware current, Fedora 8, Linux Mint, Mepis, Mandriva, and Gentoo. All of which were fresh installs/updates or boot from a Live CD. Both Gentoo and Mandriva crashed when trying to boot the Live Cd's so that was as far as I had gotten with those two. So I'm back to a fresh install of Debian. Roughly the process I've followed for Debian and Ubuntu are...

    Download the installer, currently "ati-driver-installer-8-01-x86.x86_64.run"
    cd to the download directory

    # apt-get install module-assistant build-essential fakeroot dh-make debconf libstdc++5 gcc-3.3-base linux-headers-$(uname -r) gcc autoconf automake1.9 libtool flex bison cvs

    # chmod +x ati-driver-installer-8-01-x86.x86_64.run

    # ./ati-driver-installer-8-01-x86.x86_64.run --buildpkg Debian/etch

    # dpkg -i *.deb

    # cd /usr/src

    # m-a build fglrx

    # m-a install fglrx (also tried it in one command #m-a a-i fglrx)

    #aticonfig --initial

    I've tried a few variations of that list of commands which include adding symlinks and not using module assistant but compiling and moving the fglrx.ko manually. Some guides I've tried..

    http://ubuntuforums.org/showthread.php?t=24557
    http://technowizah.com/2006/10/debia...i-drivers.html
    http://wiki.cchtml.com/index.php/Deb...allation_Guide
    http://linuxized.blogspot.com/2007/0...gl-compiz.html

    I gave Envy a go with the same results. That was the only method I tried that had errors, but those were md5 mismatch errors when downloading the ati installer. So far no matter what install method I try, when I type "fglrxinfo" I get..

    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.5.1)

    This is an entry from the xorg.0.log

    (II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
    (II) fglrx(0): detected X.org 7.1.1.0
    (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed! *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO) *
    (WW) fglrx(0): * no 3D acceleration available *
    (WW) fglrx(0): ********************************************* *

    That entry is from Debian, the other distributions just hard lock.

    Upon searching more I found a post here that boasts a solution..

    http://linuxmint.com/forum/viewtopic.php?t=6317

    However that solution does not work with Ubuntu gutsy or Debian etch. With gutsy I got the hard locked black screen, for both repository drivers and the current ones from ATI, and Debian just defaults to mesa. I think Lolo Uila is on the right track of bypassing the recognition of the R570 chip as a PCIe bus. This past few weeks I've read alot of into about the ati proprietary drivers, compiling a kernel with agp support (CONFIG_AGP), and native PCIe gpu's that use adapters for the AGP bus. But I've found nothing that can help me so far.

    Some spec's on my system... ASUS p4c800e-deluxe, p4 3.2Ghz, 1024mb DDR, 8x AGP Sapphire x1950Pro 512mb GDDR3.

    Does anyone have any ideas of how blacklisting fools the Mint clone into recognizing the card correctly? Or how I can have the same effect on Debian, or Ubuntu if necessary?

    Any help on this is GREATLY appreciated.

    THANKS in advance!

  2. #2
    Join Date
    Jan 2008
    Posts
    3

    Default

    [SOLVED] With the new ATI drivers version ati-driver-installer-8-02-x86.x86_64.run,
    everything installs as it should, and I can get 3D acceleration for a native Linux version of Quake 3 Arena, and Guild Wars running through Wine's latest version. I haven't tested Compiz yet, but I'm sure with fuzion it should work ok. The three operating systems I have had success with are Ubuntu/gutsy Debian/etch and Debian /lenny. I haven't tested Fedora, or Slackware yet. Hope this helps someone. For installation on either of those 3 o/s's follow this guide ..
    http://wiki.cchtml.com/index.php/Main_Page
    and pick your distribution from the column on the right.

  3. #3
    Join Date
    Jan 2008
    Posts
    3

    Default

    SOLVED...

    The latest ATI driver, ati-driver-installer-8-02-x86.x86_64.run seems to work. I've tested it on Ubuntu-Gutsy, and Debian-Etch and Lenny. So far it seems to work as it should, I can get 3D acceleration on a native Linux version on Quake 3 Arena, and on Guild Wars running through Wine's latest version. I haven't tested anything Compiz yet, or any different distributions. For installing follow this guide,

    http://wiki.cchtml.com/index.php/Main_Page

    Hope this helps someone that also has this pain of a video card.

  4. #4

    Default

    Hello,

    I hope you can help me!
    I installed Gutsy (32Bit version) and envy (to install the latest drivers) and wine and it will not work ...
    I edited the missing parts in the xorg.conf and restarted, but no matter what I do wine throws an exception when I start Guild Wars.

    Pleeeease help me! )

    This is the call:
    env WINEPREFIX="/home/tt/.wine" wine "C:\Programme\GUILD WARS\Gw.exe" -windowed -noshaders

    I can send you the errors via mail, I cant't post that much stuff here!

    Help is very much appreciated!

    TT

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •