Running RHEL6 workstation 2.6.32-71.el6.x86_64 with a Firepro V7900. I'm moving away from windows, thus this is my first *nix kit. I currently have 2monitors, but will eventually have 4. I'm having quite a difficult time getting the multi-monitor setup to work properly.

Base RHEL install video driver works with only a single monitor. I then installed v8.911.3.1 of AMD's proprietary driver. This gave me both screens and after enabling Xinerama I was able to drag windows between the two screens. However, performance was quite sloppy. So I went to google assuming it was something I was doing wrong. I found and applied the setting "export CLUTTER_VBLANK=none" in my /etc/profile. Not much improvement. Also found the xf86-video-ati which I'm not sure whether or not I need.

I know this is a powerful card and I should be getting better performance than I'm getting. Unfortunately, AMD's linux supported documentation stinks.

Here's a copy of my xorg.conf created by AMD's prop driver.

Code:
Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
        Screen         "amdcccle-Screen[15]-1" 1920 0
EndSection

Section "Module"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Monitor"
        Identifier   "0-DFP1"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
        Option      "PreferredMode" "1920x1200"
        Option      "TargetRefresh" "60"
        Option      "Position" "0 0"
        Option      "Rotate" "normal"
        Option      "Disable" "false"
EndSection

Section "Monitor"
        Identifier   "0-DFP2"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
        Option      "PreferredMode" "1920x1080"
        Option      "TargetRefresh" "60"
        Option      "Position" "0 0"
        Option      "Rotate" "normal"
        Option      "Disable" "false"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        Option      "Monitor-DFP1" "0-DFP1"
        BusID       "PCI:15:0:0"
EndSection

Section "Device"
        Identifier  "amdcccle-Device[15]-1"
        Driver      "fglrx"
        Option      "Monitor-DFP2" "0-DFP2"
        BusID       "PCI:15:0:0"
        Screen      1
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Section "Screen"
        Identifier "amdcccle-Screen[15]-1"
        Device     "amdcccle-Device[15]-1"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
Any help would be appreciated.