Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22

Thread: An Updated Look At Radeon Gallium3D 2D Color Tiling

  1. #21
    Join Date
    May 2007
    Posts
    231

    Default

    Quote Originally Posted by pingufunkybeat View Post
    Jerome, you're probably right, but I'm having the same thing here (Linux 3.3 vanilla, libdrm, mesa and xf86-video-ati all from git yesterday, HD 4550). I'm running the vanilla 3.3 kernel and don't remember now whether that has tiling patches in it, so it COULD be a different bug (see also http://phoronix.com/forums/showthrea...356#post254356).

    Any suggestions for where to start looking for problems?
    Again open bugs, attach api trace of problematic gl application, or provide a use case with open source gl application, gave GPU version and all Xorg / kernel log revealent.

  2. #22
    Join Date
    Jun 2009
    Posts
    2,927

    Default

    Hrm, while trying to put together a bug report, I narrowed it down to R600_STREAMOUT. Resetting that gave me GL 2.1 again and everything works now.

    Older Mesa versions worked fine, and reported GL 3.0.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •