Results 1 to 10 of 10

Thread: Driver Problems

  1. #1
    Join Date
    Dec 2007
    Posts
    39

    Default Driver Problems

    Hey all
    OS = Ubuntu 7.10 (32bit)
    GPU = X1600
    Driver = ATi 7.11

    Problem =

    fglrxinfo -display :0 gives
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: Radeon X1600 Series
    OpenGL version string: 2.1.7059 Release

    Which is nice to see, but.

    fglrxinfo -display :1 gives
    display: :1.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (2.1 Mesa 7.0.1)

    glxinfo also tells me Mesa and display 1.0

    I think I'm running on Display 1.0 not 0.0 because I don't have any direct rendering.

    How can I change it from display 1.0 to display 0.0?
    I have my xorg.conf the Xorg.0.log handy if you want it.

    Cheers,
    Basil.

  2. #2
    Join Date
    Oct 2007
    Posts
    321

    Default

    Mind giving some information on the system setup, and have you enabled dual monitor support yet?

  3. #3
    Join Date
    Dec 2007
    Posts
    39

    Default

    Sure thing.

    Fairly basic rig, nothing special.

    Using a 17" CRT monitor.

    Yeah, pretty much I've just kept it basic.

    Getting a sound card soon, or a TV capture card.

  4. #4
    Join Date
    Oct 2007
    Posts
    51

    Default

    So how did you install the driver?

    Did you run it as

    sh ati-driver-installer-8.42.3-x86.x86_64.run

    or did you use the buildpkg to create ubuntu debs?, and the install it .


    And if you can the xorg.conf and the xorg.0.log would be helpfull

  5. #5
    Join Date
    Oct 2007
    Posts
    321

    Default

    teroedni, that is not always the best solution, i prefer to use the method 2 they put on the unofficial wiki for this page, which does the same thing, without fail... ( keep in mind he has to have the right packages to build the kernel module. )
    http://wiki.cchtml.com/index.php/Ubu...allation_Guide

  6. #6
    Join Date
    Dec 2007
    Posts
    39

    Default

    I went through the wiki and installed it that way, with the debs.

    Code:
    Section "ServerLayout"
    
    	# Uncomment if you have a wacom tablet
    	#	InputDevice     "stylus"	"SendCoreEvents"
    	#	InputDevice     "cursor"	"SendCoreEvents"
    	#	InputDevice     "eraser"	"SendCoreEvents"
    	Identifier     "Default Layout"
    	Screen      0  "aticonfig-Screen[0]" 0 0
    	InputDevice    "Generic Keyboard"
    	InputDevice    "Configured Mouse"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
    	Load  "dri"
    	Load  "glx"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Generic Keyboard"
    	Driver      "kbd"
    	Option	    "CoreKeyboard"
    	Option	    "XkbRules" "xorg"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "us"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Configured Mouse"
    	Driver      "mouse"
    	Option	    "CorePointer"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "Protocol" "ImPS/2"
    	Option	    "ZAxisMapping" "4 5"
    	Option	    "Emulate3Buttons" "true"
    EndSection
    
    Section "InputDevice"
    	Identifier  "stylus"
    	Driver      "wacom"
    	Option	    "Device" "/dev/input/wacom"
    	Option	    "Type" "stylus"
    	Option	    "ForceDevice" "ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Identifier  "eraser"
    	Driver      "wacom"
    	Option	    "Device" "/dev/input/wacom"
    	Option	    "Type" "eraser"
    	Option	    "ForceDevice" "ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Identifier  "cursor"
    	Driver      "wacom"
    	Option	    "Device" "/dev/input/wacom"
    	Option	    "Type" "cursor"
    	Option	    "ForceDevice" "ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]"
    	Driver      "fglrx"
    	BusID       "PCI:1:0:0"
    	Option	    "VideoOverlay" "on"
    	Option	    "OpenGLOverlay" "off"
    	Option      "TexturedXrender" "true"
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]"
    	Device     "aticonfig-Device[0]"
    	Monitor    "aticonfig-Monitor[0]"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    Section "DRI"
    	Mode 0666
    EndSection
    Ran out of character space, I'll post it somewhere else.

  7. #7
    Join Date
    Oct 2007
    Posts
    321

    Default

    ok... that looks fine... is the kernel module loaded... all you need to type is this in the terminal to check:

    lsmod | grep fglrx.

  8. #8
    Join Date
    Dec 2007
    Posts
    39

    Default

    tarmael@melchior:~$ lsmod | grep fglrx
    fglrx 1481708 36
    agpgart 35016 2 fglrx,ati_agp

    I'm not liking the ati_agp thing.

  9. #9
    Join Date
    Dec 2007
    Posts
    39

    Default

    I'll test the new drivers and come back if/when I have any problems.

    Cheers for your help so far.

  10. #10
    Join Date
    Dec 2007
    Posts
    39

    Default

    Fixed it.

    Just had to remove xgl from my compy.

    Cheers for your help.

    Cheers,
    Bas.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •