Results 1 to 4 of 4

Thread: Linux Cedar View support

  1. #1
    Join Date
    Feb 2012
    Posts
    1

    Default Linux Cedar View support

    I there, I've bought an Intel N10 board that carries the new GMA3600 GPU built in, but graphics support in linux sucks!

    And I'm having real troubles in having a linux distibution that simply is able to work...

    I've tried ubuntu 11.10, sabayon 7, fedora 16, tried poulsbo driver and nothing!
    Three different sets of kernel, 3.0, 3.1, 3.3-rc2, the latest crashes with gma500_gfx enabled!

    I don't know if I've done anything wrong or not, there's not much talk/guides around the Internet.

    Can someone give some points/recommendations how can I have HW acelerated FB!?

    Does Intel EMGD driver supports this platform, it doesn't state there?

    What open source solutions do I have?

  2. #2
    Join Date
    Feb 2012
    Posts
    1

    Default

    I am working through the same issues on the Intel DN2800MT board with integrated GMA3600 graphics.

    I have also tried many of the distro's you listed and have been unsuccessful as well. I'm currently working on an FC16 platform and am compiling the vanilla 3.3-rc3 kernel with experimental support for the GMA3600 under the GMA500 driver. I have the following (relating to the GMA500 config) set in my .config...

    CONFIG_DRM_GMA500=m
    CONFIG_DRM_GMA3600=y
    # CONFIG_DRM_GMA600 is not set
    # CONFIG_STUB_POULSBO is not set

    I previously compiled in the STUB and GMA600 support and the system crashed as X started (I wasnt able to capture any logs). I'm hoping this new config will prove more stable.

    The PNP ID for my GMA3600 is 8086:0be2 and lspci states that is it rev 09. What is the PNP for the device you are working on? Also, have you had any success? My goal at this point is getting support for common display resolutions.

  3. #3
    Join Date
    Feb 2012
    Posts
    11

    Default Tomorrow: The Laid Back Strategy

    My plan is http://www.phoronix.com/vr.php?view=MTA1ODI as soon as I can get a DN2800MT. Tomorrow is another day and MeeGo is likely not my ultimate destination. If necessary, Intel will find folks smarter than I to show just how easy this can be in due course.

  4. #4
    Join Date
    Apr 2012
    Posts
    1

    Default

    Let me apologize for my poor English,I`m not a native speaker.

    I compiled the kernel 3.3.1 with :

    CONFIG_DRM_GMA500=m
    CONFIG_DRM_GMA3600=y
    # CONFIG_DRM_GMA600 is not set
    # CONFIG_STUB_POULSBO is not set

    in .config,but still can`t get support with GMA 3600(my cpu is atom N2800, Ubuntu 12.04 beta2)

    my resolution still locks in 4 modes, the highest one is 1280x1024.

    The N2800 is driving me crazy,my last chance seems like MeeGo.

    Is there some one use kernel 3.3 and Ubuntu to make GMA 3600 work fine?

    I need some step by step help. : (

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •