Page 2 of 8 FirstFirst 1234 ... LastLast
Results 11 to 20 of 77

Thread: Catalyst 7.12 - PreInitDAL failed

  1. #11
    Join Date
    Dec 2007
    Posts
    25

    Default

    I had the very same problem ("PreInitDAL failed", after EDID data), with my new Sapphire Radeon HD 3870 (PCI-Express).

    I was using uvesafb. After seeing http://gentoo-wiki.com/HOWTO_ATI_Dri...InitDAL_failed, I deactivated it (at boot... no need to remove it from the kernel). It now works without problem (as per `glxinfo` and `glxgears`).
    Well, I don't think that deactivating the framebuffer will solve the problem [for all]... I tried that too (vesafb), but I wasn't lucky... It continued without working...

    Snake, that's true, its not AGP-specific, my HD2400 is for pcie...

    I'll add the output of /var/log/Xorg.0.log later, please tell me if it is necessary to post any other files...

    Thanks in advance for all your help...

  2. #12
    Join Date
    Oct 2007
    Posts
    73

    Default

    Quote Originally Posted by Snake View Post
    I do not think this is AGP-specific, because I get the same error with the x1400 PCIe on my Lenovo Z61m when using an external (analog connected) 1680x1050 LCD.

    When I unplug the external LCD X starts without errors, but with the known problem using 1280x1024 on the internal 1680x1050 panel.
    I'm using an external LCD monitor through a DVI connector, I can't try any other monitors.

    An ebuild for 7.12 has appeared in the untested tree of Gentoo's portage, I tried it but have the same error.
    Last edited by Crunchy; 12-21-2007 at 08:04 AM.

  3. #13
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    39

    Default

    I've got no framebuffer support in kernel, so I assume this is yet another side effect of the somehow broken EDID data handling that also makes it impossible to use 1680x1050 with 7.12 on my hardware.

    Anyways, previous driver versions seemed to support 1680x1050 only because this resolution was explicitly reported by EDID. I was never able to get any other widescreen resolution like 1440x900 with fglrx.

  4. #14
    Join Date
    Aug 2007
    Posts
    6,630

    Default

    Well it is a bit stupid to release a driver without proper edid support together with broken modeline support. For nvidia edid does not always work too, but there are override options and modelines do work if needed...

  5. #15
    Join Date
    Jul 2007
    Location
    Seoul, Korea
    Posts
    22

    Default same problem

    Code:
    (II) fglrx(0): Serial No:  TY  33333333
    (II) fglrx(0): Monitor name: PHILIPS 200P4
    (II) fglrx(0): Ranges: V min: 56  V max: 85 Hz, H min: 30  H max: 92 kHz, PixClock max 160 MHz
    (II) fglrx(0): EDID (in hex):
    (II) fglrx(0):  00ffffffffffff00410c1908d2040000
    (II) fglrx(0):  0f0d01039f291f78ee60e5a3574b9c25
    (II) fglrx(0):  115054bfef0431ca314a454a614c8180
    (II) fglrx(0):  a94001010101f00ad0b420e02d10126c
    (II) fglrx(0):  a20098321100001e000000ff00205459
    (II) fglrx(0):  20203333333333333333000000fc0050
    (II) fglrx(0):  48494c495053203230305034000000fd
    (II) fglrx(0):  0038551e5c10000a2020202020200062
    (II) fglrx(0): End of Display1 EDID data --------------------
    (WW) fglrx(0): Only one display is connnected,so single mode is enabled
    (EE) fglrx(0): PreInitDAL failed
    how can i do?

  6. #16
    Join Date
    Dec 2007
    Posts
    25

    Default

    Hi! Well as I promised... Here is the output of /var/log/Xorg.0.log.

    Xorg.0.log

    I'm not using 1680x1050 resolution, my display is working at 1152x864.

  7. #17
    Join Date
    Nov 2007
    Posts
    35

    Default

    Hmm I also have encountered this problem with 7.12. Thought it was the dvi but I tried vga also and it still didn't work. Hopefully someone has a solution to this soon.

  8. #18
    Join Date
    Jun 2007
    Posts
    406

    Default

    An ebuild for 7.12 has appeared in the untested tree of Gentoo's portage, I tried it but have the same error.
    the ebuild works fine for me on 4 different ati powered pcs.
    the problem of the initdal failed on gentoo is fixed with:

    eselect opengl set ati
    dispatch-conf
    with updating every new file to the last. (use etc-update or whatever you prefer instead of dispatch-conf if you want).

    i've had the same issue, but after that it's fixed.
    if it still isn't fixed try removing all the vesafb and vga options passed to the kernel in the /boot/grub/menu.lst and the fbsplash.

    for the resolution issue try the following:
    add the proper modes (like these

    Depth 24
    Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    )
    and then add a virtual desktop with this:
    ViewPort 0 0
    Virtual 1600 1200
    this would put a virtual desktop of 1600x1200 on the display 0:0 which normally is used for xorg. the possible result would be 2:
    1. the driver reads the mode for 1600x1200 and puts the virtual display and everything goes fine
    2. the driver doesn't read the mode for 1600x1200 and puts the virtual for 1600x1200 isntead.
    if your case is the second then we have to think of something else.
    ps.@rainbyte as i've seen from your log you could try setting one mode for all the 3 bits 24, 15, 8 to
    1280x960 @70hz
    that's what your manufacturer has set for your monitor and what the driver finds out from its edid.

    I've got no framebuffer support in kernel, so I assume this is yet another side effect of the somehow broken EDID data handling that also makes it impossible to use 1680x1050 with 7.12 on my hardware.

    Anyways, previous driver versions seemed to support 1680x1050 only because this resolution was explicitly reported by EDID. I was never able to get any other widescreen resolution like 1440x900 with fglrx.
    try setting 1440x900 as the greatest resolution in your modes and the driver should use that. for what i know it should use the most advanced specified into the modes lines.

  9. #19
    Join Date
    Oct 2007
    Posts
    73

    Default

    Quote Originally Posted by givemesugarr View Post
    the ebuild works fine for me on 4 different ati powered pcs.
    the problem of the initdal failed on gentoo is fixed with:

    eselect opengl set ati
    dispatch-conf
    This does not fix the problem for me. I do the following:

    1) Downgrade to 8.433
    2) eselect opengl set ati
    3) etc-update to update all the files back to 8.433 versions.
    4) Upgrade back to 8.443.1
    5) eselect opengl set ati
    6) etc-update to update all the files to 8.443.1 versions

  10. #20
    Join Date
    Jun 2007
    Posts
    406

    Default

    Quote Originally Posted by Crunchy View Post
    This does not fix the problem for me. I do the following:

    1) Downgrade to 8.433
    2) eselect opengl set ati
    3) etc-update to update all the files back to 8.433 versions.
    4) Upgrade back to 8.443.1
    5) eselect opengl set ati
    6) etc-update to update all the files to 8.443.1 versions
    try downgrade to 8.433. etc-update, revdep-rebuild, etc-update if you have rebuilded something, upgrade 8.433.1, etc-update and chose -3 option, eselect opengl show and if its opengl not on ati set it to ati. see if you have the libGL.so.1 in /usr/lib and if the files of qlist ati-drivers are there. (it will take some minutes to verify all them and doing it with ls -lR /directory >> list.txt would help it. just do a qlist ati-drivers >> qlist.txt and open the 2 files in text editor to see if there are problems).
    if everything is ok, then comment everything in your section device, with th exception of the capabilities lines and of the opengloverlay and videooverlay and kernelparam. try starting xorg with /etc/init.d/xdm start.
    if it gives you the same error, remove the lines of the framebuffer splash in /boot/grub/menu.lst or /boot/grub/grub.conf (is one or the other not both).
    the options to remove are:
    all options with vga and vesaxxx inside.
    then init 6 and go in interactive mode, skip xdm and then start it manually. at that time it should definitively work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •