Page 4 of 8 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 77

Thread: Catalyst 7.12 - PreInitDAL failed

  1. #31
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    365

    Default

    what modules do you load in section modules in your xorg.conf?what modules do you load in section modules in your xorg.conf?
    http://www.phoronix.com/forums/showthread.php?t=7044
    See this Thread. The same problem occurs on Gentoo and Fedora, maybe I'll also try it on Debian but I don't think it'll be other there.

    My modules in Gentoo are glx, dri, dbe and freetype, which worked perfectly with 8.43.
    In Fedora I only load glx and dri.

  2. #32
    Join Date
    Jun 2007
    Posts
    406

    Default

    Quote Originally Posted by NeoBrain View Post
    http://www.phoronix.com/forums/showthread.php?t=7044
    See this Thread. The same problem occurs on Gentoo and Fedora, maybe I'll also try it on Debian but I don't think it'll be other there.

    My modules in Gentoo are glx, dri, dbe and freetype, which worked perfectly with 8.43.
    In Fedora I only load glx and dri.
    assure that you have
    Section "DRI"
    Group "video"
    Mode 0660
    EndSection
    and
    Option "no_accel" "no"
    Option "no_dri" "no"
    in your section device.
    this should do

  3. #33
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    365

    Default

    ...Did that, but first have to reinstall 8.44

    EDIT: nope, doesn't work, same errors.
    Last edited by NeoBrain; 12-23-2007 at 10:29 AM.

  4. #34
    Join Date
    Jun 2007
    Posts
    406

    Default

    Quote Originally Posted by NeoBrain View Post
    ...Did that, but first have to reinstall 8.44

    EDIT: nope, doesn't work, same errors.
    the last thing you could try is removing the kernel agpgart and set useinternalagpgart to yes. here http://debian.wgdd.de/temp/fglrx_man/fglrx.4x.html
    you can have more info about ati agp setting in xorg.conf. maybe the problem is related to the wrong agpgart use.

  5. #35
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    365

    Default

    I have have tried that to before, but it neither worked..
    I'll play around with the AGP options a bit when I have some free time again.

  6. #36
    Join Date
    Jun 2007
    Posts
    406

    Default

    I'll play around with the AGP options a bit when I have some free time again.
    remember that you'll have to remove the kernel agpgart before using the internal one. else it will not work.

  7. #37
    Join Date
    Oct 2007
    Posts
    73

    Default

    Quote Originally Posted by givemesugarr View Post
    remember that you'll have to remove the kernel agpgart before using the internal one. else it will not work.
    My genkernel test was a disaster, X crashes on startup no matter what version of fglrx I used.

  8. #38
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    365

    Default

    Oh well, that's nice to see... fglrx doesn't accept using it's own agpgart anymore...
    My Xorg.log says that the Option "useInternalAGPGART" is set to "yes" but later it says that it doesn't use the build-in one...

  9. #39
    Join Date
    Jun 2007
    Posts
    406

    Default

    My genkernel test was a disaster, X crashes on startup no matter what version of fglrx I used.
    genkernel should never be used. it's the worst configurator that i've seen... it's really awful...

    My Xorg.log says that the Option "useInternalAGPGART" is set to "yes" but later it says that it doesn't use the build-in one...
    you have to force if the things are as this.

    try setting these after you're sure to have removed the agpgart module and the modules that need it from the kernel:

    Option "BusType" "AGP" #set this only if you're sure to have an agp card, otherwise might happen hw problems.
    Option "ForceGenericCPU" "no" #we try to tell the driver to use its gpu
    Option "KernelModuleParm" "agpgart=0" # we tell the driver to use its internal agpgart
    Option "KernelModuleParm" "agp_try_unsupported=1" #we use this later to try fixing the agpgart stuff not loading by setting the try unsupported chipsets.

    with these it should work.

  10. #40
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    365

    Default

    Well, I have completely removed the agpgart module and now fglrx says it can't find the agpgart module.
    xorg.log:
    (**) fglrx(0): using built in AGPGART module: no
    (**) fglrx(0): KernelModuleParm: "agp_try_unsupported=1"
    (**) fglrx(0): ATI GART size: 256 MB
    (II) fglrx(0): [pci] find AGP GART
    (EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
    (EE) fglrx(0): cannot init AGP
    My Device section in xorg.conf so far is:
    Section "Device"

    # Driver "radeonhd"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    Option "MaxGARTSize" "256"
    Option "UseInternalAGPGART" "yes"
    Option "TexturedVideo" "true"
    Option "Textured2D" "true"
    Option "AGPMode" "8"
    Option "UseFastTLS" "2"
    Option "no_accel" "no"
    Option "no_dri" "no"
    Option "KernelModuleParm" "agpgart=0"
    Option "KernelModuleParm" "agp_try_unsupported=1"
    Option "BusType" "AGP"
    Option "ForceGenericCPU" "no"
    EndSection

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •