Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Can't build Kernel Modules in F8

Hybrid View

  1. #1
    Join Date
    Dec 2007
    Posts
    17

    Default Can't build Kernel Modules in F8

    Hi Everyone,

    I'm running 32-bit Fedora 8 with a X1800XL and am having a problem building the kernel modules for 7.12. I've always used the installer to build the modules before for prior releases without any problems until now [sh ati-installer.run --buildpkg Fedora/F8].

    Below is the failure output:

    Code:
    Package build failed!
    Package build utility output:
    Building target platforms: i386
    Building for target i386
    Executing(%prep): /bin/sh -e /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/rpm-tmp.86704
    + umask 022
    + cd /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/BUILD
    + LANG=C
    + export LANG
    + unset DISPLAY
    + cd /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/BUILD
    + cd ATI-fglrx-8.443.1
    ++ /usr/bin/id -u
    + '[' 500 = 0 ']'
    ++ /usr/bin/id -u
    + '[' 500 = 0 ']'
    + /bin/chmod -Rf a+rX,u+w,g-w,o-w .
    + exit 0
    Executing(%build): /bin/sh -e /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/rpm-tmp.86704
    + umask 022
    + cd /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/BUILD
    + cd ATI-fglrx-8.443.1
    + LANG=C
    + export LANG
    + unset DISPLAY
    + exit 0
    Executing(%install): /bin/sh -e /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/rpm-tmp.86704
    + umask 022
    + cd /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/BUILD
    + cd ATI-fglrx-8.443.1
    + LANG=C
    + export LANG
    + unset DISPLAY
    + rm -rf /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo
    + '[' -d /etc/ld.so.conf.d ']'
    + mkdir -p /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/etc/ld.so.conf.d
    + pushd /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/etc/ld.so.conf.d
    /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/etc/ld.so.conf.d /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/BUILD/ATI-fglrx-8.443.1
    + cat
    + popd
    /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/BUILD/ATI-fglrx-8.443.1
    + mkdir -p /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/usr/share/applications
    + pushd /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/usr/share/applications
    /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/usr/share/applications /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/BUILD/ATI-fglrx-8.443.1
    + cat
    + popd
    /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/BUILD/ATI-fglrx-8.443.1
    + cp -pR /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/BUILD/ATI-fglrx-8.443.1/etc /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/BUILD/ATI-fglrx-8.443.1/lib /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/BUILD/ATI-fglrx-8.443.1/usr /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo
    + find /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/usr/share/doc -type f -perm 0555 -exec chmod 0644 '{}' ';'
    + find /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo -type f -perm 0555 -exec chmod 0755 '{}' ';'
    + export AS_USER=y
    + AS_USER=y
    + pushd /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/lib/modules/fglrx/build_mod
    /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/lib/modules/fglrx/build_mod /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/BUILD/ATI-fglrx-8.443.1
    + bash make.sh verbose
    ATI module generator V 2.0
    ==========================
    initializing...
    make.sh: line 537: [: =: unary operator expected
    OsRelease=2.6.23.9-85.fc8
    major=2
    minor=6
    patch=23
    extra=.9-85.fc8
    SMP=1
    smp=-SMP
    iii=
    AGP=1
    CC=gcc
    cc_version=
    cleaning...
    patching 'highmem.h'...
    assuming new VMA API since we do have kernel 2.6.x...
     Assuming default VMAP API
     Assuming default munmap API
    doing Makefile based build for kernel 2.6.x and higher
    make -C /lib/modules/2.6.23.9-85.fc8/build SUBDIRS=/tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/lib/modules/fglrx/build_mod/2.6.x modules
    make[1]: Entering directory `/usr/src/kernels/2.6.23.9-85.fc8-i686'
      CC [M]  /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
    /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_check_pci':
    /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1953: warning: 'pci_find_slot' is deprecated (declared at include/linux/pci.h:481)
    /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_pci_find_slot':
    /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2842: warning: 'pci_find_slot' is deprecated (declared at include/linux/pci.h:481)
      LD [M]  /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/lib/modules/fglrx/build_mod/2.6.x/fglrx.o
      Building modules, stage 2.
      MODPOST 1 modules
      CC      /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
      LD [M]  /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
    make[1]: Leaving directory `/usr/src/kernels/2.6.23.9-85.fc8-i686'
    build succeeded with return value 0
    duplicating results into driver repository...
    done.
    ==============================
    You must change your working directory to /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/lib/modules/fglrx
    and then call ./make_install.sh in order to install the built module.
    ==============================
    + mkdir -p /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/lib/modules/2.6.23.9-85.fc8/extra
    + install -D -m 0644 fglrx.ko /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/lib/modules/2.6.23.9-85.fc8/extra/fglrx/fglrx.ko
    + rm -rf /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo/lib/modules/fglrx
    + popd
    /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/BUILD/ATI-fglrx-8.443.1
    + /usr/lib/rpm/check-buildroot
    + /usr/lib/rpm/redhat/brp-compress
    + /usr/lib/rpm/redhat/brp-strip /usr/bin/strip
    + /usr/lib/rpm/redhat/brp-strip-static-archive /usr/bin/strip
    + /usr/lib/rpm/redhat/brp-strip-comment-note /usr/bin/strip /usr/bin/objdump
    + /usr/lib/rpm/brp-python-bytecompile
    + /usr/lib/rpm/redhat/brp-python-hardlink
    + /usr/lib/rpm/redhat/brp-java-repack-jars
    Processing files: ATI-fglrx-8.443.1-1.f8
    Provides: config(ATI-fglrx) = 8.443.1-1.f8 fglrx_dri.so fglrx_drv.so glesx.so libGL.so.1 libfglrx_dm.so.1.0 libfglrx_gamma.so.1 libfglrx_pp.so.1.0 libfglrx_tvout.so.1 libfglrxdrm.so
    Requires(interp): /bin/sh /bin/sh /bin/sh
    Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    Requires(post): /bin/sh /sbin/chkconfig /sbin/ldconfig
    Requires(preun): /bin/sh /sbin/chkconfig /sbin/service
    Requires(postun): /bin/sh /sbin/ldconfig /sbin/service
    Requires: /bin/bash /bin/sh config(ATI-fglrx) = 8.443.1-1.f8 kernel-module-ATI-fglrx-2.6.23.9-85.fc8 = 8.443.1-1.f8 libGL.so.1 libX11.so.6 libXext.so.6 libXrandr.so.2 libXrender.so.1 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.2) libc.so.6(GLIBC_2.2.3) libdl.so.2 libdl.so.2(GLIBC_2.0) libdl.so.2(GLIBC_2.1) libfglrx_dm.so.1.0 libfglrx_gamma.so.1 libfglrx_pp.so.1.0 libfglrx_tvout.so.1 libgcc_s.so.1 libgcc_s.so.1(GCC_3.0) libm.so.6 libm.so.6(GLIBC_2.0) libpthread.so.0 libpthread.so.0(GLIBC_2.0) libpthread.so.0(GLIBC_2.1) libpthread.so.0(GLIBC_2.2) librt.so.1 librt.so.1(GLIBC_2.2) system-config-display
    Conflicts: fglrx fglrx-glc22 fglrx_4_3_0 fglrx_6_8_0 kernel-module-fglrx ati-fglrx ati-fglrx-devel kmod-fglrx xorg-x11-drv-fglrx xorg-x11-drv-fglrx-devel nvidia-glx nvidia-glx-legacy xorg-x11-drv-nvidia xorg-x11-drv-nvidia-legacy
    Processing files: ATI-fglrx-control-center-8.443.1-1.f8
    Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    Requires: ATI-fglrx = 8.443.1-1.f8 libGL.so.1 libICE.so.6 libSM.so.6 libX11.so.6 libXcursor.so.1 libXext.so.6 libXi.so.6 libXrandr.so.2 libXrender.so.1 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.2) libdl.so.2 libdl.so.2(GLIBC_2.0) libdl.so.2(GLIBC_2.1) libfontconfig.so.1 libfreetype.so.6 libgcc_s.so.1 libgcc_s.so.1(GCC_3.0) libgcc_s.so.1(GLIBC_2.0) libm.so.6 libm.so.6(GLIBC_2.0) libm.so.6(GLIBC_2.1) libm.so.6(GLIBC_2.2) libpthread.so.0 libpthread.so.0(GLIBC_2.0) libpthread.so.0(GLIBC_2.1) libpthread.so.0(GLIBC_2.2) libstdc++.so.5 libstdc++.so.5(CXXABI_1.2) libstdc++.so.5(GLIBCPP_3.2)
    Processing files: ATI-fglrx-devel-8.443.1-1.f8
    Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    Requires: /usr/include/GL ATI-fglrx = 8.443.1-1.f8 libGL.so.1
    Processing files: kernel-module-ATI-fglrx-2.6.23.9-85.fc8-8.443.1-1.f8
    Requires(interp): /bin/sh /bin/sh
    Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    Requires(post): /bin/sh
    Requires(postun): /bin/sh
    Checking for unpackaged file(s): /usr/lib/rpm/check-files /tmp/ATI-fglrx-8.443.1-1-10182-uquevedo/tmp/ATI-fglrx-8.443.1-1.f8-root-uquevedo
    error: Installed (but unpackaged) file(s) found:
       /etc/ati/amdpcsdb.default
    
    
    RPM build errors:
        Installed (but unpackaged) file(s) found:
       /etc/ati/amdpcsdb.default
    Removing temporary directory: fglrx-install.Y10047
    Has anyone else run into this yet, and if so how did you overcome the error [if you did]?

  2. #2
    Join Date
    Dec 2007
    Posts
    2

    Default Same Here with X1300 and F8

    The same problem:
    I did the download twice. And the check is ok.

    [root@protheus05 Desktop]# ./ati-driver-installer-8.443.1-x86.x86_64.run -c
    Verifying archive integrity... MD5 checksums are OK. All good.
    [root@protheus05 Desktop]# ./ati-driver-installer-8.443.1-x86.x86_64.run --buildpkg Fedora/F8
    Created directory fglrx-install.dr7984
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.443.1
    ATI Technologies Linux Driver Installer/Packager
    ==================================================
    Generating package: Fedora/F8
    Package build failed!
    Package build utility output:
    Building target platforms: i386
    Building for target i386
    Executing(%prep): /bin/sh -e /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/rpm-tmp.89036
    + umask 022
    + cd /tmp/ATI-fglrx-8.443.1-1-8061-root/BUILD
    + LANG=C
    + export LANG
    + unset DISPLAY
    + cd /tmp/ATI-fglrx-8.443.1-1-8061-root/BUILD
    + cd ATI-fglrx-8.443.1
    ++ /usr/bin/id -u
    + '[' 0 = 0 ']'
    + /bin/chown -Rhf root .
    ++ /usr/bin/id -u
    + '[' 0 = 0 ']'
    + /bin/chgrp -Rhf root .
    + /bin/chmod -Rf a+rX,u+w,g-w,o-w .
    + exit 0
    Executing(%build): /bin/sh -e /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/rpm-tmp.89036
    + umask 022
    + cd /tmp/ATI-fglrx-8.443.1-1-8061-root/BUILD
    + cd ATI-fglrx-8.443.1
    + LANG=C
    + export LANG
    + unset DISPLAY
    + exit 0
    Executing(%install): /bin/sh -e /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/rpm-tmp.89036
    + umask 022
    + cd /tmp/ATI-fglrx-8.443.1-1-8061-root/BUILD
    + cd ATI-fglrx-8.443.1
    + LANG=C
    + export LANG
    + unset DISPLAY
    + rm -rf /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root
    + '[' -d /etc/ld.so.conf.d ']'
    + mkdir -p /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/etc/ld.so.conf.d
    + pushd /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/etc/ld.so.conf.d
    /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/etc/ld.so.conf.d /tmp/ATI-fglrx-8.443.1-1-8061-root/BUILD/ATI-fglrx-8.443.1
    + cat
    + popd
    /tmp/ATI-fglrx-8.443.1-1-8061-root/BUILD/ATI-fglrx-8.443.1
    + mkdir -p /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/usr/share/applications
    + pushd /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/usr/share/applications
    /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/usr/share/applications /tmp/ATI-fglrx-8.443.1-1-8061-root/BUILD/ATI-fglrx-8.443.1
    + cat
    + popd
    /tmp/ATI-fglrx-8.443.1-1-8061-root/BUILD/ATI-fglrx-8.443.1
    + cp -pR /tmp/ATI-fglrx-8.443.1-1-8061-root/BUILD/ATI-fglrx-8.443.1/etc /tmp/ATI-fglrx-8.443.1-1-8061-root/BUILD/ATI-fglrx-8.443.1/lib /tmp/ATI-fglrx-8.443.1-1-8061-root/BUILD/ATI-fglrx-8.443.1/usr /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root
    + find /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/usr/share/doc -type f -perm 0555 -exec chmod 0644 '{}' ';'
    + find /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root -type f -perm 0555 -exec chmod 0755 '{}' ';'
    + export AS_USER=y
    + AS_USER=y
    + pushd /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/lib/modules/fglrx/build_mod
    /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/lib/modules/fglrx/build_mod /tmp/ATI-fglrx-8.443.1-1-8061-root/BUILD/ATI-fglrx-8.443.1
    + bash make.sh verbose
    ATI module generator V 2.0
    ==========================
    initializing...
    make.sh: line 537: [: =: unary operator expected
    OsRelease=2.6.23.9-85.fc8
    major=2
    minor=6
    patch=23
    extra=.9-85.fc8
    SMP=1
    smp=-SMP
    iii=
    AGP=1
    CC=gcc
    cc_version=
    cleaning...
    patching 'highmem.h'...
    assuming new VMA API since we do have kernel 2.6.x...
    Assuming default VMAP API
    Assuming default munmap API
    doing Makefile based build for kernel 2.6.x and higher
    make -C /lib/modules/2.6.23.9-85.fc8/build SUBDIRS=/tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/lib/modules/fglrx/build_mod/2.6.x modules
    make[1]: Entering directory `/usr/src/kernels/2.6.23.9-85.fc8-i686'
    CC [M] /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
    /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_check_pci':
    /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1953: warning: 'pci_find_slot' is deprecated (declared at include/linux/pci.h:481)
    /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_pci_find_slot':
    /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2842: warning: 'pci_find_slot' is deprecated (declared at include/linux/pci.h:481)
    LD [M] /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/lib/modules/fglrx/build_mod/2.6.x/fglrx.o
    Building modules, stage 2.
    MODPOST 1 modules
    CC /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
    LD [M] /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
    make[1]: Leaving directory `/usr/src/kernels/2.6.23.9-85.fc8-i686'
    build succeeded with return value 0
    duplicating results into driver repository...
    done.
    ==============================
    You must change your working directory to /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/lib/modules/fglrx
    and then call ./make_install.sh in order to install the built module.
    ==============================
    + mkdir -p /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/lib/modules/2.6.23.9-85.fc8/extra
    + install -D -m 0644 fglrx.ko /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/lib/modules/2.6.23.9-85.fc8/extra/fglrx/fglrx.ko
    + rm -rf /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root/lib/modules/fglrx
    + popd
    /tmp/ATI-fglrx-8.443.1-1-8061-root/BUILD/ATI-fglrx-8.443.1
    + /usr/lib/rpm/check-buildroot
    + /usr/lib/rpm/redhat/brp-compress
    + /usr/lib/rpm/redhat/brp-strip /usr/bin/strip
    + /usr/lib/rpm/redhat/brp-strip-static-archive /usr/bin/strip
    + /usr/lib/rpm/redhat/brp-strip-comment-note /usr/bin/strip /usr/bin/objdump
    + /usr/lib/rpm/brp-python-bytecompile
    + /usr/lib/rpm/redhat/brp-python-hardlink
    + /usr/lib/rpm/redhat/brp-java-repack-jars
    Processing files: ATI-fglrx-8.443.1-1.f8
    Provides: config(ATI-fglrx) = 8.443.1-1.f8 fglrx_dri.so fglrx_drv.so glesx.so libGL.so.1 libfglrx_dm.so.1.0 libfglrx_gamma.so.1 libfglrx_pp.so.1.0 libfglrx_tvout.so.1 libfglrxdrm.so
    Requires(interp): /bin/sh /bin/sh /bin/sh
    Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    Requires(post): /bin/sh /sbin/chkconfig /sbin/ldconfig
    Requires(preun): /bin/sh /sbin/chkconfig /sbin/service
    Requires(postun): /bin/sh /sbin/ldconfig /sbin/service
    Requires: /bin/bash /bin/sh config(ATI-fglrx) = 8.443.1-1.f8 kernel-module-ATI-fglrx-2.6.23.9-85.fc8 = 8.443.1-1.f8 libGL.so.1 libX11.so.6 libXext.so.6 libXrandr.so.2 libXrender.so.1 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.2) libc.so.6(GLIBC_2.2.3) libdl.so.2 libdl.so.2(GLIBC_2.0) libdl.so.2(GLIBC_2.1) libfglrx_dm.so.1.0 libfglrx_gamma.so.1 libfglrx_pp.so.1.0 libfglrx_tvout.so.1 libgcc_s.so.1 libgcc_s.so.1(GCC_3.0) libm.so.6 libm.so.6(GLIBC_2.0) libpthread.so.0 libpthread.so.0(GLIBC_2.0) libpthread.so.0(GLIBC_2.1) libpthread.so.0(GLIBC_2.2) librt.so.1 librt.so.1(GLIBC_2.2) system-config-display
    Conflicts: fglrx fglrx-glc22 fglrx_4_3_0 fglrx_6_8_0 kernel-module-fglrx ati-fglrx ati-fglrx-devel kmod-fglrx xorg-x11-drv-fglrx xorg-x11-drv-fglrx-devel nvidia-glx nvidia-glx-legacy xorg-x11-drv-nvidia xorg-x11-drv-nvidia-legacy
    Processing files: ATI-fglrx-control-center-8.443.1-1.f8
    Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    Requires: ATI-fglrx = 8.443.1-1.f8 libGL.so.1 libICE.so.6 libSM.so.6 libX11.so.6 libXcursor.so.1 libXext.so.6 libXi.so.6 libXrandr.so.2 libXrender.so.1 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.2) libdl.so.2 libdl.so.2(GLIBC_2.0) libdl.so.2(GLIBC_2.1) libfontconfig.so.1 libfreetype.so.6 libgcc_s.so.1 libgcc_s.so.1(GCC_3.0) libgcc_s.so.1(GLIBC_2.0) libm.so.6 libm.so.6(GLIBC_2.0) libm.so.6(GLIBC_2.1) libm.so.6(GLIBC_2.2) libpthread.so.0 libpthread.so.0(GLIBC_2.0) libpthread.so.0(GLIBC_2.1) libpthread.so.0(GLIBC_2.2) libstdc++.so.5 libstdc++.so.5(CXXABI_1.2) libstdc++.so.5(GLIBCPP_3.2)
    Processing files: ATI-fglrx-devel-8.443.1-1.f8
    Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    Requires: /usr/include/GL ATI-fglrx = 8.443.1-1.f8 libGL.so.1
    Processing files: kernel-module-ATI-fglrx-2.6.23.9-85.fc8-8.443.1-1.f8
    Requires(interp): /bin/sh /bin/sh
    Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    Requires(post): /bin/sh
    Requires(postun): /bin/sh
    Checking for unpackaged file(s): /usr/lib/rpm/check-files /tmp/ATI-fglrx-8.443.1-1-8061-root/tmp/ATI-fglrx-8.443.1-1.f8-root-root
    error: Installed (but unpackaged) file(s) found:
    /etc/ati/amdpcsdb.default


    RPM build errors:
    Installed (but unpackaged) file(s) found:
    /etc/ati/amdpcsdb.default
    Removing temporary directory: fglrx-install.dr7984

  3. #3
    Join Date
    Dec 2007
    Posts
    17

    Default There is no /etc/ati/amdpcsdb.default in a clean install...

    Hmm...I even did a complete uninstall of the 7.11 driver and even removed the /etc/ati directory just in case and still got the below error.

    Code:
    error: Installed (but unpackaged) file(s) found:
       /etc/ati/amdpcsdb.default
    
    
    RPM build errors:
        Installed (but unpackaged) file(s) found:
       /etc/ati/amdpcsdb.default
    Removing temporary directory: fglrx-install.dr7984[/QUOTE]
    After reading some of the known problems though, I'm not so sure that I want to install the 7.11 driver because my default resolution on my display is 1680x1050. I don't want to be stuck at 1280x1024 if that will be the result of successfully getting 7.12 installed.

    Has anyone else successfully installed 7.12 in Fedora 8 [32-bit or 64-bit]?

  4. #4
    Join Date
    Oct 2007
    Posts
    19

    Default

    It's a bug in their .spec file.
    To quell this error, you can add
    Code:
    %_unpackaged_files_terminate_build 1
    to ~/.rpmmacros or /etc/rpm/macros

  5. #5
    Join Date
    Dec 2007
    Posts
    2

    Default It didn work for me.

    I get the same error. there are lot's of macro.xxx
    in the etc/rpm directory.

    Could you explain how can I install that?

    Thanks,
    Douglas Chagas

  6. #6
    Join Date
    Dec 2007
    Posts
    17

    Default rpmmacros didn't seem to work...or I did it wrong.

    I inserted:
    Code:
    %_unpackaged_files_terminate_build 1
    into a ~/.rpmmacros file, and it didn't work. I looked in /etc/rpm/ there are several macros files:
    Code:
    macros.dist      macros.kde4     macros.qt4
    macros.jpackage  macros.prelink  macros.specspo
    I tried adding the additional line to the macros.dist file but the compile still failed.

    I am curious now to hear if ANYONE has successfully installed the 7.12 release on Fedora 8 [either 32-bit or 64-bit].

    Please respond if you have...

  7. #7
    Join Date
    Oct 2007
    Posts
    19

    Default

    Quote Originally Posted by r0d3nt View Post
    I inserted:
    Code:
    %_unpackaged_files_terminate_build 1
    into a ~/.rpmmacros file, and it didn't work. I looked in /etc/rpm/ there are several macros files:
    Code:
    macros.dist      macros.kde4     macros.qt4
    macros.jpackage  macros.prelink  macros.specspo
    I tried adding the additional line to the macros.dist file but the compile still failed.
    Just create a new /etc/rpm/macros file.

  8. #8
    Join Date
    Nov 2006
    Posts
    102

    Default

    I am curious now to hear if ANYONE has successfully installed the 7.12 release on Fedora 8 [either 32-bit or 64-bit].
    I had the same problem with both f7 and f8, so instead I used the full screen installer and it worked as it should.

  9. #9
    Join Date
    Nov 2007
    Posts
    5

    Default

    I was able to get 7.12 working on Fedora 8 64bit, but not without some work.

    Simply using the graphical installer failed to make the kernel module, though the driver gets installed properly. Building the rpms was only possible after I patched the packaging script. The original script was not putting the 32bit library directories in the proper place before calling rpmbuild.

    However, after installing the rpms, I got the PreInitDAL problem mentioned in http://phoronix.com/forums/showthread.php?t=7015

    I solved that by running the graphical installer again. Whatever file was causing the PreInitDAL problem got overwritten with a proper one, and the missing kernel module that the graphical installer does not make was already put in place by the rpms.

    The patch I made was to the file packages/Fedora/ati-packager.sh in the directory made by the installer:

    Code:
    --- ati-packager.sh.original    2007-12-20 11:30:39.000000000 -0700
    +++ ati-packager.sh     2007-12-22 06:02:35.000000000 -0700
    @@ -125,8 +125,12 @@
           ln -fs ../../../../${ARCH_LIB}/dri/fglrx_dri.so
         # Same work around for 32-on-64
         if [ "${release_arch}" = 'x86_64' ]; then
    +#the directory copying above does not make the 32bit lib directory, so make it now
    +      cp -pR ${INSTALLER_ROOT_DIR}/arch/x86/usr/X11R6/lib ${TMP_RPM_BUILD_DIR}/usr/X11R6/lib
           mkdir -p ${TMP_RPM_BUILD_DIR}/usr/lib/dri
    -      mv ${TMP_RPM_BUILD_DIR}/usr/X11R6/lib/modules/dri/* \
    +#copy instead of move the dri contents, as ${TMP_RPM_BUILD_DIR}/usr/X11R6/lib/modules/dri/* is in the spec file
    +#      mv ${TMP_RPM_BUILD_DIR}/usr/X11R6/lib/modules/dri/* \
    +      cp -pR ${TMP_RPM_BUILD_DIR}/usr/X11R6/lib/modules/dri/* \
            ${TMP_RPM_BUILD_DIR}/usr/lib/dri
           ln -fs ../../../../lib/dri/fglrx_dri.so
           popd &> /dev/null

  10. #10
    Join Date
    Dec 2007
    Posts
    17

    Default Wish it would work the first time...

    Hmm...having to patch the installer to make it work? I think I'm going to stick with 7.11 until either the 7.12 installer gets fixed, or just wait for 8.1. Can't say I'm entirely thrilled by this release. Everything seemed to have been going fine up until now.

    I still prefer ATi video cards over NVIDIA based cards, and will probably get a 38X0 card in the future, I'll just have to wait a bit to see if the latest release driver at the time will install properly.

    Thanx for all that responded, I greatly appreciate your input.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •