Results 1 to 4 of 4

Thread: 7.12 & compiz - hangs

  1. #1
    Join Date
    Oct 2007
    Posts
    32

    Default 7.12 & compiz - hangs

    I have 7.12 installed on my thinkpad t60p (FireGL V5250) under RHEL 5., and it seems stable under non-compiz use.

    I just ensured AIGLX was enabled, and enabled desktop effects. Unfortunately as soon as the compiz window manager starts, the desktop effectively freezes. Any running apps continue to run, but cannot be interacted with. Further an attempt to switch to a VT results in simply a flashing cursor top left.

    The salient sections of xorg.conf includes

    Section "ServerLayout"
    Option "AIGLX" "true"
    EndSection

    Section "Files"
    EndSection

    Section "Module"
    Load "dri"
    Load "glx"
    Load "extmod"
    Load "dbe"
    EndSection

    Section "Device"

    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    Option "EnableMonitor" "crt1,lvds"
    Option "VideoOverlay" "on"
    Option "DesttopSetup" "horizontal,reverse"
    Option "DRI" "true"
    Option "XAANoOffscreenPixmaps" "true"
    Option "ForceGenericCPU" "no"
    Option "no_accel" "no"
    Option "no_dri" "no"
    Option "mtrr" "off"
    EndSection

    Section "DRI"
    Group 0
    Mode 0666
    EndSection

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection


    Some lines are omitted for conciseness

    Ideas? compiz is 0.5.2-1

  2. #2
    Join Date
    Oct 2007
    Posts
    32

    Default

    Aftersome reading/some tweaks, Here's the errors I get

    bash-3.1$ fusion-icon
    * Using the GTK Interface
    * Searching for installed applications...
    /usr/bin/ccsm
    /usr/bin/compiz
    /usr/bin/gtk-window-decorator
    /usr/bin/emerald
    /usr/bin/metacity
    /usr/bin/kwin
    * gnome session
    * No GLX_EXT_texture_from_pixmap present with direct rendering context
    ... present with indirect rendering, exporting: LIBGL_ALWAYS_INDIRECT=1
    * Executing: compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering
    compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
    compiz (core) - Error: Failed to manage screen: 0
    compiz (core) - Fatal: No manageable screens found on display :0.0
    Traceback (most recent call last):
    File "/usr/bin/fusion-icon", line 129, in ?
    choose_interface()
    File "/usr/bin/fusion-icon", line 101, in choose_interface
    import_interface(interface)
    File "/usr/bin/fusion-icon", line 66, in import_interface
    exec('import ' + module)
    File "<string>", line 1, in ?
    File "/usr/share/fusion-icon/interface_gtk.py", line 238, in ?
    gtk.main()
    KeyboardInterrupt

    With my xorg.conf looking like this:
    bash-3.1$ cat /etc/X11/xorg.conf

    # Xorg configuration created by pyxf86config

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen 0 "aticonfig-Screen[0]" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Synaptics" "CorePointer"
    Option "AIGLX" "true"
    Option "IgnoreABI" "on"
    EndSection

    Section "Files"
    EndSection

    Section "Module"
    Load "dbe"
    Load "dri"
    Load "glx"
    Load "extmod"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "gb"
    EndSection

    Section "InputDevice"
    Identifier "Synaptics"
    Driver "synaptics"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "auto-dev"
    Option "Emulate3Buttons" "yes"
    Option "LeftEdge" "1700"
    Option "RightEdge" "5300"
    Option "TopEdge" "1700"
    Option "BottomEdge" "4200"
    Option "FingerLow" "25"
    Option "FingerHigh" "30"
    Option "MaxTapTime" "180"
    Option "MaxTapMove" "220"
    Option "VertScrollDelta" "100"
    Option "MinSpeed" "0.06"
    Option "MaxSpeed" "0.12"
    Option "AccelFactor" "0.0010"
    Option "SHMConfig" "on"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"

    # Option "DesktopSetup" "0x00000100"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    Option "EnableMonitor" "lvds"
    #Option "ForceMonitors" "lvds,tmds1"
    Option "VideoOverlay" "on"
    # Option "MonitorLayout" "AUTO, CRT"
    Option "DesttopSetup" "horizontal,reverse"
    Option "XAANoOffscreenPixmaps" "true"
    Option "DRI" "true"
    Option "BackingStore" "True"
    #Option "TexturedVideo" "False"
    Option "Capabilities" "0x00000000"
    #Option "OpenGLOverlay" "off"
    Option "AllowGLXWithComposite" "true"
    Option "RenderAccel" "true"
    Option "DesktopSetup" "single"
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    Option "AddARGBGLXVisuals" "true"
    Option "DisableGLXRootClipping" "true"
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "DRI"
    Group 0
    Mode 0666
    EndSection

    Section "Extensions"
    Option "DAMAGE" "true"
    Option "Composite" "Enable"
    EndSection

    compiz is 0.5.2 -- latest binary rpms I could find compatible with RHEL 5.1 without rebuilding etc.

  3. #3
    Join Date
    Oct 2007
    Posts
    32

    Default

    anyone got this working now?

  4. #4
    Join Date
    May 2007
    Posts
    352

    Default

    What's the output of 'fglrxinfo' and 'Xorg -version'?

    Adam

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •