Results 1 to 9 of 9

Thread: The Impact Of KDE On 3D Gaming

  1. #1
    Join Date
    Jan 2007
    Posts
    14,906

    Default The Impact Of KDE On 3D Gaming

    Phoronix: The Impact Of KDE On 3D Gaming

    Being discussed following the Ubuntu 12.04 Desktops Impact Performance, Power Consumption was the impact that KDE's KWin compositing window manager (and others that don't redirect fullscreen windows by default) has on the OpenGL gaming performance...

    http://www.phoronix.com/vr.php?view=MTA4NjU

  2. #2
    Join Date
    Jun 2006
    Location
    Portugal
    Posts
    530

    Default

    An alternative is to enable "Suspend desktop effects for fullscreen windows" in the configure desktop effects > advanced tab.
    Enabled on all my systems.

  3. #3
    Join Date
    Nov 2008
    Posts
    770

  4. #4
    Join Date
    Sep 2008
    Location
    Vilnius, Lithuania
    Posts
    2,562

    Default

    One of the reasons why it's not on by default is that it causes annoying screen flickering/corruption when something is being overlayed on fullscreen windows, such as Amarok's On Screen Display. Since I bet more people are using that than playing games, it's probably best to keep it off by default.

  5. #5
    Join Date
    May 2010
    Posts
    187

    Default

    Quote Originally Posted by GreatEmerald View Post
    One of the reasons why it's not on by default is that it causes annoying screen flickering/corruption when something is being overlayed on fullscreen windows, such as Amarok's On Screen Display. Since I bet more people are using that than playing games, it's probably best to keep it off by default.
    I'm sure your right, but why is amaroks on screen display on by default? It's completely inconsistent with the kde desktop and amarok works great when using kdes normal notifications

  6. #6

    Default

    This result is odd, but thanks for the benchmark. Waiting for more.

  7. #7
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,795

    Default

    Quote Originally Posted by [Knuckles] View Post
    An alternative is to enable "Suspend desktop effects for fullscreen windows" in the configure desktop effects > advanced tab.
    Enabled on all my systems.
    This is the default actually. But I guess Ubuntu does their own thing and changed it.

    Edit: I just saw KDE 4.7 changed this. It was the default, but not anymore.

  8. #8
    Join Date
    Aug 2009
    Posts
    2,264

    Default

    Cleaner solution taking performance hit. We all knew that with KDE ages ago. I don't even care as long as it works well; performance optimizations and faster hardware will take care of it.

    I realy hated how on Compiz with Ubuntu (what was it... 2008/2009?) was flickering the shit out of fullscreen games. I'd rather have lower FPS than SOSPS (shit on screen per second)

  9. #9
    Join Date
    Jun 2006
    Location
    Portugal
    Posts
    530

    Default

    Yes, you do have to put up with the flickering, unfortunately.
    But I mostly see it when using firefox in fullscreen (which is rarely), so it's a good tradeoff I guess.

    I once suggested a kind of dynamic blacklist: when kwin has to switch compositing on/off too many times (5? 10?) in a row, ask the user something like:
    The current fullscreen application seems to be having trouble with desktop effects. What do you want to do?
    [ Enable compatibility mode ] [ Ignore ] [ Turn off desktop effects ] [ ] Remember my choice for this application
    (where compatibility mode = stop unredirecting this app, ignore = keep unredirecting, turn off desktop effects = obvious)

    For those interested, bug #1337495 (https://bugs.kde.org/show_bug.cgi?id=177495) is where this issue is normally discussed.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •