Results 1 to 3 of 3

Thread: 7.12: Failed to remmap MC AGP aperture base!

Hybrid View

  1. #1
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    364

    Default 7.12: Failed to remmap MC AGP aperture base!

    Hi all,
    I just upgraded to 8.44 and also had that PreInitDAL problem (magically fixed after restarting X), but on my gentoo computer it's another error which prevents my 3D acceleration from working: (2D accel works)
    (Xorg.log
    (**) fglrx(0): ATI GART size: 256 MB
    (II) fglrx(0): [pci] find AGP GART
    (II) fglrx(0): [agp] Mode=0x1f004e1b bridge: 0x1039/0x0746
    (II) fglrx(0): [agp] AGP v1/2 disable mask 0x00000000
    (II) fglrx(0): [agp] AGP v3 disable mask 0x00000000
    (II) fglrx(0): [agp] enabling AGP with mode=0x1f004f1a
    (EE) fglrx(0): [agp] Failed to remmap MC AGP aperture base!
    (EE) fglrx(0): cannot init AGP
    (II) fglrx(0): [drm] DRM buffer queue setup: nbufs = 100 bufsize = 65536

    [...]

    (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed! *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO) *
    (WW) fglrx(0): * no 3D acceleration available *
    (WW) fglrx(0): ********************************************* *

    [...]

    (EE) AIGLX: Screen 0 is not DRI capable
    I'd also add that everything worked with 8.43 before.
    My xorg.conf:
    Section "ServerLayout"
    Identifier "Simple Layout"
    Screen 0 "aticonfig-Screen[0]" 0 0
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
    Option "AIGLX" "true"
    EndSection

    Section "Files"
    FontPath "/usr/share/fonts/misc/"
    FontPath "/usr/share/fonts/Type1/"
    FontPath "/usr/share/fonts/100dpi/"
    FontPath "/usr/share/fonts/75dpi/"
    EndSection

    Section "Module"
    Load "glx"
    Load "dri"
    Load "dbe" # Double buffer extension
    SubSection "extmod"
    Option "omit xfree86-dga" # don't initialise the DGA ext$
    EndSubSection
    Load "freetype"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "de"
    EndSection

    Section "Input Device"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "Auto" # Auto detect
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5 6 7"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "DRI"
    Group 0
    Mode 0666
    EndSection

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection
    I'm using an X1600 Pro by Saphire, 512 MB and an AGP card.

    Any ideas on how to fix that?
    Many thanks in advance.

  2. #2
    Join Date
    Oct 2007
    Posts
    14

    Default

    got the same issue here on a X1650 pro 512MB AGP

    Edit: Fixed that thing by lowering AGP aperture size in bios from 512MB to 256MB ;-)
    Last edited by uzi-; 12-22-2007 at 10:56 AM.

  3. #3
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    364

    Default

    hm, nice to hear that you got it fixed
    unfortunately neither changing agp aperture size in bios nor chaning the max gart size with aticonfig helped for me, now I'm at 64 mb aperture size and 64 mb max gart size and it still doesn't work..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •