Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: RADEON GPU accel not working Debian 6.0.1

Hybrid View

  1. #1
    Join Date
    Nov 2008
    Posts
    89

    Default RADEON GPU accel not working Debian 6.0.1

    The following error message is coming up.....

    RADEON(0): GPU accel disabled or not working, using shadowfb for KMS

    Graphics card is a Radeon 5870, works OK on FGLRX

    I have a custom compiled kernel (3.2.9 also 2.6.39.1 has the same error) but the supplied Debian kernel does the same thing.

    I have chased through all the docs including the radeon Build howto and as far as I can see it should be working. Help on the next step most apreciated.
    I start to a console then run startx, kernel correctly sets console to 1920x1200, the following is part of the output of dmesg

    [ 4.582642] [drm] radeon kernel modesetting enabled.
    [ 4.582733] radeon 0000:03:00.0: PCI INT A -> GSI 24 (level, low) -> IRQ 24
    [ 4.582788] radeon 0000:03:00.0: setting latency timer to 64
    [ 4.582904] [drm] initializing kernel modesetting (CYPRESS 0x1002:0x6898).
    [ 4.582979] [drm] register mmio base: 0xFBBC0000
    [ 4.583027] [drm] register mmio size: 131072
    [ 4.583146] ATOM BIOS: GV
    [ 4.583206] radeon 0000:03:00.0: VRAM: 1024M 0x0000000000000000 - 0x000000003FFFFFFF (1024M used)
    [ 4.583277] radeon 0000:03:00.0: GTT: 512M 0x0000000040000000 - 0x000000005FFFFFFF
    [ 4.583347] mtrr: type mismatch for d0000000,10000000 old: write-back new: write-combining
    [ 4.583416] [drm] Detected VRAM RAM=1024M, BAR=256M
    [ 4.583464] [drm] RAM width 256bits DDR
    [ 4.583536] [TTM] Zone kernel: Available graphics memory: 423352 kiB.
    [ 4.583588] [TTM] Zone highmem: Available graphics memory: 3109052 kiB.
    [ 4.583640] [TTM] Initializing pool allocator.
    [ 4.583699] [drm] radeon: 1024M of VRAM memory ready
    [ 4.583748] [drm] radeon: 512M of GTT memory ready.
    [ 4.583802] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
    [ 4.583853] [drm] Driver supports precise vblank timestamp query.
    [ 4.583929] radeon 0000:03:00.0: irq 77 for MSI/MSI-X
    [ 4.583933] radeon 0000:03:00.0: radeon: using MSI.
    [ 4.584009] [drm] radeon: irq initialized.
    [ 4.584057] [drm] GART: num cpu pages 131072, num gpu pages 131072
    [ 4.584514] [drm] Loading CYPRESS Microcode

    [ 5.501401] [drm] Internal thermal controller with fan control
    [ 5.501482] [drm] radeon: power management initialized
    [ 5.636159] [drm] fb mappable at 0xD0141000
    [ 5.636208] [drm] vram apper at 0xD0000000
    [ 5.636255] [drm] size 9216000
    [ 5.636300] [drm] fb depth is 24
    [ 5.636345] [drm] pitch is 7680
    [ 5.636424] fbcon: radeondrmfb (fb0) is primary device(II) [KMS] Kernel modesetting enabled.
    [ 6.064861] Console: switching to colour frame buffer device 240x75
    [ 6.070598] fb0: radeondrmfb frame buffer device
    [ 6.070599] drm: registered panic notifier
    [ 6.070647] [drm] Initialized radeon 2.9.0 20080528 for 0000:03:00.0 on minor 0

    part of Xorg.log


    (II) [KMS] Kernel modesetting enabled.
    (**) RADEON(0): Depth 24, (--) framebuffer bpp 32
    (II) RADEON(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
    (==) RADEON(0): Default visual is TrueColor
    (==) RADEON(0): RGB weight 888
    (II) RADEON(0): Using 8 bits per RGB (8 bit DAC)
    (--) RADEON(0): Chipset: "ATI Radeon HD 5800 Series" (ChipID = 0x6898)
    (II) RADEON(0): PCIE card detected
    (WW) RADEON(0): Color tiling is not yet supported on R600/R700
    (II) RADEON(0): KMS Color Tiling: disabled
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 9, (OK)
    drmOpenByBusid: Searching for BusID pci:0000:03:00.0
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 9, (OK)
    drmOpenByBusid: drmOpenMinor returns 9
    drmOpenByBusid: drmGetBusid reports pci:0000:03:00.0


    (II) RADEON(0): GPU accel disabled or not working, using shadowfb for KMS

  2. #2
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by Blacksmith View Post
    The following error message is coming up.....

    RADEON(0): GPU accel disabled or not working, using shadowfb for KMS

    Graphics card is a Radeon 5870, works OK on FGLRX
    i think debian 6 is to old. debian 7 will support this.
    debian 6 is mostly a "ubuntu 10.04 " or older. maybe you check the functionality with an old Ubuntu version.
    i my exoerience the radeon driver is no fun with old linux versions like debian6
    i use kubuntu 12.04 right now with oibaf ppa.

    try to use a newer linux. (i also wait for debian 7)

  3. #3
    Join Date
    Jun 2009
    Posts
    2,933

    Default

    The kernel bits look OK, but it could be that Mesa in Debian stable is too old to support HD5000 hardware (it's Mesa 7.7, which is ancient). Have you tried compiling a newer Mesa by hand? Mesa 8.0 has been out for quite a while now, with OpenGL 3.0 support.

    You could also try pulling Mesa from sid or wheezy, which would give you 7.11, and that should support your card.

  4. #4
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,275

    Default

    Don't forget to run recent video-ati and libdrm, too.

  5. #5
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    The easiest solution is probably to just dist-upgrade to unstable.

  6. #6
    Join Date
    Nov 2008
    Posts
    89

    Default

    Many thanks for the replies I suspected that Mesa was a little to old. I Debian testing and Sid both have the same version of Mesa (debian version 7.11.2). I will compile the newer versions of the ati driver, drm and Mesa. Downloaded all these a couple of days ago.

    Have been using linux now for twenty years (Note 1) so am quite used to compiling various things.

    Note 1: TWENTY years (kernel 0.96d).................... sssssiiiiiiiiigggggghhhhhhh,........ how time flies by!!!!!!!!

    Blacksmith

  7. #7
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,542

    Default

    Any chance you're missing the HW microcode images ? I think Debian considers them as firmware and leaves them out by default.

    It's hard to tell from the logs if that is the problem because of the gap in dmesg output, but IIRC there are some missing lines. Believe the package name is firmware-linux-nonfree.
    Last edited by bridgman; 04-29-2012 at 08:32 AM.

  8. #8
    Join Date
    Nov 2008
    Posts
    89

    Default

    Quote Originally Posted by bridgman View Post
    Any chance you're missing the HW microcode images ? I think Debian considers them as firmware and leaves them out by default.

    It's hard to tell from the logs if that is the problem because of the gap in dmesg output, but IIRC there are some missing lines. Believe the package name is firmware-linux-nonfree.
    Thank you for the reply, I will have to confirm what is happening here, I do have the non-free firmware on the system and in kernel 2.6.39.1 the KMS code spits out an error if these files are not there. The system is not currently connected up to my network (cannot find a cat5 cable) and this makes it diffcult to debug as one has to ssh into the system to read the kernel log or in this case reboot to another kernel to read the log, very messy when exprimenting. As it seems this should be working I will put a bit more effort in to to get it to go. I was having a bit of abreak as I was not sure if this card should have GPU accelaration support in xserver, I assume from your reply it has.

    A bit of experimenting does not trouble me, back in the early days such work was vital when linux was still fairly new as few were avaible to answer questions. Most Linux users now do not know they are alive .

    Many thanks,
    Blacksmith

  9. #9
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by Blacksmith View Post
    A bit of experimenting does not trouble me, back in the early days such work was vital when linux was still fairly new as few were avaible to answer questions. Most Linux users now do not know they are alive .
    glorious days and I hope it will become a monument for eternity!

  10. #10
    Join Date
    Feb 2008
    Posts
    1,229

    Default

    You can use backports on Debian stable. Right now there are kernel 3.2.15, xorg-server 1.10.4,
    drm 2.4.26, radeon 6.14.2 and mesa 7.10.3.

    All you need to do is to, recompile or even backport some packages for you:

    1. libdrm to 2.4.33 (or git master)
    2. radeon to 6.14.4 (or git master)
    3. mesa 8.0.2 (or git master)

    That way your graphics stack can be mostly recent on Debian Squeeze.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •