Page 7 of 25 FirstFirst ... 5678917 ... LastLast
Results 61 to 70 of 243

Thread: AMD To Drop Radeon HD 2000/3000/4000 Catalyst Support

  1. #61
    Join Date
    Oct 2011
    Location
    Toruń, Poland
    Posts
    160

    Default

    Quote Originally Posted by Qaridarium View Post
    is your health status fine? because: there isn't any native openGL4.x linux game.

    but yes people in a madhouse also buy future products in the past to make sure they are fine in the here and now.
    Is yours? What about Oil Rush?

  2. #62
    Join Date
    Apr 2012
    Location
    Canada
    Posts
    42

    Default Gnome Shell on proprietary drivers

    Quote Originally Posted by remjg View Post
    I know ! It's shame that the proprietary driver doesn't (didn't ?) ! The open source driver is still too slow though...
    This seems to be the trend with proprietary drivers; with my nvidia card, I've noticed that gnome-shell actually runs a lot better on nouveau, but alas I need the Nvidia driver for other reasons.

  3. #63
    Join Date
    Oct 2007
    Posts
    1,283

    Default

    Quote Originally Posted by enrico.tagliavini View Post
    Ok AMD just try to do that and you will never see one more $ from me and I'm sure I'm not the only one. I bought a new laptop just one year ago with a radeon card on it.
    The same thing happened with Catalyst 9-3 and the DX9 parts (RadeonHD X1k and Mobility Radeon 2x00 were still on the shelves). You have no one to blame but yourself. Those who don't study history are doomed to repeat it...

  4. #64
    Join Date
    Jan 2012
    Posts
    22

    Default

    this kind of support is also planned in windows platform, due to there is not official support for hd 4000 series in windows 8

  5. #65
    Join Date
    Nov 2009
    Location
    Europe
    Posts
    272

    Default

    Quote Originally Posted by JanC View Post
    Even Ubuntu 12.04 will be supported for 5 years, so that means until April 2017...
    That's very good. So that means that a maintained Ubuntu release will be probably compatible with Catalyst <12.7 until April 2017. And Catalyst <12.7 should be also compatible with maintained releases of RHEL based distros even much longer.

    Then no much reason to worry about this step then.

  6. #66
    Join Date
    Mar 2008
    Location
    Istanbul
    Posts
    135

    Default

    You don't needed to be sad. Even with my 6850HD, (I bought almost a year ago) you cannot use Gnome3 Shell. FGLRX bugs kills the shell and force me logging out at the middle of coding, fu*king my concentration...
    So, fglrx "support" is not an actually "support". They better drop whole catalyst for linux.
    Instead, they could donate some $ to open source ati GPU driver coders... I call this a real linux support...

  7. #67
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    258

    Default

    Regardless of the typical phoronix newsmongering paparazzi going on, the responses here just prove people will complain whatever happens. Before AMD open sourced their specs, it was evil AMD bluh bluh bluh. Then when it finally happened, it turned out most of it was talking. Very few people actually delved into the specs and did some work, otherwise the drivers wouldn't need so much time to mature. Then AMD drops blob support, which is the expected things to do after you open source your specs, and what happens? people complain.

    This shows something I've been suspecting for quite a while (though phoronix really tries hard to bring out that side in people) -- there are idiots in every community, and usually roughly the same percentage (with the exception of ievil users, the number of idiots there is more like 90%).

  8. #68
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    It's the same story with the Unigine Engine on open-source, at least not without greatly sacrificing the visual richness of the engines and building Mesa support with patent-encumbered features (S3TC, floating-point textures, etc).
    Or, you know, you could get Mesa from a distro that doesn't disable float textures. Also, there's no need to recompile for S3TC...

  9. #69
    Join Date
    May 2011
    Posts
    353

    Default

    Quote Originally Posted by Fenrin View Post
    I think support for AGP cards was dropped by the proprietary driver long time ago, but maybe I am wrong. Gnome shell works very good with the free Radeon driver.
    AGP support wasn't dropped yet. Radeon HD 2000+ is still working with Catalyst 12.3 (etc.), no matter what interface, PCIe or AGP, you use.

  10. #70
    Join Date
    Mar 2008
    Posts
    575

    Default

    Wait, I know what's happening:

    Valve is about to release Steam for Linux, so users will need full 3d support. How can AMD make money out of this "historical" situation? SIMPLE: kill the driver for 70% users out there and force them to buy a new GPU because the OSS driver won't be able to run Valve's games!

    Bingo.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •