Quote Originally Posted by sunny View Post
@nfina: Thanks! that compiles like charm but doesn't run properly. I get the following error:

Code:
SQLite 3.7.3:
    pts/sqlite-1.8.0 [Test Target: Default Test Directory]
    Test 1 of 1
    Estimated Trial Run Count:    3
    Estimated Time To Completion: 17 Minutes
        Running Pre-Test Script @ 15:56:30
        Started Run 1 @ 15:56:30
        The test run did not produce a result.
        Running Interim Test Script @ 15:56:32
        Started Run 2 @ 15:56:34
        The test run did not produce a result.
        Running Interim Test Script @ 15:56:34
        Started Run 3 @ 15:56:36
        The test run did not produce a result.
        Running Post-Test Script @ 15:56:36

    Test Results:

    Average: 0 Seconds
    This test failed to run properly.


The following tests failed to properly run:

        - pts/sqlite-1.8.0: Test Target: Default Test Directory
Did you get this error? If so do you know how to0 fix this? Thanks!

./phoronix-test-suite debug-run sqlite
Test Run Command: cd /root/.phoronix-test-suite/installed-tests/pts/sqlite-1.8.0/ && ./sqlite-benchmark 2>&1

./sqlite_/bin/sqlite3: symbol lookup error: ./sqlite_/bin/sqlite3: undefined symbol: sqlite3_config
./sqlite_/bin/sqlite3: symbol lookup error: ./sqlite_/bin/sqlite3: undefined symbol: sqlite3_config
cat: write error: Broken pipe
./sqlite_/bin/sqlite3: symbol lookup error: ./sqlite_/bin/sqlite3: undefined symbol: sqlite3_config
cat: write error: Broken pipe
./sqlite_/bin/sqlite3: symbol lookup error: ./sqlite_/bin/sqlite3: undefined symbol: sqlite3_config
cat: write error: Broken pipe
./sqlite_/bin/sqlite3: symbol lookup error: ./sqlite_/bin/sqlite3: undefined symbol: sqlite3_config
cat: write error: Broken pipe
./sqlite_/bin/sqlite3: symbol lookup error: ./sqlite_/bin/sqlite3: undefined symbol: sqlite3_config
cat: write error: Broken pipe

In my case it has something to do with this line 'rm -rf sqlite_/lib/' in install.sh. Libs are removed after installing sqlite. So I made come change and it worked all fine.
Code:
sed -i -e 's/\(^rm -rf sqlite_\/lib\/$\)/#\1/' ~/.phoronix-test-suite/test-profiles/pts/sqlite-1.8.0/install.sh
./phoronix-test-suite remove-installed-test sqlite
./phoronix-test-suite benchmark sqlite