Results 1 to 8 of 8

Thread: How to lower the system teperature

  1. #1
    Join Date
    Dec 2007
    Posts
    2

    Default How to lower the system teperature

    First, excuse for a bad english.
    I've a hp dv4266 notebook with 1,73 GHz centrino cpu and x700 mobility with ubuntu 7.10 installed on. I've tried to lower the system temperature so that doesn't run the fan. I use already the linux-phc patch for downgrade the cpu clock but i've tried many driver for ati mobility, atipower too, but i don't know how to fix the system temperature under 49-50C so that the fan doesn't run. Under winxp it's ok...the fun doesn't run with 800 MHz as cpu clock (fixed with nhc) and ati powerplay active with gpu clock fixed on 105 MHz.
    Please help me becouse i don't want to use windows...but i hate this fun noise.

  2. #2
    Join Date
    Jun 2007
    Posts
    406

    Default

    Quote Originally Posted by fr33m4n View Post
    First, excuse for a bad english.
    I've a hp dv4266 notebook with 1,73 GHz centrino cpu and x700 mobility with ubuntu 7.10 installed on. I've tried to lower the system temperature so that doesn't run the fan. I use already the linux-phc patch for downgrade the cpu clock but i've tried many driver for ati mobility, atipower too, but i don't know how to fix the system temperature under 49-50C so that the fan doesn't run. Under winxp it's ok...the fun doesn't run with 800 MHz as cpu clock (fixed with nhc) and ati powerplay active with gpu clock fixed on 105 MHz.
    Please help me becouse i don't want to use windows...but i hate this fun noise.
    for what i know powerplay on linux is governed by atieventsd service and cannot be adjusted manually. if you want your system to be cooler then put the processor on powersave governor (in that way it will always run at the lowest speed). also in linux the trip points may be different from the ones in windows. for example in my laptop on windows the system would run at full speed until 80 and be in active[1] - fan off - state until it would arrive at 60 while in linux i have active[1] - 57 (with 2.6.21 i had 58) and passive at 75). you might be able to adjust other stuff with lm_sensors but in a laptop it doesn't always work (on my laptop i don't have nothing to adjust, and i use lm_sensors just for reading the processor core temp. if you want to see your trip points have a look at:
    /proc/acpi/termal_zone/THRM0/trip_points where THRM0 indicates your thermal zone and might have a different value on your pc.
    you also should set the polling frequency to something like 2 seconds (the file is named polling_frequency and is situated in the same thermal directory as the file trip_points and it is writable while the file trip_points isn't writable).
    the last thing that you could adjust if the processor throttling. the file to see your processor throttling capabilities is: /proc/acpi/processor/CPU0/throttling
    the file /proc/acpi/processor/CPU0/limit indicates the processor limits including active limits.
    be aware that the throttling sets your processor to idle states in which it doesn't responds. the percentage 00% indicates no idle while 90% indicates that it stays idle for 90% of the time the pc is open. the throttling is good for having power saving but it's not indicated at more than 20% on a everyday desktop system.

  3. #3
    Join Date
    Jul 2007
    Posts
    16

    Default

    try the following to list the appropriate powerplay states:

    Code:
    aticonfig --lsp
    Use the following to use the lowest power state:

    Code:
    aticonfig --set-powerstate=1

  4. #4
    Join Date
    Dec 2007
    Posts
    2

    Default

    Quote Originally Posted by mintcoffee View Post
    try the following to list the appropriate powerplay states:

    Code:
    aticonfig --lsp
    Use the following to use the lowest power state:

    Code:
    aticonfig --set-powerstate=1
    I've already tried this solution but with no luky.

    And I think that the trip points are the same in windows and linux.

    When AMD realeases the documentation for the x700 mobility???

  5. #5
    Join Date
    Jun 2007
    Posts
    406

    Default

    Quote Originally Posted by fr33m4n View Post
    I've already tried this solution but with no luky.

    And I think that the trip points are the same in windows and linux.

    When AMD realeases the documentation for the x700 mobility???
    maybe the powerstate 1 isn't the powersave for your board. for example my powerstate 1 is performance on the x200m.
    check out with speedfan when your system spins down the fan. but be aware that forcing powerstates in speedfan might break your pc.
    you could try setting the tickeless in the kernel and make your system throttle a little. but consider this:
    if you use windows usually you use the performance setting which will make your fan start too. if you use powersave on windows then your processor would stand to the lowest speed but sometimes the fan would still start. if you want it to be the more quiet possible is having the polling frequency set to 1 second or less and so having it starting from time to time would bother you less.
    ps. if your fan is so noisy, then call your manufacturer assistance and have it changed. usually the notebooks' fans are quite quiet.

  6. #6
    Join Date
    Jan 2008
    Location
    Have a good day.
    Posts
    678

    Default

    if you want your system to be cooler then put the processor on powersave governor (in that way it will always run at the lowest speed)
    That doesn't seem to be right. Apparently you and your processor are better off with the ondemand governor; this way whenever there's something to do it will get done quicker and the CPU will enter into a sleep state sooner and for longer.

    I had similar problems the OP mentions and are now fixed with a combination of the HPET patch (included in 2.6.24) and an analysis of Powertop's output.

    http://www.lesswatts.org/projects/powertop/

    I have to say that, hating as I do the fglrx driver (I don't and likely will not ever use it again), its powersaving feature worked quite nice here, keeping the GPU quite cool. Does somebody know whether there is any chance this could be achieved with the OSS driver?

  7. #7
    Join Date
    Nov 2007
    Posts
    31

    Default

    i posted something about setting the power saving features here:

    http://www.phoronix.com/forums/showthread.php?t=6522

  8. #8
    Join Date
    Nov 2007
    Posts
    31

    Default

    I wrote something about using power saving features on radeons here:
    http://www.phoronix.com/forums/showthread.php?t=6522

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •