Results 1 to 6 of 6

Thread: HDMI audio with fglrx?

Hybrid View

  1. #1
    Join Date
    Nov 2008
    Posts
    150

    Default HDMI audio with fglrx?

    Hello, I am using a Radeon 7870 with Kubuntu 12.04 and fglrx 12.4. HDMI audio does not work.

    When I go to System Settings / Phonon / Audio Hardware Setup I see only one option "Built-in Audio".
    Also alsamixer shows only one sound card "HDA Intel PCH".

    Any suggestions please?

    Code:
    dmen@tera:~$ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC889 Analog [ALC889 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 1: ALC889 Digital [ALC889 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    Code:
    dmen@tera:~$ lspci
    00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
    00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
    00:02.0 Display controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
    00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
    00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
    00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
    00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
    00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
    00:1c.6 PCI bridge: Intel Corporation 82801 PCI Bridge (rev b5)
    00:1c.7 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 8 (rev b5)
    00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
    00:1f.0 ISA bridge: Intel Corporation Z68 Express Chipset Family LPC Controller (rev 05)
    00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family SATA AHCI Controller (rev 05)
    00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Device 6818
    01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Device aab0
    03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
    04:00.0 PCI bridge: Integrated Technology Express, Inc. Device 8892 (rev 30)
    06:00.0 USB controller: Etron Technology, Inc. EJ168 USB 3.0 Host Controller (rev 01)

  2. #2
    Join Date
    Aug 2007
    Posts
    6,645

    Default

    Maybe try kernel 3.3 or just update alsa drivers.

  3. #3
    Join Date
    Jun 2012
    Posts
    48

    Default

    hello, I have the same problem with my 7850 on Ubuntu 12.04, catalyst 12.6:

    $ lspci |grep ATI
    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Device 6819
    01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Device aab0

    $ aplay -l
    **** Liste des Périphériques Matériels PLAYBACK ****
    carte 0: Intel [HDA Intel], périphérique 0: ALC1200 Analog [ALC1200 Analog]
    Sous-périphériques: 1/1
    Sous-périphérique #0: subdevice #0
    carte 0: Intel [HDA Intel], périphérique 1: ALC1200 Digital [ALC1200 Digital]
    Sous-périphériques: 1/1
    Sous-périphérique #0: subdevice #0

    Aplay and Pulseaudio does not find any hdmi audio device :-/
    Did you find a solution? Someone could help?

  4. #4
    Join Date
    Jun 2012
    Posts
    48

    Default

    I upgraded kernel to 3.3.7, like I saw in another discussion, and now my radeon 7850 hdmi audio is recognized by the system:

    aplay -l
    **** Liste des Périphériques Matériels PLAYBACK ****
    carte 0: Intel [HDA Intel], périphérique 0: ALC1200 Analog [ALC1200 Analog]
    Sous-périphériques: 1/1
    Sous-périphérique #0: subdevice #0
    carte 0: Intel [HDA Intel], périphérique 1: ALC1200 Digital [ALC1200 Digital]
    Sous-périphériques: 1/1
    Sous-périphérique #0: subdevice #0
    carte 1: HDMI [HDA ATI HDMI], périphérique 3: HDMI 0 [HDMI 0]
    Sous-périphériques: 0/1
    Sous-périphérique #0: subdevice #0
    carte 1: HDMI [HDA ATI HDMI], périphérique 7: HDMI 1 [HDMI 1]
    Sous-périphériques: 1/1
    Sous-périphérique #0: subdevice #0
    carte 1: HDMI [HDA ATI HDMI], périphérique 8: HDMI 2 [HDMI 2]
    Sous-périphériques: 1/1
    Sous-périphérique #0: subdevice #0
    carte 1: HDMI [HDA ATI HDMI], périphérique 9: HDMI 3 [HDMI 3]
    Sous-périphériques: 1/1
    Sous-périphérique #0: subdevice #0
    carte 1: HDMI [HDA ATI HDMI], périphérique 10: HDMI 4 [HDMI 4]
    Sous-périphériques: 1/1
    Sous-périphérique #0: subdevice #0
    carte 1: HDMI [HDA ATI HDMI], périphérique 11: HDMI 5 [HDMI 5]
    Sous-périphériques: 1/1
    Sous-périphérique #0: subdevice #0

  5. #5
    Join Date
    Nov 2008
    Posts
    150

    Default

    Quote Originally Posted by legluondunet View Post
    I upgraded kernel to 3.3.7, like I saw in another discussion, and now my radeon 7850 hdmi audio is recognized by the system
    Hi, how did you upgrate the kernel?

  6. #6
    Join Date
    Jun 2012
    Posts
    48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •