Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Can't boot Linux via USB

  1. #1

    Default Can't boot Linux via USB

    I have been trying to boot Ubuntu, Xubuntu, Mint LXDE, openSUSE, Fedora, and so on, via USB on my recently built machine using the Universal USB Installer (the most recent version) which has never let me down in the past. I tell my computer to boot from the USB, it does, the Ubuntu/Xubuntu/Mint LXDE/other options come up, I choose the one that allows me to simply try them, stuff starts loading that a newbie like me cannot decipher, and then a blank screen. I left my desktop running for several minutes each time, but nothing. Strangely enough, when using the exact same method with Puppy Linux, it works fine. They also boot up fine on my HP Pavilion dv6000 laptop which is over three years old.

    Find below an image of what loads up. The USB and its contents are obviously being recognized, but after selecting to run whatever operating system is currently on there via the USB, a blank screen comes up, or in the case of openSUSE, a desktop background with nothing on it.



    My specs are:


    • Intel Core i5 2500K
    • Gigabyte GA-Z68AP-D3
    • 8Gb (2x4Gb) Corsair Vengeance @ 1600Mhz
    • 1TB Seagate Barracuda 7200RPM
    • Gainward GeForce GTX 570 Golden Sample
    • Antec TruePower New Modular 650W
    • Lian-Li PC-K63B First Knight
    • Windows 7 Home Premium 64bit

  2. #2
    Join Date
    Apr 2012
    Posts
    120

    Default

    Likely need to change the boot parameters. Here's a good place to start:

    https://help.ubuntu.com/community/BootParameters

  3. #3
    Join Date
    Jan 2012
    Posts
    82

    Default

    When I had this problem with Fedora 16, it was because the installer expected the USB drive to have the same volume name as the CD/DVD disc, because it was attempting to mount by volume name.

    I don't know if Ubuntu's installer has the same problem, but it is something to look at.

  4. #4
    Join Date
    Jan 2007
    Posts
    418

    Default

    Are you booting 32 or 64bit 'iso/img'? I've had a simlar/same problem on my Asus m5a97 where it would not boot from USB, only in 32bit mode.

    Turns out, the bios was so buggy (it still is, but less now) that USB didn't work (at all) in 64bit mode. So booting from the USB stick worked fine, but once the kernel tried to mount the USB stick to read the image, it would not find it and thus fail.

  5. #5

    Default

    Quote Originally Posted by fuzz View Post
    Likely need to change the boot parameters. Here's a good place to start:

    https://help.ubuntu.com/community/BootParameters
    I managed to boot into Ubuntu 12.04! At first, none of those parameters worked, but then I went to help, typed in menu, that brought me back to the menu (the way it's supposed to look like this time), pressed F6, selected nomodeset, and it fully loaded up. The resolution was pretty low and it had a 4:3 aspect ratio but hey, it's an improvement. I couldn't change the resolution or the aspect ratio and it said "Laptop" in the display settings despite me being on a desktop as well. What's more, openSUSE didn't have the nomodeset option, and I doubt Fedora and the other Linux distros not related to Ubuntu will either.

  6. #6

    Default

    Quote Originally Posted by Zan Lynx View Post
    When I had this problem with Fedora 16, it was because the installer expected the USB drive to have the same volume name as the CD/DVD disc, because it was attempting to mount by volume name.

    I don't know if Ubuntu's installer has the same problem, but it is something to look at.
    I am not even sure what I am supposed to look at here. It was explained to me that the USB apparently boots fine, it's just what happens after that causes issues.

  7. #7

    Default

    Quote Originally Posted by oliver View Post
    Are you booting 32 or 64bit 'iso/img'? I've had a simlar/same problem on my Asus m5a97 where it would not boot from USB, only in 32bit mode.

    Turns out, the bios was so buggy (it still is, but less now) that USB didn't work (at all) in 64bit mode. So booting from the USB stick worked fine, but once the kernel tried to mount the USB stick to read the image, it would not find it and thus fail.
    I have tried both 32 bit and 64 bit iso images but neither work unfortunately. I am kind of lost with the second part of your post but if there is a way to change my BIOS so that it is 32 bit then I could test that out too. Windows 7 64 bit runs fine on my desktop.

  8. #8
    Join Date
    Apr 2012
    Posts
    120

    Default

    Quote Originally Posted by FutureSuture View Post
    I managed to boot into Ubuntu 12.04! At first, none of those parameters worked, but then I went to help, typed in menu, that brought me back to the menu (the way it's supposed to look like this time), pressed F6, selected nomodeset, and it fully loaded up. The resolution was pretty low and it had a 4:3 aspect ratio but hey, it's an improvement. I couldn't change the resolution or the aspect ratio and it said "Laptop" in the display settings despite me being on a desktop as well. What's more, openSUSE didn't have the nomodeset option, and I doubt Fedora and the other Linux distros not related to Ubuntu will either.
    Congrats! I don't know about the other distributions, but the low resolution problem very likely might be due to drivers. Ubuntu has a restricted driver option somewhere in its menus (I haven't used the OS in years). NVIDIA proprietary drivers are quite good, if you're willing to use them.

  9. #9

    Default

    Quote Originally Posted by fuzz View Post
    Congrats! I don't know about the other distributions, but the low resolution problem very likely might be due to drivers. Ubuntu has a restricted driver option somewhere in its menus (I haven't used the OS in years). NVIDIA proprietary drivers are quite good, if you're willing to use them.
    I am getting some advice on the Ubuntu forums as well and Ubuntu, apart from Puppy Linux, is the only one I have managed to fully boot up on my desktop anyway.

    This is what I get after I put in the jockey-gtk command as suggested by a poster in the Ubuntu forums:



    So I found some instructions online after downloading the Nvidia driver and after a while got this:


  10. #10
    Join Date
    Jan 2007
    Posts
    418

    Default

    Quote Originally Posted by FutureSuture View Post
    I have tried both 32 bit and 64 bit iso images but neither work unfortunately. I am kind of lost with the second part of your post but if there is a way to change my BIOS so that it is 32 bit then I could test that out too. Windows 7 64 bit runs fine on my desktop.
    On the ubuntu download page, you get to choose 32bit or 64bit ISO images Your kernel decides during bootup whether your CPU runs in 32bit or 64bit mode

    But you don't seem to have the issue I had

    the 'nomodeset' parameter disables 'KMS' stuff. E.g. you have an issue with your graphics card. Probably not supported because it's too new or other. I think ubuntu and fedora now default to the nuveau driver. I think forcing the vesa driver (or nomodeset) during the USB boot to get to the installer is all you need. Install ubuntu and it should have detected your graphics card. After installation you can boot and it will probably tell you to install the nvidia binary drivers

    The reason this issue lives, is cause nVidia refuses to help/support anything other than their binary blob; and 'vesa mode is good enough' as a fall back as it will let you install our driver.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •