Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 42

Thread: AMD Catalyst 12.6 Beta improvements?

  1. #31

    Default

    Quote Originally Posted by eronquillo View Post
    Hi, I installed the catalyst 12.6 beta drivers on my linux mint 13 maya system, using a radeon 7750 with hdmi, dvi-i and display port. extending the workspace to the hdmi and dvi works fine, but the monitor with the display port (using a display port to dvi adaptor) is not receiving a signal from the card. When I boot and post, I can see the bios bootup, but then goes black while the other two monitors are able to display the linux mint workspace. I'll look further.
    Send bugreport: http://www.amdsurveys.com/se.ashx?s=5A1E27D20B2F3EAC

  2. #32
    Join Date
    Feb 2010
    Location
    Montreal, Québec, Canada
    Posts
    4

    Default

    Quote Originally Posted by RussianNeuroMancer View Post
    That why you need to put valid signature follow instruction.
    For me it was a simple matter of copying the control and signature files from the 12.4 release to /etc/ati. Even easier than following the instructions to the letter.

  3. #33

    Default

    Quote Originally Posted by rherbert57 View Post
    copying the control and signature files from the 12.4 release to /etc/ati
    Or download it. Every way is working anyway.

  4. #34
    Join Date
    Nov 2011
    Posts
    3

    Default

    I just want to say after almost a week, that they finally fixed "ASIC hang happened" which in my case was causing hangs during going sleep (not wakeup - it always worked). I'm using HD 5770 on Debian Sid and I'm so happy with full working sleep/wakeup after almost a year of struggle with that.

  5. #35
    Join Date
    Oct 2009
    Posts
    126

    Default

    Any previsions for a new beta driver with Debian amd64 xorg 1.12 support?

  6. #36
    Join Date
    Mar 2012
    Location
    USA
    Posts
    4

    Default

    Quote Originally Posted by Massa View Post
    Hi xgt001,

    It's working for me under Fedora 17 64-bit with Xorg 1.12 and kernel 3.3.7-1.fc17.x86_64.

    It's also quite snappier on my AMD E-350, very happy with this release so far.

    Just don't update to the 3.4.0-1 kernel and you'll be fine. Otherwise it's either go back to 3.3.7-1 or use Gallium. That was my mistake and kmod-catalyst is taking a while.

  7. #37
    Join Date
    Mar 2012
    Location
    USA
    Posts
    4

    Default

    Quote Originally Posted by vitorgatti View Post
    Didn't work. I can't remove the watermark saying "AMD Testing use only".
    It seems that there is no signature inside the driver install script.

    Anybody managed to remove/hide it?

    Thanks
    What's your distro?

    I use Fedora 17 GNOME 64-bit on Kernel 3.3.7.

    #!/bin/sh
    DRIVER=/lib64/xorg/modules/drivers/fglrx_drv.so
    for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
    sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
    done

    Save as fixwatermark.sh
    chmod +x to make it executable
    su -c 'sh ./fixwatermark.sh'

    then log out and back in.

    That worked for me.

    Again, this is on kernel 3.3.7 for Fedora 17 64-bit.

  8. #38
    Join Date
    Mar 2012
    Location
    USA
    Posts
    4

    Default

    Quote Originally Posted by ElderSnake View Post
    Please tell me they have/will be fixing suspend/resume...

    Driving me nuts on my Fusion powered netbook. fglrx does everything better than the open source driver (power management and HD video playback etc) EXCEPT I cant suspend the machine without it coming back up with a blank screen. very frustrating.
    Same here, but that is with all distros for me.
    My hardware is A6-3400M x4 1.2~2.4 (scaled) with 6 GB RAM, 600 HDD, Radeon HD 6520G.

  9. #39
    Join Date
    Aug 2011
    Posts
    82

    Default

    using the beta on my 7850 with the watermark patch

    performance is about the same, but it does fix a texture rendering problem in vdrift
    also not compatible with kernel 3.4.x but there might be hacks for that too ...

  10. #40
    Join Date
    Apr 2011
    Posts
    38

    Default

    Fianally a driver that doesn't crash my laptop (E350, HD6310) on suspend/resume! But it took AMD over a year to fix this bug and that's really unacceptable. I had a crash with serious graphic corruption though when changing the backligt so it's not stable enough yet but I'm looking forward to the final version!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •