Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: A8-3500M + Radeon HD 6650M: make it cool?

  1. #11
    Join Date
    Oct 2009
    Posts
    2,081

    Default

    Thanks, nice to know where to get the numbers from.
    However, I think mine is broken...
    Code:
    $ cat /sys/kernel/debug/dri/0/radeon_pm_info 
    default engine clock: 200000 kHz
    current engine clock: 6520 kHz
    default memory clock: 667000 kHz
    6.52 MHz doesn't seem reasonable.

  2. #12

    Default

    Hello, droidhacker.
    I have 7560G, that simply same laptop, but 17". (Don't forget to update BIOS, by the way.)

    Quote Originally Posted by droidhacker View Post
    power management method is set to profile, profile is set to low. Doesn't seem to make any difference from profile set to default.
    Because you also need to disable discrete GPU in BIOS or by
    Code:
    echo "OFF" > /sys/kernel/debug/vgaswitcheroo/switch
    Quote Originally Posted by droidhacker View Post
    CPU cores idle at 800 MHz, and max out at 1500 MHz. Now I know that the thing is *supposed* to "turbocore" up to 2400 MHz, but this doesn't seem to actually happen. Any way to make this work?
    Answer for this question is here: http://support.amd.com/us/Processor_TechDocs/41131.pdf (2.5.3.1.1)
    To ensure proper OS operation, boosted P-states should be hidden from the operating system.
    So boosted P-states (up to 2.4 GHz) is here, works (check CPB here /sys/devices/system/cpu/cpuN/cpufreq/cpb), you just doesn't see it. To see it use cpufreq-aperf or cpupowerutils (run "cpupower monitor").
    Quote Originally Posted by droidhacker View Post
    Any way to shut down excess cores when not needed?
    AFAIK it happen automatically. See 2.5.3.2.3.2 for details.
    Quote Originally Posted by droidhacker View Post
    Any way to get the thing to scale down LOWER than 800 MHz? 800 MHz seems a little higher than it needs to be.
    It doesn't make sense: http://mjg59.livejournal.com/88608.html
    Quote Originally Posted by droidhacker View Post
    Thanks, nice to know where to get the numbers from.
    However, I think mine is broken...
    Code:
    $ cat /sys/kernel/debug/dri/0/radeon_pm_info 
    default engine clock: 200000 kHz
    current engine clock: 6520 kHz
    default memory clock: 667000 kHz
    6.52 MHz doesn't seem reasonable.
    I would like to know answer for this too: https://bugzilla.kernel.org/show_bug.cgi?id=43114
    Last edited by RussianNeuroMancer; 06-09-2012 at 04:59 PM.

  3. #13
    Join Date
    Oct 2009
    Posts
    2,081

    Default

    Quote Originally Posted by RussianNeuroMancer View Post
    Hello, droidhacker.
    I have 7560G, that simply same laptop, but 17". (Don't forget to update BIOS, by the way.)

    Because you also need to disable discrete GPU in BIOS or by
    Code:
    echo "OFF" > /sys/kernel/debug/vgaswitcheroo/switch
    Answer for this question is here: http://support.amd.com/us/Processor_TechDocs/41131.pdf (2.5.3.1.1)

    So boosted P-states (up to 2.4 GHz) is here, works (check CPB here /sys/devices/system/cpu/cpuN/cpufreq/cpb), you just doesn't see it. To see it use cpufreq-aperf or cpupowerutils (run "cpupower monitor").
    AFAIK it happen automatically. See 2.5.3.2.3.2 for details.
    It doesn't make sense: http://mjg59.livejournal.com/88608.html
    I would like to know answer for this too: https://bugzilla.kernel.org/show_bug.cgi?id=43114
    THANK YOU very much!!!
    It didn't occur to me that it had both GPUs powered on and sucking battery. In fact, it didn't even register with me that it has two!!!
    Discrete is now disabled in bios, and idle temp is just over 40 degrees.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •