Quote Originally Posted by allquixotic View Post
Fedora also has a newer kernel, newer Xorg, etc. So of course it's going to have the latest features and be the fastest.

But for once I can't use Fedora on my desktop, because I spent like 8 hours trying to fix installing Fedora in UEFI+GPT mode on my Ivy Bridge desktop, to no avail. I even tried to get some folks in #fedora to help, but everyone completely ignored my query.

Basically, I have a hardware RAID controller joining together two 4TB hard drives into an 8TB array (striped). The first three partitions are (in this order) EFI System Partition, Reserved Windows partition, and NTFS partition for Windows. Then immediately following that is another EFI System Partition, then my Linux root filesystem (ext4), then /home, then /. I tried installing Fedora 17 in this configuration and I get the "minimal BASH-like editing" prompt from GRUB, and the version of GRUB appears to be GRUB1 (wtf?). When I changed to Ubuntu 12.04, using the same partition setup but wiping out the partitions, it works like a charm. My BIOS lets me choose the boot order of the OSes and shows Windows and Ubuntu separately so I can prioritize them in the list. And I can pick one on the fly during boot-up by pressing F8.

So I'm going to act like a little baby and say that Fedora 17 sucks (for me on my current hardware; I'm a huge fan of it otherwise) because it wasn't tested with UEFI+GPT setups and appears to fail epically where Ubuntu succeeds.
You can say that if you like, but you'd be wrong:

https://fedoraproject.org/wiki/Test_...al_RC4_Install
https://fedoraproject.org/wiki/Test_...al_RC3_Install
https://fedoraproject.org/wiki/Test_...al_RC2_Install
https://fedoraproject.org/wiki/Test_...al_RC1_Install

Check the 'EFI' column. We actually test quite extensively with EFI.

The use of grub-legacy is intentional; it's less broken with EFI than grub2 is. I don't know what the problem you hit is; I'd need more data. At least the grub config and the efibootmgr entries, and ideally the anaconda logs. But it's certainly not true to say F17 isn't tested with UEFI, because it was, quite heavily. There's an issue with your specific setup, not with UEFI support in general.