Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Installation on Fedora 8

  1. #1
    Join Date
    Dec 2007
    Posts
    6

    Default Installation on Fedora 8

    I am trying to install the radeon 1.1.0 driver on my Fedora 8 x86_64 system, and can't get it to work. When I go to the source code directory (that I downloaded as a tar.gz file) and run ./configure, it tells me the following:

    checking pkg-config is at least version 0.9.0... yes
    checking for XORG... configure: error: Package requirements (xorg-server xproto fontsproto ) were not met:

    No package 'xorg-server' found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables XORG_CFLAGS
    and XORG_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.


    I can't seem to find out what package 'xorg-server' exists in. I have an ATI Radeon X1600 PCI-E card and upgraded from FC6 x86_64.

    Thanks for any help,
    Harry

  2. #2

    Default

    On Fedora you need xorg-x11-server and xorg-x11-server-sdk. RadeonHD is also available via rawhide or updates-testing, if you are interested in that route.

  3. #3
    Join Date
    Dec 2007
    Posts
    6

    Default

    Quote Originally Posted by Michael View Post
    On Fedora you need xorg-x11-server and xorg-x11-server-sdk. RadeonHD is also available via rawhide or updates-testing, if you are interested in that route.
    Here's what I have installed:

    [root@localhost xf86-video-radeonhd-1.1.0]# rpm -qa |grep xorg-x11-server
    xorg-x11-server-source-1.3.0.0-37.fc8
    xorg-x11-server-Xorg-1.3.0.0-37.fc8
    xorg-x11-server-utils-7.3-2.fc8


    What am I missing?

    Thanks,
    Harry

  4. #4

    Default

    xorg-x11-server-sdk

  5. #5
    Join Date
    Dec 2007
    Posts
    6

    Default

    Quote Originally Posted by Michael View Post
    xorg-x11-server-sdk
    OK, I got that installed and was able to compile the driver. I then modified my xorg.conf file to use "radeonhd" as the driver, but when I reboot, I still get no X. I keep getting the "Id "x" respawning too fast; disabling for 5 minutes" errors. /var/log/messages and /var/log/Xorg.0.log don't show any errors.

    Also, I see when the PC boots up that one of the services that is being started is the fglrx one. I think that's due to the livna drivers. Should I removed those? And how?

    Thanks,
    Harry

  6. #6

    Default

    Quote Originally Posted by HDevine View Post
    OK, I got that installed and was able to compile the driver. I then modified my xorg.conf file to use "radeonhd" as the driver, but when I reboot, I still get no X. I keep getting the "Id "x" respawning too fast; disabling for 5 minutes" errors. /var/log/messages and /var/log/Xorg.0.log don't show any errors.
    Not sure off hand for that problem. In your xorg.conf is Composite and AIGLX disabled?

    Quote Originally Posted by HDevine View Post
    Also, I see when the PC boots up that one of the services that is being started is the fglrx one. I think that's due to the livna drivers. Should I removed those? And how?
    That is with atieventsd. You could remove it through system-config-services, but it shouldn't be preventing radeonhd from working.

  7. #7
    Join Date
    Dec 2007
    Posts
    6

    Default

    Quote Originally Posted by Michael View Post
    Not sure off hand for that problem. In your xorg.conf is Composite and AIGLX disabled?



    That is with atieventsd. You could remove it through system-config-services, but it shouldn't be preventing radeonhd from working.
    Still no go, but I'm further. I removed the fglrx livna stuff, and the ATI drivers, then modified my xorg.conf to turn off Composite (set it to Disabled) and AIGLX. I had to modify the ModulePath in xorg.conf to be "/usr/local/lib/xorg/modules" since that's where the default make install of the radeon 1.1.0 driver puts everything.

    Now when I boot, my /var/log/Xorg.0.log says:
    (EE) Failed to load module "radeonhd" (module does not exist, 0)
    (EE) No drivers available.

    The other X components, like XInput for the mouse, etc., are loading their drivers from /usr/lib64/xorg/modules. Can I assume that I need to recompile the radeon driver to put the modules at /usr/lib64/xorg/modules? And what option in configure would I set to do that?

    Thanks,
    Harry

  8. #8

    Default

    During the ./configure process did you specify --prefix=/usr/ ?

  9. #9
    Join Date
    Dec 2007
    Posts
    6

    Default

    Quote Originally Posted by Michael View Post
    During the ./configure process did you specify --prefix=/usr/ ?
    Just recompiled doing that and still nothing. Same "Id "x" respawning too fast" errors, and the (EE) module not found error in /var/log/Xorg.0.log.

    The X server seems to be looking for the modules in /usr/lib64/xorg/modules irregardless of what ModulePath is set to in xorg.conf. I copied the 2 radeon* files from /usr/lib/xorg/modules to /usr/lib64/xorg/modules and that had no effect.

    What should I try next?

    Thanks,
    Harry

  10. #10
    Join Date
    Apr 2007
    Posts
    17

    Default

    It looks like you're trying to compile the driver yourself, but if you'd like to go the route of just installing a Fedora package for it, you can get the 1.1 version of the driver from Koji. It hasn't actually been pushed out to the repository yet, but I downloaded it earlier today and am using it right now (can't get the fglrx driver to work with my dual 3870s).

    You can check here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •