Results 1 to 10 of 33

Thread: why do the nativ linux clind of Heroes of Newearth not work with the radeon driver?

Hybrid View

  1. #1
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default why do the nativ linux clind of Heroes of Newearth not work with the radeon driver?

    hi the windows version in wine do well but the nativ linux version do not run!...

    error message:

    ass@ass-GA-790XT-USB3:~/HoN$ /home/ass/HoN/hon.sh
    warning: The VAD has been replaced by a hack pending a complete rewrite
    libGL error: failed to load driver: r600
    libGL error: Try again with LIBGL_DEBUG=verbose for more details.
    libGL error: failed to load driver: swrast
    libGL error: Try again with LIBGL_DEBUG=verbose for more details.
    K2 - Fatal Error: ARB_vertex_buffer_object not available.

  2. #2
    Join Date
    Apr 2010
    Posts
    1,946

    Default

    Quick googling reveals this is specific to all S2 games and occurs also on nvidia hardware with closed drivers of specific versions.

    "this message is not from savage2. it's from an old lib that is used by savage2 and early versions of hon."

    1) Try removing all local library versions from ./libs-x86, except these two:libfmodex.so libpng14.so.14

    2) Try fixing configuration:
    echo 'SetSave "gl_modesetting" ""' > ~/.Heroes\ of\ Newerth/game/startup.cfg

    3) Try disabling antialiasing

  3. #3
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by crazycheese View Post
    Quick googling reveals this is specific to all S2 games and occurs also on nvidia hardware with closed drivers of specific versions.

    "this message is not from savage2. it's from an old lib that is used by savage2 and early versions of hon."

    1) Try removing all local library versions from ./libs-x86, except these two:libfmodex.so libpng14.so.14
    i follow this and then i get this error message:

    ./hon-x86_64: error while loading shared libraries: libcurl.so.4: cannot open shared object file: No such file or directory

    and then i installed the libcurl3 package of my distro and now the nativ hon clind run.

    thank you very much

    but why is the HON linux support so bad that they don't fix this in there "installer" ?

  4. #4
    Join Date
    Oct 2011
    Location
    Toruń, Poland
    Posts
    160

    Default

    Quote Originally Posted by Qaridarium View Post
    i follow this and then i get this error message:

    ./hon-x86_64: error while loading shared libraries: libcurl.so.4: cannot open shared object file: No such file or directory

    and then i installed the libcurl3 package of my distro and now the nativ hon clind run.

    thank you very much

    but why is the HON linux support so bad that they don't fix this in there "installer" ?
    Go ask them. Actually, I would do it myself, but I am so lazy... Still on catalyst because of this laziness.

  5. #5
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by Hirager View Post
    Go ask them. Actually, I would do it myself, but I am so lazy... Still on catalyst because of this laziness.
    i'm banned in the HON linux-support-forum because i write about there bad linux support.

  6. #6
    Join Date
    Apr 2010
    Posts
    1,946

    Default

    Quote Originally Posted by Qaridarium View Post
    i'm banned in the HON linux-support-forum because i write about there bad linux support.
    Yes, this is what I slightly personally dislike in your posts. Its better to write how to fix, instead of complain how bad it is. Complaining alone gets nowhere. Except, you offer a lot of approaches and they are all either ignored or closed with "wontfix" / "notbug" / "worksforme".

    Btw how are framerates?

    PS
    Issue with libcurl is actually widely spread (urban terror, for example), because some developers are "brilliant" enough to link to some specific library version.
    Like "libcurl.so.3". No wonder it fails.
    The sane way, is always link to "libcurl.so", and to demand that "libcurl.so" is symlink to current "libcurl" implementation on this system.
    I think, Gentoo does this, whilst Ubuntu not.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •